scarabeus    14/08/23 10:17:39

  Modified:             icu-52.1.ebuild ChangeLog
  Added:                icu-53.1.ebuild
  Log:
  Add patch to fix time-based test. Add icu 53, should work with lo 4.2.6. 
bug#520322 and bug#506916
  
  (Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 
8EEE3BE8)

Revision  Changes    Path
1.12                 dev-libs/icu/icu-52.1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/icu/icu-52.1.ebuild?rev=1.12&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/icu/icu-52.1.ebuild?rev=1.12&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/icu/icu-52.1.ebuild?r1=1.11&r2=1.12

Index: icu-52.1.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-libs/icu/icu-52.1.ebuild,v
retrieving revision 1.11
retrieving revision 1.12
diff -u -r1.11 -r1.12
--- icu-52.1.ebuild     21 Aug 2014 10:38:58 -0000      1.11
+++ icu-52.1.ebuild     23 Aug 2014 10:17:39 -0000      1.12
@@ -1,6 +1,6 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/icu-52.1.ebuild,v 1.11 
2014/08/21 10:38:58 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/icu-52.1.ebuild,v 1.12 
2014/08/23 10:17:39 scarabeus Exp $
 
 EAPI=5
 
@@ -27,7 +27,8 @@
 
 src_prepare() {
        local variable
-
+       
+       epatch "${FILESDIR}/icu-fix-tests-depending-on-date.patch"
        epatch_user
 
        # Do not hardcode flags in icu-config and icu-*.pc files.



1.278                dev-libs/icu/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/icu/ChangeLog?rev=1.278&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/icu/ChangeLog?rev=1.278&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/icu/ChangeLog?r1=1.277&r2=1.278

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-libs/icu/ChangeLog,v
retrieving revision 1.277
retrieving revision 1.278
diff -u -r1.277 -r1.278
--- ChangeLog   21 Aug 2014 10:38:58 -0000      1.277
+++ ChangeLog   23 Aug 2014 10:17:39 -0000      1.278
@@ -1,6 +1,14 @@
 # ChangeLog for dev-libs/icu
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/ChangeLog,v 1.277 2014/08/21 
10:38:58 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/ChangeLog,v 1.278 2014/08/23 
10:17:39 scarabeus Exp $
+
+*icu-53.1 (23 Aug 2014)
+
+  23 Aug 2014; Tomáš Chvátal <scarab...@gentoo.org>
+  +files/icu-fix-tests-depending-on-date.patch, +icu-53.1.ebuild,
+  icu-52.1.ebuild:
+  Add patch to fix time-based test. Add icu 53, should work with lo 4.2.6.
+  bug#520322 and bug#506916
 
   21 Aug 2014; Agostino Sarubbo <a...@gentoo.org> icu-52.1.ebuild:
   Stable for ppc64, wrt bug #512012



1.1                  dev-libs/icu/icu-53.1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/icu/icu-53.1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/icu/icu-53.1.ebuild?rev=1.1&content-type=text/plain

Index: icu-53.1.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/icu-53.1.ebuild,v 1.1 
2014/08/23 10:17:39 scarabeus Exp $

EAPI=5

inherit eutils toolchain-funcs autotools multilib-minimal

DESCRIPTION="International Components for Unicode"
HOMEPAGE="http://www.icu-project.org/";
SRC_URI="http://download.icu-project.org/files/icu4c/${PV/_/}/icu4c-${PV//./_}-src.tgz";

LICENSE="BSD"

SLOT="0/52"

KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 
~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
IUSE="debug doc examples static-libs"

DEPEND="
        doc? (
                app-doc/doxygen[dot]
        )
"

S="${WORKDIR}/${PN}/source"

src_prepare() {
        local variable

        epatch "${FILESDIR}/icu-fix-tests-depending-on-date.patch"
        epatch_user

        # Do not hardcode flags in icu-config and icu-*.pc files.
        # https://ssl.icu-project.org/trac/ticket/6102
        for variable in CFLAGS CPPFLAGS CXXFLAGS FFLAGS LDFLAGS; do
                sed \
                        -e "/^${variable} =.*/s: *@${variable}@\( *$\)\?::" \
                        -i config/icu.pc.in \
                        -i config/Makefile.inc.in \
                        || die
        done

        # Disable renaming as it is stupind thing to do
        sed -i \
                -e "s/#define U_DISABLE_RENAMING 0/#define U_DISABLE_RENAMING 
1/" \
                common/unicode/uconfig.h || die

        # Fix linking of icudata
        sed -i \
                -e "s:LDFLAGSICUDT=-nodefaultlibs -nostdlib:LDFLAGSICUDT=:" \
                config/mh-linux || die

        # Append doxygen configuration to configure
        sed -i \
                -e 's:icudefs.mk:icudefs.mk Doxyfile:' \
                configure.ac || die
        eautoreconf
}

src_configure() {
        if tc-is-cross-compiler; then
                mkdir "${WORKDIR}"/host || die
                pushd "${WORKDIR}"/host >/dev/null || die

                CFLAGS="" CXXFLAGS="" ASFLAGS="" LDFLAGS="" \
                CC="$(tc-getBUILD_CC)" CXX="$(tc-getBUILD_CXX)" 
AR="$(tc-getBUILD_AR)" \
                RANLIB="$(tc-getBUILD_RANLIB)" LD="$(tc-getBUILD_LD)" \
                "${S}"/configure --disable-renaming --disable-debug \
                        --disable-samples --enable-static || die
                emake

                popd >/dev/null || die
        fi

        multilib-minimal_src_configure
}

multilib_src_configure() {
        local myeconfargs=(
                --disable-renaming
                --disable-samples
                $(use_enable debug)
                $(use_enable static-libs static)
        )

        multilib_is_native_abi && myeconfargs+=(
                $(use_enable examples samples)
        )
        tc-is-cross-compiler && myeconfargs+=(
                --with-cross-build="${WORKDIR}"/host
        )

        # icu tries to use clang by default
        tc-export CC CXX

        ECONF_SOURCE=${S} \
        econf "${myeconfargs[@]}"
}

multilib_src_compile() {
        default

        if multilib_is_native_abi && use doc; then
                doxygen -u Doxyfile || die
                doxygen Doxyfile || die
        fi
}

multilib_src_test() {
        # INTLTEST_OPTS: intltest options
        #   -e: Exhaustive testing
        #   -l: Reporting of memory leaks
        #   -v: Increased verbosity
        # IOTEST_OPTS: iotest options
        #   -e: Exhaustive testing
        #   -v: Increased verbosity
        # CINTLTST_OPTS: cintltst options
        #   -e: Exhaustive testing
        #   -v: Increased verbosity
        emake -j1 VERBOSE="1" check
}

multilib_src_install() {
        default

        if multilib_is_native_abi && use doc; then
                dohtml -p api -r doc/html/
        fi
}

multilib_src_install_all() {
        einstalldocs
        dohtml ../readme.html
}




Reply via email to