mgorny      15/07/01 18:27:37

  Modified:             ChangeLog
  Added:                libindicate-12.10.1-r2.ebuild
  Log:
  Combine sed calls. Fix gtk-doc install path (and incorrect nonfatal use), bug 
#551162.
  
  (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 
EFB4464E!)

Revision  Changes    Path
1.44                 dev-libs/libindicate/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/libindicate/ChangeLog?rev=1.44&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/libindicate/ChangeLog?rev=1.44&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/libindicate/ChangeLog?r1=1.43&r2=1.44

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-libs/libindicate/ChangeLog,v
retrieving revision 1.43
retrieving revision 1.44
diff -u -r1.43 -r1.44
--- ChangeLog   9 Jun 2015 14:30:10 -0000       1.43
+++ ChangeLog   1 Jul 2015 18:27:37 -0000       1.44
@@ -1,6 +1,12 @@
 # ChangeLog for dev-libs/libindicate
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libindicate/ChangeLog,v 1.43 
2015/06/09 14:30:10 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libindicate/ChangeLog,v 1.44 
2015/07/01 18:27:37 mgorny Exp $
+
+*libindicate-12.10.1-r2 (01 Jul 2015)
+
+  01 Jul 2015; Michał Górny <mgo...@gentoo.org> +libindicate-12.10.1-r2.ebuild:
+  Combine sed calls. Fix gtk-doc install path (and incorrect nonfatal use), bug
+  #551162.
 
   09 Jun 2015; Justin Lecher <j...@gentoo.org> metadata.xml:
   Updating remote-id in metadata.xml



1.1                  dev-libs/libindicate/libindicate-12.10.1-r2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/libindicate/libindicate-12.10.1-r2.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/libindicate/libindicate-12.10.1-r2.ebuild?rev=1.1&content-type=text/plain

Index: libindicate-12.10.1-r2.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/dev-libs/libindicate/libindicate-12.10.1-r2.ebuild,v 
1.1 2015/07/01 18:27:37 mgorny Exp $

EAPI=5
VALA_MIN_API_VERSION="0.16"
VALA_USE_DEPEND="vapigen"

inherit autotools eutils flag-o-matic vala

DESCRIPTION="A library to raise flags on DBus for other components of the 
desktop to pick up and visualize"
HOMEPAGE="http://launchpad.net/libindicate";
SRC_URI="http://launchpad.net/${PN}/${PV%.*}/${PV}/+download/${P}.tar.gz";

LICENSE="LGPL-2.1 LGPL-3"
SLOT="3"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
IUSE="gtk +introspection"

RESTRICT="test" # consequence of the -no-mono.patch

RDEPEND=">=dev-libs/dbus-glib-0.100
        >=dev-libs/glib-2.30
        >=dev-libs/libdbusmenu-0.6.2[introspection?]
        dev-libs/libxml2
        gtk? (
                dev-libs/libdbusmenu[gtk3]
                >=x11-libs/gtk+-3.2:3
        )
        introspection? ( >=dev-libs/gobject-introspection-1 )
        !<${CATEGORY}/${PN}-0.6.1-r201"
EAUTORECONF_DEPEND="dev-util/gtk-doc-am
        gnome-base/gnome-common"
DEPEND="${RDEPEND}
        ${EAUTORECONF_DEPEND}
        $(vala_depend)
        app-text/gnome-doc-utils
        virtual/pkgconfig"

src_prepare() {
        vala_src_prepare

        epatch "${FILESDIR}"/${PN}-0.6.1-no-mono.patch

        sed -i \
                -e "s:vapigen:vapigen-$(vala_best_api_version):" \
                -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" \
                configure.ac || die

        eautoreconf
}

src_configure() {
        append-flags -Wno-error

        # python bindings are only for GTK+-2.x
        econf \
                --disable-silent-rules \
                --disable-static \
                $(use_enable gtk) \
                $(use_enable introspection) \
                --disable-python \
                --disable-scrollkeeper \
                --with-gtk=3
}

src_install() {
        emake DESTDIR="${D}" install
        dodoc AUTHORS ChangeLog NEWS

        prune_libtool_files
}




Reply via email to