eva         15/06/23 09:44:43

  Modified:             ChangeLog
  Added:                libinput-0.18.0.ebuild
  Log:
  Version bump.
  
  (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 
C6085806)

Revision  Changes    Path
1.19                 dev-libs/libinput/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/libinput/ChangeLog?rev=1.19&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/libinput/ChangeLog?rev=1.19&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/libinput/ChangeLog?r1=1.18&r2=1.19

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-libs/libinput/ChangeLog,v
retrieving revision 1.18
retrieving revision 1.19
diff -u -r1.18 -r1.19
--- ChangeLog   23 Jun 2015 01:27:23 -0000      1.18
+++ ChangeLog   23 Jun 2015 09:44:43 -0000      1.19
@@ -1,6 +1,12 @@
 # ChangeLog for dev-libs/libinput
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libinput/ChangeLog,v 1.18 
2015/06/23 01:27:23 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libinput/ChangeLog,v 1.19 
2015/06/23 09:44:43 eva Exp $
+
+*libinput-0.18.0 (23 Jun 2015)
+
+  23 Jun 2015; Gilles Dartiguelongue <e...@gentoo.org> +libinput-0.18.0.ebuild,
+  +files/libinput-0.18.0-includes.patch:
+  Version bump.
 
 *libinput-0.13.0-r1 (23 Jun 2015)
 



1.1                  dev-libs/libinput/libinput-0.18.0.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/libinput/libinput-0.18.0.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/libinput/libinput-0.18.0.ebuild?rev=1.1&content-type=text/plain

Index: libinput-0.18.0.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-libs/libinput/libinput-0.18.0.ebuild,v 
1.1 2015/06/23 09:44:43 eva Exp $

EAPI="5"

inherit eutils udev

DESCRIPTION="Library to handle input devices in Wayland"
HOMEPAGE="http://www.freedesktop.org/wiki/Software/libinput/";
SRC_URI="http://www.freedesktop.org/software/${PN}/${P}.tar.xz";

LICENSE="MIT"
SLOT="0/10"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 
~sh ~sparc ~x86"
IUSE="test"
# Tests require write access to udev rules directory which is a no-no for live 
system.
# Other tests are just about logs, exported symbols and autotest of the test 
library.
RESTRICT="test"

RDEPEND="
        >=dev-libs/libevdev-0.4
        >=sys-libs/mtdev-1.1
        virtual/libudev
"
DEPEND="${RDEPEND}
        virtual/pkgconfig
"
#       test? (
#               >=dev-libs/check-0.9.10
#               dev-util/valgrind
#               sys-libs/libunwind )

src_prepare() {
        # Fix missing include for *stat, upstream #91069
        epatch "${FILESDIR}"/${PN}-0.18.0-includes.patch
}

src_configure() {
        # Doc handling in kinda strange but everything
        # is available in the tarball already.
        sed -e 's/^\(SUBDIRS =.*\)doc\(.*\)$/\1\2/' \
                -i Makefile.am Makefile.in || die
}

src_configure() {
        # gui can be built but will not be installed
        # building documentation silently fails with graphviz syntax errors
        econf \
                --disable-documentation \
                --disable-event-gui \
                $(use_enable test tests) \
                --with-udev-dir="$(get_udevdir)"
}

src_install() {
        emake install DESTDIR="${D}"
        dodoc -r doc/html
        prune_libtool_files
}




Reply via email to