mgorny      15/05/18 15:43:15

  Modified:             ChangeLog
  Added:                libuv-1.5.0.ebuild
  Log:
  Version bump. https://github.com/gentoo/gentoo-portage-rsync-mirror/pull/115 
by jbergstroem.
  
  (Portage version: 2.2.19/cvs/Linux x86_64, signed Manifest commit with key 
EFB4464E!)

Revision  Changes    Path
1.37                 dev-libs/libuv/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/libuv/ChangeLog?rev=1.37&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/libuv/ChangeLog?rev=1.37&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/libuv/ChangeLog?r1=1.36&r2=1.37

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-libs/libuv/ChangeLog,v
retrieving revision 1.36
retrieving revision 1.37
diff -u -r1.36 -r1.37
--- ChangeLog   5 Mar 2015 05:28:48 -0000       1.36
+++ ChangeLog   18 May 2015 15:43:15 -0000      1.37
@@ -1,6 +1,12 @@
 # ChangeLog for dev-libs/libuv
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libuv/ChangeLog,v 1.36 2015/03/05 
05:28:48 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libuv/ChangeLog,v 1.37 2015/05/18 
15:43:15 mgorny Exp $
+
+*libuv-1.5.0 (18 May 2015)
+
+  18 May 2015; Michał Górny <mgo...@gentoo.org> +libuv-1.5.0.ebuild:
+  Version bump. https://github.com/gentoo/gentoo-portage-rsync-mirror/pull/115
+  by jbergstroem.
 
 *libuv-1.1.0 (05 Mar 2015)
 



1.1                  dev-libs/libuv/libuv-1.5.0.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/libuv/libuv-1.5.0.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/libuv/libuv-1.5.0.ebuild?rev=1.1&content-type=text/plain

Index: libuv-1.5.0.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-libs/libuv/libuv-1.5.0.ebuild,v 1.1 
2015/05/18 15:43:15 mgorny Exp $

EAPI=5

inherit autotools-utils eutils multilib multilib-minimal

DESCRIPTION="Cross-platform asychronous I/O"
HOMEPAGE="https://github.com/libuv/libuv";
SRC_URI="https://github.com/libuv/libuv/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD BSD-2 ISC MIT"
SLOT="0/1"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="static-libs"

DEPEND="sys-devel/libtool
        virtual/pkgconfig[${MULTILIB_USEDEP}]"

src_prepare() {
        echo "m4_define([UV_EXTRA_AUTOMAKE_FLAGS], [serial-tests])" \
                > m4/libuv-extra-automake-flags.m4 || die

        eautoreconf
}

multilib_src_configure() {
        local myeconfargs=(
                cc_cv_cflags__g=no
                $(use_enable static-libs static)
        )
        autotools-utils_src_configure
}

multilib_src_test() {
        mkdir "${BUILD_DIR}"/test || die
        cp -pPR "${S}"/test/fixtures "${BUILD_DIR}"/test/fixtures || die
        default
}

multilib_src_install_all() {
        einstalldocs
        prune_libtool_files
}




Reply via email to