ssuominen    14/10/21 05:02:11

  Modified:             ChangeLog
  Added:                redland-1.0.17.ebuild
  Log:
  Version bump wrt #526158 by Arfrever Frehtes Taifersar Arahesis. Pass global 
MAKEOPTS="-j1" wrt #500574 pending on a proper patch for parallel building and 
install.
  
  (Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 
4868F14D)

Revision  Changes    Path
1.123                dev-libs/redland/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/redland/ChangeLog?rev=1.123&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/redland/ChangeLog?rev=1.123&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/redland/ChangeLog?r1=1.122&r2=1.123

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-libs/redland/ChangeLog,v
retrieving revision 1.122
retrieving revision 1.123
diff -u -r1.122 -r1.123
--- ChangeLog   4 Aug 2014 20:50:38 -0000       1.122
+++ ChangeLog   21 Oct 2014 05:02:11 -0000      1.123
@@ -1,6 +1,13 @@
 # ChangeLog for dev-libs/redland
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/redland/ChangeLog,v 1.122 
2014/08/04 20:50:38 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/redland/ChangeLog,v 1.123 
2014/10/21 05:02:11 ssuominen Exp $
+
+*redland-1.0.17 (21 Oct 2014)
+
+  21 Oct 2014; Samuli Suominen <ssuomi...@gentoo.org> +redland-1.0.17.ebuild:
+  Version bump wrt #526158 by Arfrever Frehtes Taifersar Arahesis. Pass global
+  MAKEOPTS="-j1" wrt #500574 pending on a proper patch for parallel building 
and
+  install.
 
   04 Aug 2014; Michał Górny <mgo...@gentoo.org> redland-1.0.16.ebuild:
   Utilize db-use.eclass to obtain proper include path & library for berkdb. 
Bugs



1.1                  dev-libs/redland/redland-1.0.17.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/redland/redland-1.0.17.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/redland/redland-1.0.17.ebuild?rev=1.1&content-type=text/plain

Index: redland-1.0.17.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-libs/redland/redland-1.0.17.ebuild,v 1.1 
2014/10/21 05:02:11 ssuominen Exp $

EAPI=5
inherit db-use libtool

DESCRIPTION="High-level interface for the Resource Description Framework"
HOMEPAGE="http://librdf.org/";
SRC_URI="http://download.librdf.org/source/${P}.tar.gz";

LICENSE="Apache-2.0 GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd 
~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos"
IUSE="berkdb iodbc mysql odbc postgres sqlite static-libs"

# NOTE: libtool is required for libltdl at runtime
RDEPEND=">=sys-devel/libtool-2.2.6b
        mysql? ( virtual/mysql )
        sqlite? ( =dev-db/sqlite-3* )
        berkdb? ( sys-libs/db )
        >=media-libs/raptor-2.0.14
        >=dev-libs/rasqal-0.9.32
        postgres? ( dev-db/postgresql-base )
        iodbc? ( dev-db/libiodbc )
        odbc? ( dev-db/unixODBC )"
DEPEND="${RDEPEND}
        virtual/pkgconfig"

MAKEOPTS="${MAKEOPTS} -j1" #500574, required for both src_compile() and 
src_install()

src_prepare() {
        elibtoolize # NOTE: this is for fbsd .so version
}

src_configure() {
        local myconf=( --without-virtuoso )
        if use iodbc; then
                myconf=( --with-virtuoso --with-iodbc --without-unixodbc )
        elif use odbc; then
                myconf=( --with-virtuoso --with-unixodbc --without-iodbc )
        fi

        if use berkdb; then
                myconf+=(
                        --with-bdb-include="$(db_includedir)"
                        --with-bdb-lib="${EPREFIX}"/usr/$(get_libdir)
                        --with-bdb-dbname="$(db_libname)"
                )
        fi

        # FIXME: upstream doesn't test with --with-threads and testsuite fails
        econf \
                $(use_enable static-libs static) \
                $(use_with berkdb bdb) \
                $(use_with mysql) \
                $(use_with sqlite) \
                $(use_with postgres postgresql) \
                --without-threads \
                --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html \
                "${myconf[@]}"
}

src_test() {
        if ! use berkdb; then
                export REDLAND_TEST_CLONING_STORAGE_TYPE=hashes
                export REDLAND_TEST_CLONING_STORAGE_NAME=test
                export 
REDLAND_TEST_CLONING_STORAGE_OPTIONS="hash-type='memory',dir='.',write='yes',new='yes',contexts='yes'"
        fi
        default
}

src_install() {
        default
        dohtml {FAQS,NEWS,README,RELEASE,TODO}.html
        find "${ED}" -name '*.la' -exec sed -i -e 
"/^dependency_libs/s:=.*:='':" {} +

        # !!! REMOVE THIS ON VERSION BUMP, see bug 468298 for proper fix !!!
        if [[ -n ${LDFLAGS} ]]; then
                sed -i \
                        -e "s:${LDFLAGS} ::g" \
                        "${ED}"/usr/$(get_libdir)/pkgconfig/${PN}.pc || die
        fi

        # http://bugs.gentoo.org/467768
        local _rdocdir=/usr/share/doc/${PF}/html/${PN}
        [[ -d ${ED}/${_rdocdir} ]] && dosym ${_rdocdir} 
/usr/share/gtk-doc/html/${PN}
}




Reply via email to