idella4     14/05/06 10:13:21

  Modified:             flask-restless-0.12.0.ebuild ChangeLog
  Added:                flask-restless-0.12.1.ebuild
  Log:
  bump; drop py2.6 add pypy support
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
0xB8072B0D)

Revision  Changes    Path
1.2                  dev-python/flask-restless/flask-restless-0.12.0.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/flask-restless/flask-restless-0.12.0.ebuild?rev=1.2&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/flask-restless/flask-restless-0.12.0.ebuild?rev=1.2&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/flask-restless/flask-restless-0.12.0.ebuild?r1=1.1&r2=1.2

Index: flask-restless-0.12.0.ebuild
===================================================================
RCS file: 
/var/cvsroot/gentoo-x86/dev-python/flask-restless/flask-restless-0.12.0.ebuild,v
retrieving revision 1.1
retrieving revision 1.2
diff -u -r1.1 -r1.2
--- flask-restless-0.12.0.ebuild        22 Nov 2013 07:13:59 -0000      1.1
+++ flask-restless-0.12.0.ebuild        6 May 2014 10:13:21 -0000       1.2
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: 
/var/cvsroot/gentoo-x86/dev-python/flask-restless/flask-restless-0.12.0.ebuild,v
 1.1 2013/11/22 07:13:59 patrick Exp $
+# $Header: 
/var/cvsroot/gentoo-x86/dev-python/flask-restless/flask-restless-0.12.0.ebuild,v
 1.2 2014/05/06 10:13:21 idella4 Exp $
 
 EAPI=5
 PYTHON_COMPAT=( python{2_6,2_7} )



1.10                 dev-python/flask-restless/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/flask-restless/ChangeLog?rev=1.10&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/flask-restless/ChangeLog?rev=1.10&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/flask-restless/ChangeLog?r1=1.9&r2=1.10

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-python/flask-restless/ChangeLog,v
retrieving revision 1.9
retrieving revision 1.10
diff -u -r1.9 -r1.10
--- ChangeLog   21 Jan 2014 04:11:19 -0000      1.9
+++ ChangeLog   6 May 2014 10:13:21 -0000       1.10
@@ -1,6 +1,12 @@
 # ChangeLog for dev-python/flask-restless
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-restless/ChangeLog,v 1.9 
2014/01/21 04:11:19 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-restless/ChangeLog,v 1.10 
2014/05/06 10:13:21 idella4 Exp $
+
+*flask-restless-0.12.1 (06 May 2014)
+
+  06 May 2014; Ian Delaney <idel...@gentoo.org> +files/mapping.patch,
+  +flask-restless-0.12.1.ebuild, flask-restless-0.12.0.ebuild:
+  bump; drop py2.6 add pypy support
 
   21 Jan 2014; Patrick Lauer <patr...@gentoo.org> 
-flask-restless-0.10.0.ebuild,
   -flask-restless-0.10.1.ebuild, -flask-restless-0.11.0-r1.ebuild:



1.1                  dev-python/flask-restless/flask-restless-0.12.1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/flask-restless/flask-restless-0.12.1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/flask-restless/flask-restless-0.12.1.ebuild?rev=1.1&content-type=text/plain

Index: flask-restless-0.12.1.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/dev-python/flask-restless/flask-restless-0.12.1.ebuild,v
 1.1 2014/05/06 10:13:21 idella4 Exp $

EAPI=5
PYTHON_COMPAT=( python2_7 pypy )

PYTHON_REQ_USE="sqlite"
inherit distutils-r1

DESCRIPTION="Flask extension for easy ReSTful API generation"
HOMEPAGE="http://packages.python.org/Flask-Restless/";
SRC_URI="https://github.com/jfinkels/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="|| ( AGPL-3 BSD )"
SLOT="0"
KEYWORDS="~amd64 ~x86"

IUSE="doc examples test"

RDEPEND=">=dev-python/flask-0.7[${PYTHON_USEDEP}]
        dev-python/flask-sqlalchemy[${PYTHON_USEDEP}]
        dev-python/sqlalchemy[${PYTHON_USEDEP}]
        dev-python/python-dateutil:0[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
        dev-python/setuptools[${PYTHON_USEDEP}]
        test? ( virtual/python-unittest2[${PYTHON_USEDEP}]
                dev-python/nose[${PYTHON_USEDEP}] )
        doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
                >=dev-python/sphinxcontrib-httpdomain-1.1.7[${PYTHON_USEDEP}]
                >=dev-python/sphinxcontrib-issuetracker-0.11[${PYTHON_USEDEP}]
                dev-python/flask-themes[${PYTHON_USEDEP}] )"

PATCHES=( "${FILESDIR}"/mapping.patch )

python_compile_all() {
        if use doc; then
                if ! "${PYTHON}" -c "import flask_restless"; then
                        eerror "flask-restless is not installed. Building of 
the docs"
                        eerror "requires flask-restless to be installed."
                        eerror "emerge with USE=-doc followed bu USE=doc"
                        die
                fi
                # Changes connect to read issues @ github
                rm -f docs/changelog.rst
                einfo "Generating html docs for ${PN}"
                PYTHONPATH=${PYTHONPATH}"${S}"/docs emake -C docs html \
                        || die "Generating html docs for ${PN} failed"
        fi
}

python_test() {
        nosetests -w tests || die "Tests failed under ${EPYTHON}"
}

python_install_all() {
        use doc && local HTML_DOCS=( docs/_build/html/. )
        use examples && local EXAMPLES=( examples/. )
        distutils-r1_python_install_all
}




Reply via email to