cardoe      14/05/17 14:42:35

  Modified:             ChangeLog
  Added:                libvirt-python-1.2.4.ebuild
  Removed:              libvirt-python-1.2.1.ebuild
                        libvirt-python-1.2.0.ebuild
  Log:
  Version bump. Remove older versions as well.
  
  (Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 
1CE396377CFE7E2B!)

Revision  Changes    Path
1.10                 dev-python/libvirt-python/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/libvirt-python/ChangeLog?rev=1.10&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/libvirt-python/ChangeLog?rev=1.10&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/libvirt-python/ChangeLog?r1=1.9&r2=1.10

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-python/libvirt-python/ChangeLog,v
retrieving revision 1.9
retrieving revision 1.10
diff -u -r1.9 -r1.10
--- ChangeLog   21 Apr 2014 08:00:18 -0000      1.9
+++ ChangeLog   17 May 2014 14:42:35 -0000      1.10
@@ -1,6 +1,12 @@
 # ChangeLog for dev-python/libvirt-python
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/libvirt-python/ChangeLog,v 1.9 
2014/04/21 08:00:18 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/libvirt-python/ChangeLog,v 1.10 
2014/05/17 14:42:35 cardoe Exp $
+
+*libvirt-python-1.2.4 (17 May 2014)
+
+  17 May 2014; Doug Goldstein <car...@gentoo.org> +libvirt-python-1.2.4.ebuild,
+  -libvirt-python-1.2.0.ebuild, -libvirt-python-1.2.1.ebuild:
+  Version bump. Remove older versions as well.
 
   21 Apr 2014; Agostino Sarubbo <a...@gentoo.org> libvirt-python-1.2.3.ebuild:
   Stable for x86, wrt bug #502232



1.1                  dev-python/libvirt-python/libvirt-python-1.2.4.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/libvirt-python/libvirt-python-1.2.4.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/libvirt-python/libvirt-python-1.2.4.ebuild?rev=1.1&content-type=text/plain

Index: libvirt-python-1.2.4.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/dev-python/libvirt-python/libvirt-python-1.2.4.ebuild,v 
1.1 2014/05/17 14:42:35 cardoe Exp $

EAPI=5

#BACKPORTS=062ad8b2

PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )

MY_P="${P/_rc/-rc}"

inherit distutils-r1

DESCRIPTION="libvirt Python bindings"
HOMEPAGE="http://www.libvirt.org";
SRC_URI="http://libvirt.org/sources/python/${MY_P}.tar.gz
        ${BACKPORTS:+
                
http://dev.gentoo.org/~cardoe/distfiles/${MY_P}-${BACKPORTS}.tar.xz}";

LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"

RDEPEND=">=app-emulation/libvirt-0.9.6:=[-python(-)]"
DEPEND="${RDEPEND}
        virtual/pkgconfig
        test? ( dev-python/lxml )"

S="${WORKDIR}/${P%_rc*}"

src_prepare() {
        [[ -n ${BACKPORTS} ]] && \
                EPATCH_FORCE=yes EPATCH_SUFFIX="patch" 
EPATCH_SOURCE="${S}/patches" \
                        epatch

        distutils-r1_src_prepare
}

python_test() {
        esetup.py test
}




Reply via email to