idella4     15/08/07 06:36:53

  Modified:             mantissa-0.8.0.ebuild ChangeLog
  Added:                mantissa-0.8.1.ebuild
  Log:
  bump; restrict test phase due to massive failure rate, issue @ upstream of 
prior version extended informing of the increase, rm stray line form prior 
version
  
  (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 
0xB8072B0D)

Revision  Changes    Path
1.3                  dev-python/mantissa/mantissa-0.8.0.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/mantissa/mantissa-0.8.0.ebuild?rev=1.3&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/mantissa/mantissa-0.8.0.ebuild?rev=1.3&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/mantissa/mantissa-0.8.0.ebuild?r1=1.2&r2=1.3

Index: mantissa-0.8.0.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-python/mantissa/mantissa-0.8.0.ebuild,v
retrieving revision 1.2
retrieving revision 1.3
diff -u -r1.2 -r1.3
--- mantissa-0.8.0.ebuild       20 Jul 2015 04:30:36 -0000      1.2
+++ mantissa-0.8.0.ebuild       7 Aug 2015 06:36:53 -0000       1.3
@@ -1,6 +1,6 @@
 # Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mantissa/mantissa-0.8.0.ebuild,v 
1.2 2015/07/20 04:30:36 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mantissa/mantissa-0.8.0.ebuild,v 
1.3 2015/08/07 06:36:53 idella4 Exp $
 
 EAPI="5"
 PYTHON_COMPAT=( python2_7 )
@@ -39,7 +39,6 @@
        einfo "A folder with required modules are absent form the source"
        einfo "All are expected to be fixed in a next release consequent to the 
bug"
        einfo "filed upstream, now expected very soon"; einfo ""
-       die "dud"
        trial xmantissa || die "tests failed with ${EPYTHON}"
 }
 



1.27                 dev-python/mantissa/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/mantissa/ChangeLog?rev=1.27&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/mantissa/ChangeLog?rev=1.27&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/mantissa/ChangeLog?r1=1.26&r2=1.27

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-python/mantissa/ChangeLog,v
retrieving revision 1.26
retrieving revision 1.27
diff -u -r1.26 -r1.27
--- ChangeLog   20 Jul 2015 04:30:36 -0000      1.26
+++ ChangeLog   7 Aug 2015 06:36:53 -0000       1.27
@@ -1,6 +1,14 @@
 # ChangeLog for dev-python/mantissa
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mantissa/ChangeLog,v 1.26 
2015/07/20 04:30:36 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mantissa/ChangeLog,v 1.27 
2015/08/07 06:36:53 idella4 Exp $
+
+*mantissa-0.8.1 (07 Aug 2015)
+
+  07 Aug 2015; Ian Delaney <idel...@gentoo.org> +mantissa-0.8.1.ebuild,
+  mantissa-0.8.0.ebuild:
+  bump; restrict test phase due to massive failure rate, issue @ upstream of
+  prior version extended informing of the increase, rm stray line form prior
+  version
 
   20 Jul 2015; Ian Delaney <idel...@gentoo.org> mantissa-0.8.0.ebuild:
   Update to msg via einfo in test phase re fixes to failures



1.1                  dev-python/mantissa/mantissa-0.8.1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/mantissa/mantissa-0.8.1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/mantissa/mantissa-0.8.1.ebuild?rev=1.1&content-type=text/plain

Index: mantissa-0.8.1.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-python/mantissa/mantissa-0.8.1.ebuild,v 
1.1 2015/08/07 06:36:53 idella4 Exp $

EAPI="5"
PYTHON_COMPAT=( python2_7 )

inherit twisted-r1

MY_PN="${PN/m/M}"
DESCRIPTION="An extensible, multi-protocol, multi-user, interactive application 
server"
HOMEPAGE="https://github.com/twisted/mantissa";
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> 
${P}.tar.gz"

KEYWORDS="~amd64 ~x86"
IUSE="test"

# https://github.com/twisted/mantissa/issues/27
# Source still missing a folder 'doc' that has required modules and
# the fail / error rate is far higher then in 0.8.0
RESTRICT="test"

RDEPEND="
        >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
        >=dev-python/axiom-0.7.0[${PYTHON_USEDEP}]
        >=dev-python/cssutils-0.9.5[${PYTHON_USEDEP}]
        virtual/python-imaging[${PYTHON_USEDEP}]
        >=dev-python/nevow-0.9.5[${PYTHON_USEDEP}]
        >=dev-python/pytz-2012j[${PYTHON_USEDEP}]
        >=dev-python/twisted-core-14.0.0[${PYTHON_USEDEP}]
        >=dev-python/twisted-mail-14.0.0[${PYTHON_USEDEP}]
        >=dev-python/twisted-conch-14.0.0[${PYTHON_USEDEP}]
        >=dev-python/vertex-0.2[${PYTHON_USEDEP}]
        dev-python/pycrypto[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
        test? ( ${RDEPEND} )"

TWISTED_PLUGINS=( axiom.plugins nevow.plugins xmantissa.plugins )

python_test() {
        # https://github.com/twisted/mantissa/issues/27

        trial xmantissa || die "tests failed with ${EPYTHON}"
}

python_install() {
        distutils-r1_python_install

        # remove foreign caches we don't want to own
        find "${D}$(python_get_sitedir)" -name 'dropin.cache' -delete || die
        # then our own one
        touch "${D}$(python_get_sitedir)"/xmantissa/plugins/dropin.cache || die
}




Reply via email to