idella4     14/06/16 11:28:07

  Modified:             ChangeLog
  Added:                numba-0.13.2.ebuild
  Log:
  bump; drop py2.6 py3.2 add py 3.4, drop redundant dep requ'd for py2.6, add 
IUSE doc for install of pdf file
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
0xB8072B0D)

Revision  Changes    Path
1.5                  dev-python/numba/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/numba/ChangeLog?rev=1.5&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/numba/ChangeLog?rev=1.5&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/numba/ChangeLog?r1=1.4&r2=1.5

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-python/numba/ChangeLog,v
retrieving revision 1.4
retrieving revision 1.5
diff -u -r1.4 -r1.5
--- ChangeLog   14 Apr 2014 17:12:37 -0000      1.4
+++ ChangeLog   16 Jun 2014 11:28:07 -0000      1.5
@@ -1,6 +1,12 @@
 # ChangeLog for dev-python/numba
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/numba/ChangeLog,v 1.4 2014/04/14 
17:12:37 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numba/ChangeLog,v 1.5 2014/06/16 
11:28:07 idella4 Exp $
+
+*numba-0.13.2 (16 Jun 2014)
+
+  16 Jun 2014; Ian Delaney <idel...@gentoo.org> +numba-0.13.2.ebuild:
+  bump; drop py2.6 py3.2 add py 3.4, drop redundant dep requ'd for py2.6, add
+  IUSE doc for install of pdf file
 
 *numba-0.13.0 (14 Apr 2014)
 



1.1                  dev-python/numba/numba-0.13.2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/numba/numba-0.13.2.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/numba/numba-0.13.2.ebuild?rev=1.1&content-type=text/plain

Index: numba-0.13.2.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-python/numba/numba-0.13.2.ebuild,v 1.1 
2014/06/16 11:28:07 idella4 Exp $

EAPI=5

PYTHON_COMPAT=( python{2_7,3_3,3_4} )

inherit distutils-r1

DESCRIPTION="NumPy aware dynamic Python compiler using LLVM"
HOMEPAGE="http://numba.pydata.org/";
SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"

IUSE="doc examples"

RDEPEND="
        dev-python/llvmpy[${PYTHON_USEDEP}]
        >=dev-python/numpy-1.6[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}"

python_compile() {
        if ! python_is_python3; then
                local CFLAGS="${CFLAGS} -fno-strict-aliasing"
                export CFLAGS
        fi
        distutils-r1_python_compile
}

python_test() {
        cd "${BUILD_DIR}"/lib* || die
        ${PYTHON} -c "import numba; numba.test()" || die
}

python_install_all() {
        # doc needs obsolete sphnxjp package
        use doc && dodoc docs/Numba.pdf
        use examples && local EXAMPLES=( examples/. )

        distutils-r1_python_install_all
}




Reply via email to