alunduil    15/07/29 21:27:45

  Modified:             ChangeLog
  Added:                pyhamcrest-1.8.5.ebuild
  Log:
  add version 1.8.5
  
  (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 
11A8217C!)

Revision  Changes    Path
1.9                  dev-python/pyhamcrest/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/pyhamcrest/ChangeLog?rev=1.9&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/pyhamcrest/ChangeLog?rev=1.9&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/pyhamcrest/ChangeLog?r1=1.8&r2=1.9

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-python/pyhamcrest/ChangeLog,v
retrieving revision 1.8
retrieving revision 1.9
diff -u -r1.8 -r1.9
--- ChangeLog   7 Jun 2015 15:28:39 -0000       1.8
+++ ChangeLog   29 Jul 2015 21:27:45 -0000      1.9
@@ -1,6 +1,11 @@
 # ChangeLog for dev-python/pyhamcrest
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyhamcrest/ChangeLog,v 1.8 
2015/06/07 15:28:39 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyhamcrest/ChangeLog,v 1.9 
2015/07/29 21:27:45 alunduil Exp $
+
+*pyhamcrest-1.8.5 (29 Jul 2015)
+
+  29 Jul 2015; Alex Brandt <alund...@gentoo.org> +pyhamcrest-1.8.5.ebuild:
+  add version 1.8.5
 
   07 Jun 2015; Justin Lecher <j...@gentoo.org> metadata.xml:
   Add github to remote-id in metadata.xml



1.1                  dev-python/pyhamcrest/pyhamcrest-1.8.5.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/pyhamcrest/pyhamcrest-1.8.5.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/pyhamcrest/pyhamcrest-1.8.5.ebuild?rev=1.1&content-type=text/plain

Index: pyhamcrest-1.8.5.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/dev-python/pyhamcrest/pyhamcrest-1.8.5.ebuild,v 1.1 
2015/07/29 21:27:45 alunduil Exp $

EAPI=5
PYTHON_COMPAT=( python2_7 python3_3 python3_4 )

inherit distutils-r1

MY_PN="PyHamcrest"

DESCRIPTION="Hamcrest framework for matcher objects"
HOMEPAGE="https://github.com/hamcrest/PyHamcrest";
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"

S="${WORKDIR}/${MY_PN}-${PV}"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
IUSE="doc examples test"

CDEPEND=">=dev-python/six-1.4[${PYTHON_USEDEP}]"
DEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
        doc? (
                >=dev-python/sphinx-1.2.2[${PYTHON_USEDEP}]
                dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
        )
        test? (
                ${CDEPEND}
                >=dev-python/pytest-2.6[${PYTHON_USEDEP}]
        )
"
RDEPEND="${CDEPEND}"

python_compile_all() {
        use doc && esetup.py build_sphinx
}

python_test() {
        py.test -v || die "Tests failed under ${EPYTHON}"
}

python_install_all() {
        use doc && local HTML_DOCS=( doc/_build/html/. )
        use examples && local EXAMPLES=( examples/. )

        distutils-r1_python_install_all
}




Reply via email to