yngwin      15/07/01 06:28:26

  Modified:             ChangeLog
  Added:                reportlab-3.2.0.ebuild
  Log:
  Version bump. No longer depend on media-fonts/dejavu (bug #405183). Acked by 
patrick.
  
  (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 
0x4FDF9CFD2FAC514E!)

Revision  Changes    Path
1.134                dev-python/reportlab/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/reportlab/ChangeLog?rev=1.134&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/reportlab/ChangeLog?rev=1.134&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/reportlab/ChangeLog?r1=1.133&r2=1.134

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-python/reportlab/ChangeLog,v
retrieving revision 1.133
retrieving revision 1.134
diff -u -r1.133 -r1.134
--- ChangeLog   11 Jun 2015 19:18:54 -0000      1.133
+++ ChangeLog   1 Jul 2015 06:28:26 -0000       1.134
@@ -1,6 +1,12 @@
 # ChangeLog for dev-python/reportlab
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/reportlab/ChangeLog,v 1.133 
2015/06/11 19:18:54 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/reportlab/ChangeLog,v 1.134 
2015/07/01 06:28:26 yngwin Exp $
+
+*reportlab-3.2.0 (01 Jul 2015)
+
+  01 Jul 2015; Ben de Groot <yng...@gentoo.org> +reportlab-3.2.0.ebuild:
+  Version bump. No longer depend on media-fonts/dejavu (bug #405183). Acked by
+  patrick.
 
   11 Jun 2015; Markus Meier <mae...@gentoo.org> reportlab-3.1.44-r1.ebuild:
   arm stable, bug #546810



1.1                  dev-python/reportlab/reportlab-3.2.0.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/reportlab/reportlab-3.2.0.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/reportlab/reportlab-3.2.0.ebuild?rev=1.1&content-type=text/plain

Index: reportlab-3.2.0.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/dev-python/reportlab/reportlab-3.2.0.ebuild,v 1.1 
2015/07/01 06:28:26 yngwin Exp $

EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} ) # Tests crash with pypy
inherit distutils-r1 flag-o-matic prefix

DESCRIPTION="Tools for generating printable PDF documents from any data source"
HOMEPAGE="http://www.reportlab.com/";
SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz
        http://www.reportlab.com/ftp/fonts/pfbfer-20070710.zip";

LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd 
~amd64-linux ~x86-linux"
IUSE="doc examples"

RDEPEND="
        >=dev-python/pillow-2.4.0[tiff,truetype,${PYTHON_USEDEP}]
        >=dev-python/pip-1.4.1[${PYTHON_USEDEP}]
        >=dev-python/setuptools-2.2[${PYTHON_USEDEP}]
        media-libs/libart_lgpl
        sys-libs/zlib
"
DEPEND="${RDEPEND}
        app-arch/unzip
"

src_unpack() {
        unpack ${P}.tar.gz
        cd ${P}/src/reportlab/fonts || die
        unpack pfbfer-20070710.zip
}

python_prepare_all() {
        sed -i \
                -e 's|/usr/local/Acrobat|/opt/Acrobat|g' \
                -e 's|%(HOME)s/fonts|%(HOME)s/.fonts|g' \
                src/reportlab/rl_config.py || die

        eprefixify setup.py
        distutils-r1_python_prepare_all
}

python_compile_all() {
        use doc && emake -C docs html
}

python_compile() {
        if ! python_is_python3; then
                local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
        fi
        distutils-r1_python_compile
}

python_test() {
        pushd tests > /dev/null || die
        "${PYTHON}" runAll.py || die "Testing failed with ${EPYTHON}"
        popd > /dev/null || die
}

python_install_all() {
        use doc && local HTML_DOCS=( docs/build/html/. )
        use examples && local EXAMPLES=( demos/. tools/pythonpoint/demos )

        distutils-r1_python_install_all
}




Reply via email to