patrick     15/06/18 05:53:01

  Modified:             ChangeLog
  Added:                simpletal-5.2.ebuild
  Log:
  Bump
  
  (Portage version: 2.2.20/cvs/Linux x86_64, unsigned Manifest commit)

Revision  Changes    Path
1.14                 dev-python/simpletal/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/simpletal/ChangeLog?rev=1.14&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/simpletal/ChangeLog?rev=1.14&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/simpletal/ChangeLog?r1=1.13&r2=1.14

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-python/simpletal/ChangeLog,v
retrieving revision 1.13
retrieving revision 1.14
diff -u -r1.13 -r1.14
--- ChangeLog   9 Jan 2015 10:29:37 -0000       1.13
+++ ChangeLog   18 Jun 2015 05:53:01 -0000      1.14
@@ -1,6 +1,11 @@
 # ChangeLog for dev-python/simpletal
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/simpletal/ChangeLog,v 1.13 
2015/01/09 10:29:37 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simpletal/ChangeLog,v 1.14 
2015/06/18 05:53:01 patrick Exp $
+
+*simpletal-5.2 (18 Jun 2015)
+
+  18 Jun 2015; Patrick Lauer <patr...@gentoo.org> +simpletal-5.2.ebuild:
+  Bump
 
 *simpletal-5.1-r1 (09 Jan 2015)
 *simpletal-4.2-r1 (09 Jan 2015)



1.1                  dev-python/simpletal/simpletal-5.2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/simpletal/simpletal-5.2.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/simpletal/simpletal-5.2.ebuild?rev=1.1&content-type=text/plain

Index: simpletal-5.2.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-python/simpletal/simpletal-5.2.ebuild,v 
1.1 2015/06/18 05:53:01 patrick Exp $

EAPI=5
PYTHON_COMPAT=( python3_3 )

inherit distutils-r1

MY_PN="SimpleTAL"
MY_P="${MY_PN}-${PV}"

DESCRIPTION="Stand alone Python implementation of the Zope TAL, TALES and METAL 
specs for HTML/XML templates"
HOMEPAGE="http://www.owlfish.com/software/simpleTAL/ 
http://pypi.python.org/pypi/SimpleTAL";
SRC_URI="http://www.owlfish.com/software/simpleTAL/downloads/${MY_P}.tar.gz";

LICENSE="BSD"
SLOT="5"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
IUSE="doc examples"

DEPEND=""
RDEPEND=""

S="${WORKDIR}/${MY_P}"

python_prepare_all() {
        sed -e "s/^TEMP_DIR=.*/TEMP_DIR=os.curdir/" \
                -i tests/TALUtilsTests/TemplateCacheTestCases.py || die
        distutils-r1_python_prepare_all
}

python_test() {
        "${PYTHON}" runtests.py || die "tests failed"
}

python_install_all() {
        use doc && local HTML_DOCS=( documentation/html/. )
        use examples && local EXAMPLES=( examples/. )
        distutils-r1_python_install_all
}




Reply via email to