idella4     14/10/27 08:55:20

  Modified:             ChangeLog
  Added:                testify-0.5.6.ebuild
  Removed:              testify-0.3.5.ebuild testify-0.3.2.ebuild
                        testify-0.3.6.ebuild testify-0.3.1.ebuild
                        testify-0.3.3.ebuild testify-0.3.7.ebuild
                        testify-0.3.0.ebuild testify-0.3.4.ebuild
  Log:
  bump; rm old
  
  (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 
0xB8072B0D)

Revision  Changes    Path
1.18                 dev-python/testify/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/testify/ChangeLog?rev=1.18&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/testify/ChangeLog?rev=1.18&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/testify/ChangeLog?r1=1.17&r2=1.18

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-python/testify/ChangeLog,v
retrieving revision 1.17
retrieving revision 1.18
diff -u -r1.17 -r1.18
--- ChangeLog   15 Oct 2014 11:36:28 -0000      1.17
+++ ChangeLog   27 Oct 2014 08:55:20 -0000      1.18
@@ -1,6 +1,14 @@
 # ChangeLog for dev-python/testify
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testify/ChangeLog,v 1.17 
2014/10/15 11:36:28 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testify/ChangeLog,v 1.18 
2014/10/27 08:55:20 idella4 Exp $
+
+*testify-0.5.6 (27 Oct 2014)
+
+  27 Oct 2014; Ian Delaney <idel...@gentoo.org> +testify-0.5.6.ebuild,
+  -testify-0.3.0.ebuild, -testify-0.3.1.ebuild, -testify-0.3.2.ebuild,
+  -testify-0.3.3.ebuild, -testify-0.3.4.ebuild, -testify-0.3.5.ebuild,
+  -testify-0.3.6.ebuild, -testify-0.3.7.ebuild:
+  bump; rm old
 
 *testify-0.3.7 (15 Oct 2014)
 



1.1                  dev-python/testify/testify-0.5.6.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/testify/testify-0.5.6.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/testify/testify-0.5.6.ebuild?rev=1.1&content-type=text/plain

Index: testify-0.5.6.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-python/testify/testify-0.5.6.ebuild,v 
1.1 2014/10/27 08:55:20 idella4 Exp $

EAPI=5

# Still appears to no support >=py3.3
PYTHON_COMPAT=( python2_7 pypy )
RESTRICT="test"         # basically still very broken

inherit distutils-r1 vcs-snapshot

DESCRIPTION="A more pythonic replacement for the unittest module and nose"
HOMEPAGE="https://github.com/Yelp/testify http://pypi.python.org/pypi/testify/";
SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"

RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]
        dev-python/sqlalchemy[${PYTHON_USEDEP}]
        dev-python/mock[${PYTHON_USEDEP}]
        www-servers/tornado[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
        test? ( ${RDEPEND} )"

python_prepare_all() {
        # Correct typo in setup.py
        sed -e 's:mock,:mock:' -i setup.py || die
        distutils-r1_python_prepare_all
}

python_test() {
        # https://github.com/Yelp/Testify/issues/283
         "${PYTHON}" bin/${PN} test || die
}




Reply via email to