graaff      15/06/16 21:58:48

  Modified:             ChangeLog
  Added:                actionpack-4.2.2.ebuild
  Log:
  Version bump.
  
  (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 
0x8883FA56A308A8D7!)

Revision  Changes    Path
1.308                dev-ruby/actionpack/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/actionpack/ChangeLog?rev=1.308&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/actionpack/ChangeLog?rev=1.308&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/actionpack/ChangeLog?r1=1.307&r2=1.308

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v
retrieving revision 1.307
retrieving revision 1.308
diff -u -r1.307 -r1.308
--- ChangeLog   16 Jun 2015 21:35:36 -0000      1.307
+++ ChangeLog   16 Jun 2015 21:58:48 -0000      1.308
@@ -1,6 +1,11 @@
 # ChangeLog for dev-ruby/actionpack
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.307 
2015/06/16 21:35:36 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.308 
2015/06/16 21:58:48 graaff Exp $
+
+*actionpack-4.2.2 (16 Jun 2015)
+
+  16 Jun 2015; Hans de Graaff <gra...@gentoo.org> +actionpack-4.2.2.ebuild:
+  Version bump.
 
 *actionpack-4.1.11 (16 Jun 2015)
 



1.1                  dev-ruby/actionpack/actionpack-4.2.2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/actionpack/actionpack-4.2.2.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/actionpack/actionpack-4.2.2.ebuild?rev=1.1&content-type=text/plain

Index: actionpack-4.2.2.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/dev-ruby/actionpack/actionpack-4.2.2.ebuild,v 1.1 
2015/06/16 21:58:48 graaff Exp $

EAPI=5

USE_RUBY="ruby19 ruby20 ruby21"

RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_DOCDIR="doc"
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"

RUBY_FAKEGEM_GEMSPEC="actionpack.gemspec"

inherit ruby-fakegem versionator

DESCRIPTION="Eases web-request routing, handling, and response"
HOMEPAGE="https://github.com/rails/rails";
SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> 
rails-${PV}.tgz"

LICENSE="MIT"
SLOT="$(get_version_component_range 1-2)"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
IUSE=""

RUBY_S="rails-${PV}/${PN}"

ruby_add_rdepend "
        ~dev-ruby/activesupport-${PV}
        ~dev-ruby/actionview-${PV}
        >=dev-ruby/rack-1.6.0:1.6
        >=dev-ruby/rack-test-0.6.2:0.6
        >=dev-ruby/rails-html-sanitizer-1.0.1:1
        >=dev-ruby/rails-dom-testing-1.0.5:1
"

ruby_add_bdepend "
        test? (
                dev-ruby/mocha:0.14
                dev-ruby/bundler
                ~dev-ruby/activemodel-${PV}
                >=dev-ruby/rack-cache-1.2:1.2
        )"

all_ruby_prepare() {
        # Remove items from the common Gemfile that we don't need for this
        # test run. This also requires handling some gemspecs.
        sed -i -e 
"/\(system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|minitest\)/
 s:^:#:" \
                -e '/:job/,/end/ s:^:#:' \
                -e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
        rm ../Gemfile.lock || die
}




Reply via email to