graaff      14/05/06 18:51:15

  Modified:             ChangeLog
  Added:                activemodel-3.2.18.ebuild
  Log:
  Version bump for Rails 3.2.18, security bug 509706.
  
  (Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 
0x8883FA56A308A8D7!)

Revision  Changes    Path
1.76                 dev-ruby/activemodel/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/activemodel/ChangeLog?rev=1.76&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/activemodel/ChangeLog?rev=1.76&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/activemodel/ChangeLog?r1=1.75&r2=1.76

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v
retrieving revision 1.75
retrieving revision 1.76
diff -u -r1.75 -r1.76
--- ChangeLog   4 May 2014 11:30:08 -0000       1.75
+++ ChangeLog   6 May 2014 18:51:15 -0000       1.76
@@ -1,6 +1,11 @@
 # ChangeLog for dev-ruby/activemodel
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.75 
2014/05/04 11:30:08 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.76 
2014/05/06 18:51:15 graaff Exp $
+
+*activemodel-3.2.18 (06 May 2014)
+
+  06 May 2014; Hans de Graaff <gra...@gentoo.org> +activemodel-3.2.18.ebuild:
+  Version bump for Rails 3.2.18, security bug 509706.
 
   04 May 2014; Manuel RĂ¼ger <mr...@gentoo.org> activemodel-3.2.17.ebuild:
   Add ruby20 support to slot 3.2.



1.1                  dev-ruby/activemodel/activemodel-3.2.18.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/activemodel/activemodel-3.2.18.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/activemodel/activemodel-3.2.18.ebuild?rev=1.1&content-type=text/plain

Index: activemodel-3.2.18.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/dev-ruby/activemodel/activemodel-3.2.18.ebuild,v 1.1 
2014/05/06 18:51:15 graaff Exp $

EAPI=5

USE_RUBY="ruby19 ruby20"

RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_DOCDIR=""
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"

RUBY_FAKEGEM_GEMSPEC="activemodel.gemspec"

inherit ruby-fakegem versionator

DESCRIPTION="A toolkit for building modeling frameworks like Active Record and 
Active Resource."
HOMEPAGE="http://github.com/rails/rails";
SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"

LICENSE="MIT"
SLOT="$(get_version_component_range 1-2)"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos 
~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""

RUBY_S="rails-${PV}/${PN}"

ruby_add_rdepend "
        ~dev-ruby/activesupport-${PV}
        >=dev-ruby/builder-3.0.0:3
        >=dev-ruby/bcrypt-ruby-3.0.0"

ruby_add_bdepend "
        test? (
                dev-ruby/test-unit:2
                >=dev-ruby/mocha-0.13.0:0.13
        )"

all_ruby_prepare() {
        # Set test environment to our hand.
        rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
        sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove 
load paths"

        # Make sure we use the test-unit gem since ruby18 does not provide
        # all the test-unit features needed.
        sed -i -e '1igem "test-unit"' test/cases/helper.rb || die

        # Fix bcrypt dependency since bcrypt uses semantic versioning.
        sed -i -e '/bcrypt-ruby/ s/3.0.0/3.0/' 
lib/active_model/secure_password.rb || die
}




Reply via email to