graaff      14/05/06 20:00:10

  Modified:             ChangeLog
  Added:                activemodel-4.1.1.ebuild
  Log:
  Version bump for Rails 4.1.1, security bug 509706.
  
  (Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 
0x8883FA56A308A8D7!)

Revision  Changes    Path
1.78                 dev-ruby/activemodel/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/activemodel/ChangeLog?rev=1.78&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/activemodel/ChangeLog?rev=1.78&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/activemodel/ChangeLog?r1=1.77&r2=1.78

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v
retrieving revision 1.77
retrieving revision 1.78
diff -u -r1.77 -r1.78
--- ChangeLog   6 May 2014 19:29:30 -0000       1.77
+++ ChangeLog   6 May 2014 20:00:09 -0000       1.78
@@ -1,6 +1,11 @@
 # ChangeLog for dev-ruby/activemodel
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.77 
2014/05/06 19:29:30 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.78 
2014/05/06 20:00:09 graaff Exp $
+
+*activemodel-4.1.1 (06 May 2014)
+
+  06 May 2014; Hans de Graaff <gra...@gentoo.org> +activemodel-4.1.1.ebuild:
+  Version bump for Rails 4.1.1, security bug 509706.
 
 *activemodel-4.0.5 (06 May 2014)
 



1.1                  dev-ruby/activemodel/activemodel-4.1.1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/activemodel/activemodel-4.1.1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/activemodel/activemodel-4.1.1.ebuild?rev=1.1&content-type=text/plain

Index: activemodel-4.1.1.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/dev-ruby/activemodel/activemodel-4.1.1.ebuild,v 1.1 
2014/05/06 20:00:09 graaff Exp $

EAPI=5

USE_RUBY="ruby19 ruby20 ruby21"

RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_DOCDIR=""
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"

RUBY_FAKEGEM_GEMSPEC="activemodel.gemspec"

inherit ruby-fakegem versionator

DESCRIPTION="A toolkit for building modeling frameworks like Active Record and 
Active Resource."
HOMEPAGE="http://github.com/rails/rails";
SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"

LICENSE="MIT"
SLOT="$(get_version_component_range 1-2)"
KEYWORDS="~amd64 ~arm"
IUSE=""

RUBY_S="rails-${PV}/${PN}"

ruby_add_rdepend "
        ~dev-ruby/activesupport-${PV}
        >=dev-ruby/builder-3.1.0:3.1
"

ruby_add_bdepend "
        test? (
                >=dev-ruby/railties-4.0.0
                dev-ruby/test-unit:2
                >=dev-ruby/mocha-0.14.0:0.14
                >=dev-ruby/bcrypt-ruby-3.1.7
        )"

all_ruby_prepare() {
        # Set test environment to our hand.
        sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove 
load paths"
}




Reply via email to