graaff      14/05/06 19:30:05

  Modified:             ChangeLog
  Added:                activerecord-4.0.5.ebuild
  Log:
  Version bump for Rails 4.0.5, security bug 509706.
  
  (Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 
0x8883FA56A308A8D7!)

Revision  Changes    Path
1.265                dev-ruby/activerecord/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/activerecord/ChangeLog?rev=1.265&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/activerecord/ChangeLog?rev=1.265&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/activerecord/ChangeLog?r1=1.264&r2=1.265

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v
retrieving revision 1.264
retrieving revision 1.265
diff -u -r1.264 -r1.265
--- ChangeLog   6 May 2014 18:52:44 -0000       1.264
+++ ChangeLog   6 May 2014 19:30:05 -0000       1.265
@@ -1,6 +1,11 @@
 # ChangeLog for dev-ruby/activerecord
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.264 
2014/05/06 18:52:44 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.265 
2014/05/06 19:30:05 graaff Exp $
+
+*activerecord-4.0.5 (06 May 2014)
+
+  06 May 2014; Hans de Graaff <gra...@gentoo.org> +activerecord-4.0.5.ebuild:
+  Version bump for Rails 4.0.5, security bug 509706.
 
 *activerecord-3.2.18 (06 May 2014)
 



1.1                  dev-ruby/activerecord/activerecord-4.0.5.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/activerecord/activerecord-4.0.5.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/activerecord/activerecord-4.0.5.ebuild?rev=1.1&content-type=text/plain

Index: activerecord-4.0.5.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-4.0.5.ebuild,v 1.1 
2014/05/06 19:30:05 graaff Exp $

EAPI=5
USE_RUBY="ruby19 ruby20 ruby21"

# this is not null so that the dependencies will actually be filled
RUBY_FAKEGEM_TASK_TEST="test"

RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"

RUBY_FAKEGEM_GEMSPEC="activerecord.gemspec"

inherit ruby-fakegem versionator

DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
HOMEPAGE="http://rubyforge.org/projects/activerecord/";
SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"

LICENSE="MIT"
SLOT="$(get_version_component_range 1-2)"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="mysql postgres sqlite3"

RUBY_S="rails-${PV}/${PN}"

ruby_add_rdepend "~dev-ruby/activesupport-${PV}
        ~dev-ruby/activemodel-${PV}
        >=dev-ruby/activerecord-deprecated_finders-1.0.2:1.0
        >=dev-ruby/arel-4.0.2:4.0
        sqlite3? ( >=dev-ruby/sqlite3-1.3.5 )
        mysql? ( >=dev-ruby/mysql2-0.3.10:0.3 )
        postgres? ( >=dev-ruby/pg-0.11.0 )"

ruby_add_bdepend "
        test? (
                dev-ruby/bundler
                ~dev-ruby/actionpack-${PV}
                >=dev-ruby/sqlite3-1.3.5
                dev-ruby/mocha:0.13
        )"

all_ruby_prepare() {
        # Remove items from the common Gemfile that we don't need for this
        # test run. This also requires handling some gemspecs.
        sed -i -e 
"/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|redcarpet\)/d"
 ../Gemfile || die
        sed -i -e '/rack-ssl/d' -e 's/~> 3.4/>= 3.4/' 
../railties/railties.gemspec || die
        sed -i -e '/mail/d' ../actionmailer/actionmailer.gemspec || die

        sed -i -e '/bcrypt/ s/3.0.0/3.0/' ../Gemfile || die

        # Add back json in the Gemfile because we dropped some dependencies
        # earlier that implicitly required it.
        sed -i -e '$agem "json"' ../Gemfile || die

        # Avoid test depending on mysql adapter which we don't support for
        # this Rails version to simplify our dependencies.
        rm test/cases/connection_specification/resolver_test.rb || die

        # Avoid single test using mysql dependencies.
        rm test/cases/invalid_connection_test.rb || die

        # Avoid test depending on specific sqlite3 binding or database version.
        sed -i -e '/test_uniqueness_violations_are_translated/,/^    end/ 
s:^:#:' test/cases/adapter_test.rb || die
}

each_ruby_test() {
        case ${RUBY} in
                *jruby)
                        ;;
                *rubyee18)
                        # Turn on travis support to avoid tripping bugs in 
ree18.
                        TRAVIS=true ${RUBY} -S rake test_sqlite3
                        ;;
                *)
                        if use sqlite3; then
                                ${RUBY} -S rake test_sqlite3 || die "sqlite3 
tests failed"
                        fi
                        ;;
        esac
}




Reply via email to