graaff      15/06/16 19:59:15

  Modified:             ChangeLog
  Added:                rack-1.5.4.ebuild rack-1.6.2.ebuild
                        rack-1.5.4-r1.ebuild
  Log:
  Version bump for security bug 552324.
  
  (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 
0x8883FA56A308A8D7!)

Revision  Changes    Path
1.145                dev-ruby/rack/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/rack/ChangeLog?rev=1.145&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/rack/ChangeLog?rev=1.145&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/rack/ChangeLog?r1=1.144&r2=1.145

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-ruby/rack/ChangeLog,v
retrieving revision 1.144
retrieving revision 1.145
diff -u -r1.144 -r1.145
--- ChangeLog   7 May 2015 05:58:42 -0000       1.144
+++ ChangeLog   16 Jun 2015 19:59:15 -0000      1.145
@@ -1,6 +1,14 @@
 # ChangeLog for dev-ruby/rack
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/ChangeLog,v 1.144 2015/05/07 
05:58:42 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/ChangeLog,v 1.145 2015/06/16 
19:59:15 graaff Exp $
+
+*rack-1.6.2 (16 Jun 2015)
+*rack-1.5.4-r1 (16 Jun 2015)
+*rack-1.5.4 (16 Jun 2015)
+
+  16 Jun 2015; Hans de Graaff <gra...@gentoo.org> +rack-1.5.4.ebuild,
+  +rack-1.5.4-r1.ebuild, +rack-1.6.2.ebuild:
+  Version bump for security bug 552324.
 
 *rack-1.5.3 (07 May 2015)
 



1.1                  dev-ruby/rack/rack-1.5.4.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/rack/rack-1.5.4.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/rack/rack-1.5.4.ebuild?rev=1.1&content-type=text/plain

Index: rack-1.5.4.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/rack-1.5.4.ebuild,v 1.1 
2015/06/16 19:59:15 graaff Exp $

EAPI=5
USE_RUBY="ruby19 ruby20"

RUBY_FAKEGEM_DOCDIR="doc"
RUBY_FAKEGEM_EXTRADOC="KNOWN-ISSUES README.rdoc SPEC"

RUBY_FAKEGEM_BINWRAP=""

inherit ruby-fakegem eutils versionator

DESCRIPTION="A modular Ruby webserver interface"
HOMEPAGE="http://rack.github.com/";

LICENSE="MIT"
SLOT="$(get_version_component_range 1-2)"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd 
~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris 
~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""

RUBY_PATCHES=( ${PN}-1.2.1-gentoo.patch )

ruby_add_rdepend "virtual/ruby-ssl"

# The gem has automagic dependencies over mongrel, ruby-openid,
# memcache-client, thin, mongrel and camping; not sure if we should
# make them dependencies at all.
ruby_add_bdepend "test? ( dev-ruby/bacon )"

# Block against versions in older slots that also try to install a binary.
RDEPEND="${RDEPEND} !<dev-ruby/rack-1.4.5-r1:1.4"

each_ruby_test() {
        # Since the Rakefile calls specrb directly rather than loading it, we
        # cannot use it to launch the tests or only the currently-selected
        # RUBY interpreter will be tested.
        ${RUBY} -S bacon -Ilib -w -a \
                -q -t 
'^(?!Rack::Handler|Rack::Adapter|Rack::Session::Memcache|Rack::Server)' \
                || die "test failed for ${RUBY}"
}



1.1                  dev-ruby/rack/rack-1.6.2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/rack/rack-1.6.2.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/rack/rack-1.6.2.ebuild?rev=1.1&content-type=text/plain

Index: rack-1.6.2.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/rack-1.6.2.ebuild,v 1.1 
2015/06/16 19:59:15 graaff Exp $

EAPI=5
USE_RUBY="ruby19 ruby20 ruby21 ruby22"

RUBY_FAKEGEM_DOCDIR="doc"
RUBY_FAKEGEM_EXTRADOC="HISTORY.md KNOWN-ISSUES README.rdoc SPEC"

inherit ruby-fakegem eutils versionator

DESCRIPTION="A modular Ruby webserver interface"
HOMEPAGE="http://rack.github.com/";

LICENSE="MIT"
SLOT="$(get_version_component_range 1-2)"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd 
~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris 
~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""

RUBY_PATCHES=( ${PN}-1.2.1-gentoo.patch )

ruby_add_rdepend "virtual/ruby-ssl"

# The gem has automagic dependencies over mongrel, ruby-openid,
# memcache-client, thin, mongrel and camping; not sure if we should
# make them dependencies at all.
ruby_add_bdepend "test? ( dev-ruby/bacon )"

# Block against versions in older slots that also try to install a binary.
RDEPEND="${RDEPEND} !<dev-ruby/rack-1.4.5-r1:1.4 !<dev-ruby/rack-1.5.2-r4:1.5"

all_ruby_prepare() {
        # The build system tries to generate the ChangeLog from git. Create
        # an empty file to avoid a needless dependency on git.
        touch ChangeLog || die
}

each_ruby_test() {
        # Since the Rakefile calls specrb directly rather than loading it, we
        # cannot use it to launch the tests or only the currently-selected
        # RUBY interpreter will be tested.
        ${RUBY} -S bacon -Ilib -w -a \
                -q -t 
'^(?!Rack::Handler|Rack::Adapter|Rack::Session::Memcache|Rack::Server)' \
                || die "test failed for ${RUBY}"
}



1.1                  dev-ruby/rack/rack-1.5.4-r1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/rack/rack-1.5.4-r1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/rack/rack-1.5.4-r1.ebuild?rev=1.1&content-type=text/plain

Index: rack-1.5.4-r1.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/rack-1.5.4-r1.ebuild,v 1.1 
2015/06/16 19:59:15 graaff Exp $

EAPI=5
USE_RUBY="ruby19 ruby20 ruby21 ruby22"

RUBY_FAKEGEM_DOCDIR="doc"
RUBY_FAKEGEM_EXTRADOC="KNOWN-ISSUES README.rdoc SPEC"

RUBY_FAKEGEM_BINWRAP=""

inherit ruby-fakegem eutils versionator

DESCRIPTION="A modular Ruby webserver interface"
HOMEPAGE="http://rack.github.com/";

LICENSE="MIT"
SLOT="$(get_version_component_range 1-2)"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd 
~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris 
~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""

RUBY_PATCHES=( ${PN}-1.2.1-gentoo.patch )

ruby_add_rdepend "virtual/ruby-ssl"

# The gem has automagic dependencies over mongrel, ruby-openid,
# memcache-client, thin, mongrel and camping; not sure if we should
# make them dependencies at all.
ruby_add_bdepend "test? ( dev-ruby/bacon )"

# Block against versions in older slots that also try to install a binary.
RDEPEND="${RDEPEND} !<dev-ruby/rack-1.4.5-r1:1.4"

each_ruby_test() {
        # Since the Rakefile calls specrb directly rather than loading it, we
        # cannot use it to launch the tests or only the currently-selected
        # RUBY interpreter will be tested.
        ${RUBY} -S bacon -Ilib -w -a \
                -q -t 
'^(?!Rack::Handler|Rack::Adapter|Rack::Session::Memcache|Rack::Server)' \
                || die "test failed for ${RUBY}"
}




Reply via email to