graaff      15/06/28 06:00:17

  Modified:             ChangeLog
  Added:                rspec-expectations-3.3.0.ebuild
  Log:
  Version bump.
  
  (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 
0x8883FA56A308A8D7!)

Revision  Changes    Path
1.90                 dev-ruby/rspec-expectations/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/rspec-expectations/ChangeLog?rev=1.90&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/rspec-expectations/ChangeLog?rev=1.90&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/rspec-expectations/ChangeLog?r1=1.89&r2=1.90

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/ChangeLog,v
retrieving revision 1.89
retrieving revision 1.90
diff -u -r1.89 -r1.90
--- ChangeLog   7 Jun 2015 19:31:15 -0000       1.89
+++ ChangeLog   28 Jun 2015 06:00:17 -0000      1.90
@@ -1,6 +1,12 @@
 # ChangeLog for dev-ruby/rspec-expectations
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/ChangeLog,v 
1.89 2015/06/07 19:31:15 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/ChangeLog,v 
1.90 2015/06/28 06:00:17 graaff Exp $
+
+*rspec-expectations-3.3.0 (28 Jun 2015)
+
+  28 Jun 2015; Hans de Graaff <gra...@gentoo.org>
+  +rspec-expectations-3.3.0.ebuild:
+  Version bump.
 
   07 Jun 2015; Justin Lecher <j...@gentoo.org> metadata.xml:
   Add github to remote-id in metadata.xml



1.1                  dev-ruby/rspec-expectations/rspec-expectations-3.3.0.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/rspec-expectations/rspec-expectations-3.3.0.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/rspec-expectations/rspec-expectations-3.3.0.ebuild?rev=1.1&content-type=text/plain

Index: rspec-expectations-3.3.0.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/rspec-expectations-3.3.0.ebuild,v
 1.1 2015/06/28 06:00:17 graaff Exp $

EAPI=5
USE_RUBY="ruby19 ruby20 ruby21 ruby22"

RUBY_FAKEGEM_RECIPE_TEST="rspec3"

RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"

RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"

inherit ruby-fakegem

DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
HOMEPAGE="https://github.com/rspec/rspec-expectations";
SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"

LICENSE="MIT"
SLOT="3"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd 
~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris 
~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""

SUBVERSION="$(get_version_component_range 1-2)"

ruby_add_rdepend ">=dev-ruby/diff-lcs-1.2.0 <dev-ruby/diff-lcs-2
        =dev-ruby/rspec-support-${SUBVERSION}*"

ruby_add_bdepend "test? (
                >=dev-ruby/rspec-mocks-3.2.0:3
        )"

all_ruby_prepare() {
        # Don't set up bundler: it doesn't understand our setup.
        sed -i -e '/[Bb]undler/d' Rakefile || die

        # Remove the Gemfile to avoid running through 'bundle exec'
        rm Gemfile || die

        # fix up the gemspecs
        sed -i \
                -e '/git ls/d' \
                -e '/add_development_dependency/d' \
                "${RUBY_FAKEGEM_GEMSPEC}" || die

        #
        sed -i -e '1irequire "spec_helper"' 
spec/rspec/expectations/configuration_spec.rb || die

        # Avoid a weird, and failing, test testing already installed code.
        sed -e '/has an up-to-date caller_filter file/,/end/ s:^:#:' -i 
spec/rspec/expectations_spec.rb || die
}

each_ruby_prepare() {
        case ${RUBY} in
                *ruby22)
                        # The rubygems version bundled with ruby 2.2 causes 
warnings.
                        sed -i -e '/a library that issues no warnings when 
loaded/,/^  end/ s:^:#:' spec/rspec/expectations_spec.rb || die
                        ;;
        esac
}




Reply via email to