kensington    15/05/28 19:08:02

  Modified:             metadata.xml cmake-3.2.2.ebuild cmake-3.2.1.ebuild
                        ChangeLog
  Log:
  Replace internal-jsoncpp USE flag with system-jsoncpp to ensure that an 
initial install will succeed without user interaction.
  
  (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 
0x06B1F38DCA45A1EC!)

Revision  Changes    Path
1.6                  dev-util/cmake/metadata.xml

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-util/cmake/metadata.xml?rev=1.6&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-util/cmake/metadata.xml?rev=1.6&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-util/cmake/metadata.xml?r1=1.5&r2=1.6

Index: metadata.xml
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-util/cmake/metadata.xml,v
retrieving revision 1.5
retrieving revision 1.6
diff -u -r1.5 -r1.6
--- metadata.xml        14 Apr 2015 07:42:24 -0000      1.5
+++ metadata.xml        28 May 2015 19:08:02 -0000      1.6
@@ -3,6 +3,6 @@
 <pkgmetadata>
        <herd>kde</herd>
        <use>
-               <flag name='internal-jsoncpp'>Use bundled copy of 
<pkg>dev-libs/jsoncpp</pkg>. Enable this in order solve the circular dependency 
between cmake and jsoncpp, disable afterwards.</flag>
+               <flag name="system-jsoncpp">Use system copy of 
<pkg>dev-libs/jsoncpp</pkg> instead of bundled one.</flag>
        </use>
 </pkgmetadata>



1.3                  dev-util/cmake/cmake-3.2.2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-util/cmake/cmake-3.2.2.ebuild?rev=1.3&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-util/cmake/cmake-3.2.2.ebuild?rev=1.3&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-util/cmake/cmake-3.2.2.ebuild?r1=1.2&r2=1.3

Index: cmake-3.2.2.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-3.2.2.ebuild,v
retrieving revision 1.2
retrieving revision 1.3
diff -u -r1.2 -r1.3
--- cmake-3.2.2.ebuild  15 May 2015 00:50:07 -0000      1.2
+++ cmake-3.2.2.ebuild  28 May 2015 19:08:02 -0000      1.3
@@ -1,6 +1,6 @@
 # Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-3.2.2.ebuild,v 1.2 
2015/05/15 00:50:07 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-3.2.2.ebuild,v 1.3 
2015/05/28 19:08:02 kensington Exp $
 
 EAPI=5
 
@@ -14,7 +14,7 @@
 LICENSE="CMake"
 SLOT="0"
 KEYWORDS="~amd64 ~arm ~arm64 ~m68k ~mips ~s390 ~sh ~x86 ~amd64-fbsd 
~sparc-fbsd ~x86-fbsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux 
~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris 
~x64-solaris ~x86-solaris"
-IUSE="doc emacs internal-jsoncpp ncurses qt4 qt5"
+IUSE="doc emacs system-jsoncpp ncurses qt4 qt5"
 
 REQUIRED_USE="?? ( qt4 qt5 )"
 
@@ -35,7 +35,7 @@
                dev-qt/qtgui:5
                dev-qt/qtwidgets:5
        )
-       !internal-jsoncpp? ( >=dev-libs/jsoncpp-0.6.0_rc2:0= )
+       system-jsoncpp? ( >=dev-libs/jsoncpp-0.6.0_rc2:0= )
 "
 DEPEND="${RDEPEND}
        doc? ( dev-python/sphinx )
@@ -133,7 +133,7 @@
 src_configure() {
        local mycmakeargs=(
                -DCMAKE_USE_SYSTEM_LIBRARIES=ON
-               $(cmake-utils_useno internal-jsoncpp 
CMAKE_USE_SYSTEM_LIBRARY_JSONCPP)
+               -DCMAKE_USE_SYSTEM_LIBRARY_JSONCPP=$(usex system-jsoncpp)
                -DCMAKE_INSTALL_PREFIX="${EPREFIX}"/usr
                -DCMAKE_DOC_DIR=/share/doc/${PF}
                -DCMAKE_MAN_DIR=/share/man



1.5                  dev-util/cmake/cmake-3.2.1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-util/cmake/cmake-3.2.1.ebuild?rev=1.5&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-util/cmake/cmake-3.2.1.ebuild?rev=1.5&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-util/cmake/cmake-3.2.1.ebuild?r1=1.4&r2=1.5

Index: cmake-3.2.1.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-3.2.1.ebuild,v
retrieving revision 1.4
retrieving revision 1.5
diff -u -r1.4 -r1.5
--- cmake-3.2.1.ebuild  15 May 2015 00:50:07 -0000      1.4
+++ cmake-3.2.1.ebuild  28 May 2015 19:08:02 -0000      1.5
@@ -1,6 +1,6 @@
 # Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-3.2.1.ebuild,v 1.4 
2015/05/15 00:50:07 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-3.2.1.ebuild,v 1.5 
2015/05/28 19:08:02 kensington Exp $
 
 EAPI=5
 
@@ -14,7 +14,7 @@
 LICENSE="CMake"
 SLOT="0"
 KEYWORDS="~amd64 ~arm ~arm64 ~m68k ~mips ~s390 ~sh ~x86 ~amd64-fbsd 
~sparc-fbsd ~x86-fbsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux 
~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris 
~x64-solaris ~x86-solaris"
-IUSE="doc emacs internal-jsoncpp ncurses qt4 qt5"
+IUSE="doc emacs system-jsoncpp ncurses qt4 qt5"
 
 REQUIRED_USE="?? ( qt4 qt5 )"
 
@@ -35,7 +35,7 @@
                dev-qt/qtgui:5
                dev-qt/qtwidgets:5
        )
-       !internal-jsoncpp? ( >=dev-libs/jsoncpp-0.6.0_rc2:0= )
+       system-jsoncpp? ( >=dev-libs/jsoncpp-0.6.0_rc2:0= )
 "
 DEPEND="${RDEPEND}
        doc? ( dev-python/sphinx )
@@ -133,7 +133,7 @@
 src_configure() {
        local mycmakeargs=(
                -DCMAKE_USE_SYSTEM_LIBRARIES=ON
-               $(cmake-utils_useno internal-jsoncpp 
CMAKE_USE_SYSTEM_LIBRARY_JSONCPP)
+               -DCMAKE_USE_SYSTEM_LIBRARY_JSONCPP=$(usex system-jsoncpp)
                -DCMAKE_INSTALL_PREFIX="${EPREFIX}"/usr
                -DCMAKE_DOC_DIR=/share/doc/${PF}
                -DCMAKE_MAN_DIR=/share/man



1.307                dev-util/cmake/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-util/cmake/ChangeLog?rev=1.307&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-util/cmake/ChangeLog?rev=1.307&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-util/cmake/ChangeLog?r1=1.306&r2=1.307

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v
retrieving revision 1.306
retrieving revision 1.307
diff -u -r1.306 -r1.307
--- ChangeLog   15 May 2015 00:50:07 -0000      1.306
+++ ChangeLog   28 May 2015 19:08:02 -0000      1.307
@@ -1,6 +1,11 @@
 # ChangeLog for dev-util/cmake
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.306 2015/05/15 
00:50:07 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.307 2015/05/28 
19:08:02 kensington Exp $
+
+  28 May 2015; Michael Palimaka <kensing...@gentoo.org> cmake-3.2.1.ebuild,
+  cmake-3.2.2.ebuild, metadata.xml:
+  Replace internal-jsoncpp USE flag with system-jsoncpp to ensure that an
+  initial install will succeed without user interaction.
 
   15 May 2015; Mike Gilbert <flop...@gentoo.org> cmake-3.2.1.ebuild,
   cmake-3.2.2.ebuild:




Reply via email to