patrick     14/07/09 08:15:04

  Modified:             ChangeLog
  Added:                scons-2.3.2.ebuild
  Log:
  Bump
  
  (Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)

Revision  Changes    Path
1.152                dev-util/scons/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-util/scons/ChangeLog?rev=1.152&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-util/scons/ChangeLog?rev=1.152&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-util/scons/ChangeLog?r1=1.151&r2=1.152

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-util/scons/ChangeLog,v
retrieving revision 1.151
retrieving revision 1.152
diff -u -r1.151 -r1.152
--- ChangeLog   10 Jun 2014 00:48:55 -0000      1.151
+++ ChangeLog   9 Jul 2014 08:15:04 -0000       1.152
@@ -1,6 +1,11 @@
 # ChangeLog for dev-util/scons
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/ChangeLog,v 1.151 2014/06/10 
00:48:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/ChangeLog,v 1.152 2014/07/09 
08:15:04 patrick Exp $
+
+*scons-2.3.2 (09 Jul 2014)
+
+  09 Jul 2014; Patrick Lauer <patr...@gentoo.org> +scons-2.3.2.ebuild:
+  Bump
 
   10 Jun 2014; Mike Frysinger <vap...@gentoo.org> scons-2.3.0.ebuild:
   Mark arm64/m68k/s390/sh stable.



1.1                  dev-util/scons/scons-2.3.2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-util/scons/scons-2.3.2.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-util/scons/scons-2.3.2.ebuild?rev=1.1&content-type=text/plain

Index: scons-2.3.2.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/scons-2.3.2.ebuild,v 1.1 
2014/07/09 08:15:04 patrick Exp $

EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
PYTHON_REQ_USE="threads(+)"

inherit distutils-r1

DESCRIPTION="Extensible Python-based build utility"
HOMEPAGE="http://www.scons.org/";
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
        doc? ( http://www.scons.org/doc/${PV}/PDF/${PN}-user.pdf -> 
${P}-user.pdf
               http://www.scons.org/doc/${PV}/HTML/${PN}-user.html -> 
${P}-user.html )"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 
~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos 
~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
IUSE="doc"

python_prepare_all() {
        local PATCHES=(
                "${FILESDIR}/${PN}-2.1.0-jython.patch"
        )

        # https://bugs.gentoo.org/show_bug.cgi?id=361061
        sed -i -e 
"s|/usr/local/bin:/opt/bin:/bin:/usr/bin|${EPREFIX}/usr/local/bin:${EPREFIX}/opt/bin:${EPREFIX}/bin:${EPREFIX}/usr/bin:/usr/local/bin:/opt/bin:/bin:/usr/bin|g"
 engine/SCons/Platform/posix.py || die
        # and make sure the build system doesn't "force" /usr/local/ :(
        sed -i -e "s/'darwin'/'NOWAYdarwinWAYNO'/" setup.py || die

        distutils-r1_python_prepare_all
}

python_install() {
        distutils-r1_python_install \
                --standard-lib \
                --no-version-script \
                --install-data "${EPREFIX}"/usr/share
}

python_install_all() {
        local DOCS=( {CHANGES,README,RELEASE}.txt )
        distutils-r1_python_install_all

        use doc && dodoc "${DISTDIR}"/${P}-user.{pdf,html}
}

src_install() {
        distutils-r1_src_install

        # Build system does not use build_scripts properly.
        # http://scons.tigris.org/issues/show_bug.cgi?id=2891
        python_replicate_script "${ED}"usr/bin/scons{,ign,-time}
}




Reply via email to