robbat2     14/05/28 23:44:51

  Modified:             git-9999-r1.ebuild git-9999.ebuild
                        git-9999-r3.ebuild git-9999-r2.ebuild ChangeLog
  Log:
  Port bug #507480 fix for git-prompt to 9999 builds.
  
  (Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)

Revision  Changes    Path
1.2                  dev-vcs/git/git-9999-r1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-vcs/git/git-9999-r1.ebuild?rev=1.2&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-vcs/git/git-9999-r1.ebuild?rev=1.2&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-vcs/git/git-9999-r1.ebuild?r1=1.1&r2=1.2

Index: git-9999-r1.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999-r1.ebuild,v
retrieving revision 1.1
retrieving revision 1.2
diff -p -w -b -B -u -u -r1.1 -r1.2
--- git-9999-r1.ebuild  22 Feb 2014 02:07:52 -0000      1.1
+++ git-9999-r1.ebuild  28 May 2014 23:44:51 -0000      1.2
@@ -1,6 +1,6 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999-r1.ebuild,v 1.1 
2014/02/22 02:07:52 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999-r1.ebuild,v 1.2 
2014/05/28 23:44:51 robbat2 Exp $
 
 EAPI=5
 
@@ -374,7 +374,9 @@ src_install() {
 
        newbashcomp contrib/completion/git-completion.bash ${PN}
        # Not really a bash-completion file (bug #477920)
-       dodoc contrib/completion/git-prompt.sh
+       # but still needed uncompressed (bug #507480)
+       insinto /usr/share/${PN}
+       doins contrib/completion/git-prompt.sh
 
        if use emacs ; then
                elisp-install ${PN} contrib/emacs/git.{el,elc}



1.57                 dev-vcs/git/git-9999.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-vcs/git/git-9999.ebuild?rev=1.57&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-vcs/git/git-9999.ebuild?rev=1.57&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-vcs/git/git-9999.ebuild?r1=1.56&r2=1.57

Index: git-9999.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999.ebuild,v
retrieving revision 1.56
retrieving revision 1.57
diff -p -w -b -B -u -u -r1.56 -r1.57
--- git-9999.ebuild     22 Feb 2014 02:07:52 -0000      1.56
+++ git-9999.ebuild     28 May 2014 23:44:51 -0000      1.57
@@ -1,6 +1,6 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999.ebuild,v 1.56 
2014/02/22 02:07:52 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999.ebuild,v 1.57 
2014/05/28 23:44:51 robbat2 Exp $
 
 EAPI=5
 
@@ -374,7 +374,9 @@ src_install() {
 
        newbashcomp contrib/completion/git-completion.bash ${PN}
        # Not really a bash-completion file (bug #477920)
-       dodoc contrib/completion/git-prompt.sh
+       # but still needed uncompressed (bug #507480)
+       insinto /usr/share/${PN}
+       doins contrib/completion/git-prompt.sh
 
        if use emacs ; then
                elisp-install ${PN} contrib/emacs/git.{el,elc}



1.3                  dev-vcs/git/git-9999-r3.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-vcs/git/git-9999-r3.ebuild?rev=1.3&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-vcs/git/git-9999-r3.ebuild?rev=1.3&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-vcs/git/git-9999-r3.ebuild?r1=1.2&r2=1.3

Index: git-9999-r3.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999-r3.ebuild,v
retrieving revision 1.2
retrieving revision 1.3
diff -p -w -b -B -u -u -r1.2 -r1.3
--- git-9999-r3.ebuild  25 Apr 2014 10:47:14 -0000      1.2
+++ git-9999-r3.ebuild  28 May 2014 23:44:51 -0000      1.3
@@ -1,6 +1,6 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999-r3.ebuild,v 1.2 
2014/04/25 10:47:14 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999-r3.ebuild,v 1.3 
2014/05/28 23:44:51 robbat2 Exp $
 
 EAPI=5
 
@@ -374,7 +374,9 @@ src_install() {
 
        newbashcomp contrib/completion/git-completion.bash ${PN}
        # Not really a bash-completion file (bug #477920)
-       dodoc contrib/completion/git-prompt.sh
+       # but still needed uncompressed (bug #507480)
+       insinto /usr/share/${PN}
+       doins contrib/completion/git-prompt.sh
 
        if use emacs ; then
                elisp-install ${PN} contrib/emacs/git.{el,elc}



1.2                  dev-vcs/git/git-9999-r2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-vcs/git/git-9999-r2.ebuild?rev=1.2&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-vcs/git/git-9999-r2.ebuild?rev=1.2&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-vcs/git/git-9999-r2.ebuild?r1=1.1&r2=1.2

Index: git-9999-r2.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999-r2.ebuild,v
retrieving revision 1.1
retrieving revision 1.2
diff -p -w -b -B -u -u -r1.1 -r1.2
--- git-9999-r2.ebuild  22 Feb 2014 02:07:52 -0000      1.1
+++ git-9999-r2.ebuild  28 May 2014 23:44:51 -0000      1.2
@@ -1,6 +1,6 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999-r2.ebuild,v 1.1 
2014/02/22 02:07:52 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999-r2.ebuild,v 1.2 
2014/05/28 23:44:51 robbat2 Exp $
 
 EAPI=5
 
@@ -374,7 +374,9 @@ src_install() {
 
        newbashcomp contrib/completion/git-completion.bash ${PN}
        # Not really a bash-completion file (bug #477920)
-       dodoc contrib/completion/git-prompt.sh
+       # but still needed uncompressed (bug #507480)
+       insinto /usr/share/${PN}
+       doins contrib/completion/git-prompt.sh
 
        if use emacs ; then
                elisp-install ${PN} contrib/emacs/git.{el,elc}



1.261                dev-vcs/git/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-vcs/git/ChangeLog?rev=1.261&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-vcs/git/ChangeLog?rev=1.261&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-vcs/git/ChangeLog?r1=1.260&r2=1.261

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-vcs/git/ChangeLog,v
retrieving revision 1.260
retrieving revision 1.261
diff -p -w -b -B -u -u -r1.260 -r1.261
--- ChangeLog   11 May 2014 21:15:13 -0000      1.260
+++ ChangeLog   28 May 2014 23:44:51 -0000      1.261
@@ -1,6 +1,10 @@
 # ChangeLog for dev-vcs/git
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/ChangeLog,v 1.260 2014/05/11 
21:15:13 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/ChangeLog,v 1.261 2014/05/28 
23:44:51 robbat2 Exp $
+
+  28 May 2014; Robin H. Johnson <robb...@gentoo.org> git-9999-r1.ebuild,
+  git-9999-r2.ebuild, git-9999-r3.ebuild, git-9999.ebuild:
+  Port bug #507480 fix for git-prompt to 9999 builds.
 
 *git-1.9.3 (11 May 2014)
 




Reply via email to