hasufell    14/05/11 00:32:18

  Modified:             ChangeLog
  Added:                warsow-1.5.ebuild
  Log:
  version bump
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
BDEED020)

Revision  Changes    Path
1.57                 games-fps/warsow/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-fps/warsow/ChangeLog?rev=1.57&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-fps/warsow/ChangeLog?rev=1.57&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-fps/warsow/ChangeLog?r1=1.56&r2=1.57

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/games-fps/warsow/ChangeLog,v
retrieving revision 1.56
retrieving revision 1.57
diff -u -r1.56 -r1.57
--- ChangeLog   31 Dec 2013 12:38:40 -0000      1.56
+++ ChangeLog   11 May 2014 00:32:18 -0000      1.57
@@ -1,6 +1,12 @@
 # ChangeLog for games-fps/warsow
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/warsow/ChangeLog,v 1.56 
2013/12/31 12:38:40 hasufell Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/warsow/ChangeLog,v 1.57 
2014/05/11 00:32:18 hasufell Exp $
+
+*warsow-1.5 (11 May 2014)
+
+  11 May 2014; Julian Ospald <hasuf...@gentoo.org> +warsow-1.5.ebuild,
+  +files/warsow-1.5-build.patch:
+  version bump
 
   31 Dec 2013; Julian Ospald <hasuf...@gentoo.org> warsow-1.03.ebuild:
   remove angelscript useflag since disabling it breaks runtime



1.1                  games-fps/warsow/warsow-1.5.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-fps/warsow/warsow-1.5.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-fps/warsow/warsow-1.5.ebuild?rev=1.1&content-type=text/plain

Index: warsow-1.5.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/games-fps/warsow/warsow-1.5.ebuild,v 1.1 
2014/05/11 00:32:18 hasufell Exp $

EAPI=5
inherit eutils check-reqs gnome2-utils flag-o-matic games

# BASE_DATA_PV=1.0
# BASE_DATA_P=${PN}_${BASE_DATA_PV}_unified
DATA_PV=15
UPDATE_P=${PN}_${DATA_PV}_update
ENGINE_PV=15
ENGINE_P=${PN}_${ENGINE_PV}_sdk

DESCRIPTION="Multiplayer FPS based on the QFusion engine (evolved from Quake 2)"
HOMEPAGE="http://www.warsow.net/";
SRC_URI="http://www.warsow.net:1337/~warsow/${PV}/${ENGINE_P}.tar.gz
        http://www.warsow.eu/warsow_${DATA_PV}_unified.tar.gz
        mirror://gentoo/warsow.png"

# ZLIB: bundled angelscript
LICENSE="GPL-2 ZLIB warsow"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug dedicated irc openal server"

RDEPEND=">=dev-libs/libRocket-1.2.1_p20130110
        media-libs/freetype
        net-misc/curl
        sys-libs/zlib
        !dedicated? (
                media-libs/libpng:0
                media-libs/libsdl
                media-libs/libtheora
                media-libs/libvorbis
                x11-libs/libX11
                x11-libs/libXinerama
                x11-libs/libXrandr
                x11-libs/libXxf86dga
                x11-libs/libXxf86vm
                virtual/jpeg
                virtual/opengl
                openal? ( media-libs/openal )
        )"
DEPEND="${RDEPEND}
        app-arch/unzip
        x11-misc/makedepend
        !dedicated? (
                x11-proto/xineramaproto
                x11-proto/xf86dgaproto
                x11-proto/xf86vidmodeproto
        )
        openal? ( virtual/pkgconfig )"

S=${WORKDIR}/source/source

CHECKREQS_DISK_BUILD="1G"
CHECKREQS_DISK_USR="500M"

src_prepare() {
        if [[ $(tc-getCC) =~ clang ]]; then
                einfo "disabling -ffast-math due to clang bug"
                einfo "http://llvm.org/bugs/show_bug.cgi?id=13745";
                append-cflags -fno-fast-math
                append-cxxflags -fno-fast-math
        fi

        sed -i \
                -e "/fs_basepath =/ s:\.:${GAMES_DATADIR}/${PN}:" \
                qcommon/files.c \
                || die "sed files.c failed"

        # edos2unix breaks whitespace files
        einfo "removing dos line breaks"
        find . -type f -exec sed -i 's/\r$//' '{}' + || die

        cd "${S}"/.. || die
        epatch "${FILESDIR}"/${PN}-1.5-build.patch \
                "${FILESDIR}"/${PN}-1.03-pic.patch
        epatch_user
}

src_compile() {
        yesno() { use ${1} && echo YES || echo NO ; }

        emake -C ../libsrcs/angelscript/sdk/angelscript/projects/gnuc

        local arch
        if use amd64 ; then
                arch=x86_64
        elif use x86 ; then
                arch=i386
        fi

        local myconf
        if use dedicated ; then
                myconf=(
                        BUILD_CLIENT=NO
                        BUILD_IRC=NO
                        BUILD_SND_OPENAL=NO
                        BUILD_SND_QF=NO
                        BUILD_CIN=NO
                        BUILD_SERVER=YES
                        BUILD_TV_SERVER=YES
                )
        else
                myconf=(
                        BUILD_CLIENT=YES
                        BUILD_IRC=$(yesno irc)
                        BUILD_SND_OPENAL=$(yesno openal)
                        BUILD_SND_QF=YES
                        BUILD_CIN=YES
                        BUILD_SERVER=$(yesno server)
                        BUILD_TV_SERVER=$(yesno server)
                )
        fi

        emake \
                V=YES \
                SYSTEM_LIBS=YES \
                BASE_ARCH=${arch} \
                BINDIR=lib \
                BUILD_ANGELWRAP=YES \
                DEBUG_BUILD=$(yesno debug) \
                ${myconf[@]}
}

src_install() {
        cd lib

        if ! use dedicated ; then
                newgamesbin ${PN}.* ${PN}
                doicon -s 48 "${DISTDIR}"/${PN}.png
                make_desktop_entry ${PN} Warsow
        fi

        if use dedicated || use server ; then
                newgamesbin wsw_server.* ${PN}-ded
                newgamesbin wswtv_server.* ${PN}-tv
        fi

        exeinto "$(games_get_libdir)"/${PN}
        doexe */*.so

        insinto "${GAMES_DATADIR}"/${PN}
        doins -r "${WORKDIR}"/${PN}_15/basewsw

        local so
        for so in basewsw/*.so ; do
                dosym "$(games_get_libdir)"/${PN}/${so##*/} \
                        "${GAMES_DATADIR}"/${PN}/${so}
        done

        if [[ -e libs ]] ; then
                dodir "${GAMES_DATADIR}"/${PN}/libs
                for so in libs/*.so ; do
                        dosym "$(games_get_libdir)"/${PN}/${so##*/} \
                                "${GAMES_DATADIR}"/${PN}/${so}
                done
        fi

        dodoc "${WORKDIR}"/${PN}_15/docs/*
        prepgamesdirs
}

pkg_preinst() {
        games_pkg_preinst
        gnome2_icon_savelist
}

pkg_postinst() {
        games_pkg_postinst
        gnome2_icon_cache_update
}

pkg_postrm() {
        gnome2_icon_cache_update
}




Reply via email to