radhermit    14/10/26 17:15:40

  Modified:             ChangeLog
  Added:                rawtherapee-4.2.ebuild
  Log:
  Version bump, define CACHE_NAME_SUFFIX to use a static config location (bug 
#523022).
  
  (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 
4AB3E85B4F064CA3)

Revision  Changes    Path
1.17                 media-gfx/rawtherapee/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-gfx/rawtherapee/ChangeLog?rev=1.17&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-gfx/rawtherapee/ChangeLog?rev=1.17&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-gfx/rawtherapee/ChangeLog?r1=1.16&r2=1.17

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/media-gfx/rawtherapee/ChangeLog,v
retrieving revision 1.16
retrieving revision 1.17
diff -u -r1.16 -r1.17
--- ChangeLog   11 Jun 2014 08:30:28 -0000      1.16
+++ ChangeLog   26 Oct 2014 17:15:39 -0000      1.17
@@ -1,6 +1,12 @@
 # ChangeLog for media-gfx/rawtherapee
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/rawtherapee/ChangeLog,v 1.16 
2014/06/11 08:30:28 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/rawtherapee/ChangeLog,v 1.17 
2014/10/26 17:15:39 radhermit Exp $
+
+*rawtherapee-4.2 (26 Oct 2014)
+
+  26 Oct 2014; Tim Harder <radher...@gentoo.org> +rawtherapee-4.2.ebuild:
+  Version bump, define CACHE_NAME_SUFFIX to use a static config location (bug
+  #523022).
 
 *rawtherapee-4.1 (11 Jun 2014)
 



1.1                  media-gfx/rawtherapee/rawtherapee-4.2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-gfx/rawtherapee/rawtherapee-4.2.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-gfx/rawtherapee/rawtherapee-4.2.ebuild?rev=1.1&content-type=text/plain

Index: rawtherapee-4.2.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/media-gfx/rawtherapee/rawtherapee-4.2.ebuild,v 1.1 
2014/10/26 17:15:39 radhermit Exp $

EAPI=5

inherit cmake-utils toolchain-funcs

DESCRIPTION="A powerful cross-platform raw image processing program"
HOMEPAGE="http://www.rawtherapee.com/";
SRC_URI="http://rawtherapee.com/shared/source/${P}.tar.xz";

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="bzip2 openmp"

RDEPEND="bzip2? ( app-arch/bzip2 )
        >=x11-libs/gtk+-2.24.18:2
        >=dev-cpp/gtkmm-2.12:2.4
        >=dev-cpp/glibmm-2.16:2
        dev-libs/expat
        dev-libs/libsigc++:2
        media-libs/libcanberra[gtk]
        media-libs/tiff
        media-libs/libpng
        media-libs/libiptcdata
        media-libs/lcms:2
        sci-libs/fftw:3.0
        sys-libs/zlib
        virtual/jpeg"
DEPEND="${RDEPEND}
        app-arch/xz-utils
        virtual/pkgconfig"

pkg_pretend() {
        if use openmp ; then
                tc-has-openmp || die "Please switch to an openmp compatible 
compiler"
        fi
}

src_configure() {
        local mycmakeargs=(
                $(cmake-utils_use openmp OPTION_OMP)
                $(cmake-utils_use_with bzip2 BZIP)
                -DDOCDIR=/usr/share/doc/${PF}
                -DCREDITSDIR=/usr/share/${PN}
                -DLICENCEDIR=/usr/share/${PN}
                -DCACHE_NAME_SUFFIX=""
        )
        cmake-utils_src_configure
}




Reply via email to