[gentoo-commits] gentoo-x86 commit in media-video/ffmpeg: ChangeLog ffmpeg-2.2.16.ebuild

2015-08-04 Thread Alexis Ballier (aballier)
aballier15/08/04 12:00:23

  Modified: ChangeLog
  Removed:  ffmpeg-2.2.16.ebuild
  Log:
  remove old
  
  (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 
160F534A)

Revision  ChangesPath
1.884media-video/ffmpeg/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-video/ffmpeg/ChangeLog?rev=1.884view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-video/ffmpeg/ChangeLog?rev=1.884content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-video/ffmpeg/ChangeLog?r1=1.883r2=1.884

Index: ChangeLog
===
RCS file: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v
retrieving revision 1.883
retrieving revision 1.884
diff -u -r1.883 -r1.884
--- ChangeLog   4 Aug 2015 11:58:28 -   1.883
+++ ChangeLog   4 Aug 2015 12:00:23 -   1.884
@@ -1,6 +1,10 @@
 # ChangeLog for media-video/ffmpeg
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.883 
2015/08/04 11:58:28 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.884 
2015/08/04 12:00:23 aballier Exp $
+
+  04 Aug 2015; Alexis Ballier aball...@gentoo.org -ffmpeg-2.2.16.ebuild,
+  -files/ladspadl.patch:
+  remove old
 
   04 Aug 2015; Alexis Ballier aball...@gentoo.org -ffmpeg-2.2.14.ebuild,
   -ffmpeg-2.7.1.ebuild:






[gentoo-commits] gentoo-x86 commit in media-video/ffmpeg: ChangeLog ffmpeg-2.2.16.ebuild

2015-06-22 Thread Alexis Ballier (aballier)
aballier15/06/22 08:15:39

  Modified: ChangeLog
  Added:ffmpeg-2.2.16.ebuild
  Log:
  version bump for 2.2 branch
  
  Signed-off-by: Alexis Ballier aball...@gentoo.org
  (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 
160F534A)

Revision  ChangesPath
1.868media-video/ffmpeg/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-video/ffmpeg/ChangeLog?rev=1.868view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-video/ffmpeg/ChangeLog?rev=1.868content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-video/ffmpeg/ChangeLog?r1=1.867r2=1.868

Index: ChangeLog
===
RCS file: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v
retrieving revision 1.867
retrieving revision 1.868
diff -u -r1.867 -r1.868
--- ChangeLog   22 Jun 2015 08:08:04 -  1.867
+++ ChangeLog   22 Jun 2015 08:15:39 -  1.868
@@ -1,6 +1,11 @@
 # ChangeLog for media-video/ffmpeg
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.867 
2015/06/22 08:08:04 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.868 
2015/06/22 08:15:39 aballier Exp $
+
+*ffmpeg-2.2.16 (22 Jun 2015)
+
+  22 Jun 2015; Alexis Ballier aball...@gentoo.org +ffmpeg-2.2.16.ebuild:
+  version bump for 2.2 branch
 
 *ffmpeg-2.7.1 (22 Jun 2015)
 



1.1  media-video/ffmpeg/ffmpeg-2.2.16.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-video/ffmpeg/ffmpeg-2.2.16.ebuild?rev=1.1view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-video/ffmpeg/ffmpeg-2.2.16.ebuild?rev=1.1content-type=text/plain

Index: ffmpeg-2.2.16.ebuild
===
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-2.2.16.ebuild,v 
1.1 2015/06/22 08:15:39 aballier Exp $

EAPI=5

# Subslot: libavutil major.libavcodec major.libavformat major
# Since FFmpeg ships several libraries, subslot is kind of limited here.
# Most consumers will use those three libraries, if a less used library
# changes its soname, consumers will have to be rebuilt the old way
# (preserve-libs).
# If, for example, a package does not link to libavformat and only libavformat
# changes its ABI then this package will be rebuilt needlessly. Hence, such a
# package is free _not_ to := depend on FFmpeg but I would strongly encourage
# doing so since such a case is unlikely.
FFMPEG_SUBSLOT=52.55.55

SCM=
if [ ${PV#} != ${PV} ] ; then
SCM=git-2
EGIT_REPO_URI=git://source.ffmpeg.org/ffmpeg.git
fi

inherit eutils flag-o-matic multilib multilib-minimal toolchain-funcs ${SCM}

DESCRIPTION=Complete solution to record, convert and stream audio and video. 
Includes libavcodec
HOMEPAGE=http://ffmpeg.org/;
if [ ${PV#} != ${PV} ] ; then
SRC_URI=
elif [ ${PV%_p*} != ${PV} ] ; then # Snapshot
SRC_URI=mirror://gentoo/${P}.tar.bz2
else # Release
SRC_URI=http://ffmpeg.org/releases/${P/_/-}.tar.bz2;
fi
FFMPEG_REVISION=${PV#*_p}

LICENSE=GPL-2 amr? ( GPL-3 ) encode? ( aac? ( GPL-3 ) )
SLOT=0/${FFMPEG_SUBSLOT}
if [ ${PV#} = ${PV} ] ; then
KEYWORDS=~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 
~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux
fi
IUSE=
aac aacplus alsa amr amrenc bluray +bzip2 cdio celt
cpudetection debug doc +encode examples faac fdk flite fontconfig frei0r
gme gnutls gsm +hardcoded-tables +iconv iec61883 ieee1394 jack 
jpeg2k
ladspa libass libcaca libsoxr libv4l modplug mp3 +network openal opengl
openssl opus oss pic pulseaudio quvi rtmp schroedinger sdl speex ssh
static-libs test theora threads truetype twolame v4l vaapi vdpau vorbis 
vpx
wavpack webp X x264 x265 xvid +zlib zvbi


ARM_CPU_FEATURES=armv5te armv6 armv6t2 neon armvfp:vfp
MIPS_CPU_FEATURES=mips32r2 mipsdspr1 mipsdspr2 mipsfpu
PPC_CPU_FEATURES=altivec
X86_CPU_FEATURES=( 3dnow:amd3dnow 3dnowext:amd3dnowext avx:avx avx2:avx2 
fma3:fma3 fma4:fma4 mmx:mmx mmxext:mmxext sse:sse sse2:sse2 sse3:sse3 
ssse3:ssse3 sse4_1:sse4 sse4_2:sse42 )

# String for CPU features in the useflag[:configure_option] form
# if :configure_option isn't set, it will use 'useflag' as configure option
CPU_FEATURES=
${ARM_CPU_FEATURES}
${MIPS_CPU_FEATURES}
${PPC_CPU_FEATURES}
${X86_CPU_FEATURES[@]/#/cpu_flags_x86_}


for i in ${CPU_FEATURES}; do
IUSE=${IUSE} ${i%:*}
done

FFTOOLS=aviocat cws2fws ffescape ffeval ffhash fourcc2pixfmt graph2dot 
ismindex pktdumper qt-faststart trasher

for i in ${FFTOOLS}; do
IUSE=${IUSE} +fftools_$i
done

RDEPEND=