jer         15/08/04 06:22:15

  Modified:             fail2ban-99999999.ebuild ChangeLog
  Added:                fail2ban-0.9.2-r1.ebuild
  Log:
  Fix bashisms and do not direct useful output to /dev/null (bug #536320). 
Remove global logrotate settings (bug #549856).
  
  (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 
A792A613)

Revision  Changes    Path
1.8                  net-analyzer/fail2ban/fail2ban-99999999.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-analyzer/fail2ban/fail2ban-99999999.ebuild?rev=1.8&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-analyzer/fail2ban/fail2ban-99999999.ebuild?rev=1.8&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-analyzer/fail2ban/fail2ban-99999999.ebuild?r1=1.7&r2=1.8

Index: fail2ban-99999999.ebuild
===================================================================
RCS file: 
/var/cvsroot/gentoo-x86/net-analyzer/fail2ban/fail2ban-99999999.ebuild,v
retrieving revision 1.7
retrieving revision 1.8
diff -u -r1.7 -r1.8
--- fail2ban-99999999.ebuild    31 Jul 2015 13:53:49 -0000      1.7
+++ fail2ban-99999999.ebuild    4 Aug 2015 06:22:14 -0000       1.8
@@ -1,12 +1,12 @@
 # Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: 
/var/cvsroot/gentoo-x86/net-analyzer/fail2ban/fail2ban-99999999.ebuild,v 1.7 
2015/07/31 13:53:49 floppym Exp $
+# $Header: 
/var/cvsroot/gentoo-x86/net-analyzer/fail2ban/fail2ban-99999999.ebuild,v 1.8 
2015/08/04 06:22:14 jer Exp $
 
 EAPI=5
 PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
 DISTUTILS_SINGLE_IMPL=1
 
-inherit distutils-r1 git-r3 systemd vcs-snapshot
+inherit distutils-r1 eutils git-r3 systemd vcs-snapshot
 
 DESCRIPTION="scans log files and bans IPs that show malicious signs"
 HOMEPAGE="http://www.fail2ban.org/";
@@ -17,7 +17,6 @@
 KEYWORDS=""
 IUSE="selinux systemd"
 
-DEPEND=""
 RDEPEND="
        net-firewall/iptables
        net-misc/whois
@@ -40,6 +39,12 @@
        # Replace /var/run with /run, but not in the top source directory
        sed -i -e 's|/var\(/run/fail2ban\)|\1|g' $( find . -type f -mindepth 2 
) || die
 
+       # Fix bashisms and do not direct useful output to /dev/null (bug 
#536320)
+       # Remove global logrotate settings (bug #549856)
+       epatch \
+               "${FILESDIR}"/${PN}-0.9.2-initd.patch \
+               "${FILESDIR}"/${PN}-0.9.2-logrotate.patch
+
        distutils-r1_src_prepare
 }
 



1.168                net-analyzer/fail2ban/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-analyzer/fail2ban/ChangeLog?rev=1.168&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-analyzer/fail2ban/ChangeLog?rev=1.168&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-analyzer/fail2ban/ChangeLog?r1=1.167&r2=1.168

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/ChangeLog,v
retrieving revision 1.167
retrieving revision 1.168
diff -u -r1.167 -r1.168
--- ChangeLog   4 Aug 2015 05:57:28 -0000       1.167
+++ ChangeLog   4 Aug 2015 06:22:14 -0000       1.168
@@ -1,6 +1,14 @@
 # ChangeLog for net-analyzer/fail2ban
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/ChangeLog,v 1.167 
2015/08/04 05:57:28 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/ChangeLog,v 1.168 
2015/08/04 06:22:14 jer Exp $
+
+*fail2ban-0.9.2-r1 (04 Aug 2015)
+
+  04 Aug 2015; Jeroen Roovers <j...@gentoo.org> +fail2ban-0.9.2-r1.ebuild,
+  fail2ban-99999999.ebuild, +files/fail2ban-0.9.2-initd.patch,
+  +files/fail2ban-0.9.2-logrotate.patch:
+  Fix bashisms and do not direct useful output to /dev/null (bug #536320).
+  Remove global logrotate settings (bug #549856).
 
   04 Aug 2015; Jeroen Roovers <j...@gentoo.org> -fail2ban-0.8.13.ebuild,
   -fail2ban-0.8.14.ebuild, -fail2ban-0.9.1.ebuild:



1.1                  net-analyzer/fail2ban/fail2ban-0.9.2-r1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-analyzer/fail2ban/fail2ban-0.9.2-r1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-analyzer/fail2ban/fail2ban-0.9.2-r1.ebuild?rev=1.1&content-type=text/plain

Index: fail2ban-0.9.2-r1.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/net-analyzer/fail2ban/fail2ban-0.9.2-r1.ebuild,v 1.1 
2015/08/04 06:22:14 jer Exp $

EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
DISTUTILS_SINGLE_IMPL=1

inherit distutils-r1 eutils systemd vcs-snapshot

DESCRIPTION="scans log files and bans IPs that show malicious signs"
HOMEPAGE="http://www.fail2ban.org/";
SRC_URI="https://github.com/${PN}/${PN}/tarball/${PV} -> ${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="selinux systemd"

RDEPEND="
        net-firewall/iptables
        net-misc/whois
        virtual/logger
        virtual/mta
        selinux? ( sec-policy/selinux-fail2ban )
        systemd? ( $(python_gen_cond_dep '|| (
                dev-python/python-systemd[${PYTHON_USEDEP}]
                sys-apps/systemd[python(-),${PYTHON_USEDEP}]
        )' 'python*' ) )
"

REQUIRED_USE="systemd? ( !python_single_target_pypy )"

DOCS=( ChangeLog DEVELOP README.md THANKS TODO doc/run-rootless.txt )

src_prepare() {
        # Replace /var/run with /run, but not in the top source directory
        sed -i -e 's|/var\(/run/fail2ban\)|\1|g' $( find . -type f -mindepth 2 
) || die

        # Fix bashisms and do not direct useful output to /dev/null (bug 
#536320)
        # Remove global logrotate settings (bug #549856)
        epatch \
                "${FILESDIR}"/${PN}-0.9.2-initd.patch \
                "${FILESDIR}"/${PN}-0.9.2-logrotate.patch

        distutils-r1_src_prepare
}

python_test() {
        ${EPYTHON} bin/${PN}-testcases
}

src_install() {
        distutils-r1_src_install

        rm -rf "${D}"/usr/share/doc/${PN}

        # not FILESDIR
        newconfd files/gentoo-confd ${PN}
        newinitd files/gentoo-initd ${PN}
        systemd_dounit files/${PN}.service
        systemd_dotmpfilesd files/${PN}-tmpfiles.conf
        doman man/*.{1,5}

        # Use INSTALL_MASK  if you do not want to touch /etc/logrotate.d.
        # See http://thread.gmane.org/gmane.linux.gentoo.devel/35675
        insinto /etc/logrotate.d
        newins files/${PN}-logrotate ${PN}
}

pkg_preinst() {
        has_version "<${CATEGORY}/${PN}-0.7"
        previous_less_than_0_7=$?
}

pkg_postinst() {
        if [[ $previous_less_than_0_7 = 0 ]] ; then
                elog
                elog "Configuration files are now in /etc/fail2ban/"
                elog "You probably have to manually update your configuration"
                elog "files before restarting Fail2ban!"
                elog
                elog "Fail2ban is not installed under /usr/lib anymore. The"
                elog "new location is under /usr/share."
                elog
                elog "You are upgrading from version 0.6.x, please see:"
                elog 
"http://www.fail2ban.org/wiki/index.php/HOWTO_Upgrade_from_0.6_to_0.8";
        fi
        if ! has_version ${CATEGORY}/${PN}; then
                if ! has_version dev-python/pyinotify && ! has_version 
app-admin/gamin; then
                        elog "For most jail.conf configurations, it is 
recommended you install either"
                        elog "dev-python/pyinotify or app-admin/gamin (in order 
of preference)"
                        elog "to control how log file modifications are 
detected"
                fi
                if ! has_version dev-lang/python[sqlite]; then
                        elog "If you want to use ${PN}'s persistent database, 
then reinstall"
                        elog "dev-lang/python with USE=sqlite"
                fi

                if has_version sys-apps/systemd[-python]; then
                        elog "If you want to track logins through 
sys-apps/systemd's"
                        elog "journal backend, then reinstall sys-apps/systemd 
with USE=python"
                fi
        fi
}




Reply via email to