tamiko      15/06/23 09:32:25

  Modified:             ChangeLog
  Added:                firewalld-0.3.14.2.ebuild
  Removed:              firewalld-0.2.12.ebuild firewalld-0.2.9-r1.ebuild
  Log:
  cleanup; version bump, thanks to Denis Schridde, bug #552832
  
  (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 
BD3A97A3)

Revision  Changes    Path
1.20                 net-firewall/firewalld/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-firewall/firewalld/ChangeLog?rev=1.20&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-firewall/firewalld/ChangeLog?rev=1.20&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-firewall/firewalld/ChangeLog?r1=1.19&r2=1.20

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/net-firewall/firewalld/ChangeLog,v
retrieving revision 1.19
retrieving revision 1.20
diff -u -r1.19 -r1.20
--- ChangeLog   27 May 2015 11:15:52 -0000      1.19
+++ ChangeLog   23 Jun 2015 09:32:25 -0000      1.20
@@ -1,6 +1,12 @@
 # ChangeLog for net-firewall/firewalld
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/firewalld/ChangeLog,v 1.19 
2015/05/27 11:15:52 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/firewalld/ChangeLog,v 1.20 
2015/06/23 09:32:25 tamiko Exp $
+
+*firewalld-0.3.14.2 (23 Jun 2015)
+
+  23 Jun 2015; Matthias Maier <tam...@gentoo.org> +firewalld-0.3.14.2.ebuild,
+  -firewalld-0.2.12.ebuild, -firewalld-0.2.9-r1.ebuild:
+  cleanup; version bump, thanks to Denis Schridde, bug #552832
 
   27 May 2015; Agostino Sarubbo <a...@gentoo.org> firewalld-0.3.10.ebuild:
   Stable for x86, wrt bug #549270



1.1                  net-firewall/firewalld/firewalld-0.3.14.2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-firewall/firewalld/firewalld-0.3.14.2.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-firewall/firewalld/firewalld-0.3.14.2.ebuild?rev=1.1&content-type=text/plain

Index: firewalld-0.3.14.2.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/net-firewall/firewalld/firewalld-0.3.14.2.ebuild,v 1.1 
2015/06/23 09:32:25 tamiko Exp $

EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
#BACKPORTS=

inherit autotools eutils gnome2-utils python-r1 systemd multilib 
bash-completion-r1

DESCRIPTION="A firewall daemon with D-BUS interface providing a dynamic 
firewall"
HOMEPAGE="http://fedorahosted.org/firewalld";
SRC_URI="https://fedorahosted.org/released/firewalld/${P}.tar.bz2
        
${BACKPORTS:+http://dev.gentoo.org/~cardoe/distfiles/${P}-${BACKPORTS}.tar.xz}";

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="gui"

RDEPEND="${PYTHON_DEPS}
        dev-python/dbus-python[${PYTHON_USEDEP}]
        dev-python/decorator[${PYTHON_USEDEP}]
        >=dev-python/python-slip-0.2.7[dbus,${PYTHON_USEDEP}]
        dev-python/pygobject:3[${PYTHON_USEDEP}]
        net-firewall/ebtables
        net-firewall/iptables[ipv6]
        || ( >=sys-apps/openrc-0.11.5 sys-apps/systemd )
        gui? ( x11-libs/gtk+:3 )"
DEPEND="${RDEPEND}
        dev-libs/glib:2
        >=dev-util/intltool-0.35
        sys-devel/gettext"

src_prepare() {
        [[ -n ${BACKPORTS} ]] && \
                EPATCH_FORCE=yes EPATCH_SUFFIX="patch" 
EPATCH_SOURCE="${S}/patches" \
                        epatch

        epatch_user
        eautoreconf
}

src_configure() {
        python_setup

        econf \
                --enable-systemd \
                "$(systemd_with_unitdir 'systemd-unitdir')" \
                --with-bashcompletiondir="$(get_bashcompdir)"
}

src_install() {
        # manually split up the installation to avoid "file already exists" 
errors
        emake -C config DESTDIR="${D}" install
        emake -C po DESTDIR="${D}" install
        emake -C shell-completion DESTDIR="${D}" install
        emake -C doc DESTDIR="${D}" install

        install_python() {
                emake -C src DESTDIR="${D}" pythondir="$(python_get_sitedir)" 
install
                python_optimize
        }
        python_foreach_impl install_python

        python_replicate_script 
"${D}"/usr/bin/firewall-{offline-cmd,cmd,applet,config}
        python_replicate_script "${D}/usr/sbin/firewalld"

        # Get rid of junk
        rm -rf "${D}/etc/rc.d/"
        rm -rf "${D}/etc/sysconfig/"

        # For non-gui installs we need to remove GUI bits
        if ! use gui; then
                rm -f "${D}/usr/bin/firewall-applet"
                rm -f "${D}/usr/bin/firewall-config"
                rm -rf "${D}/usr/share/icons"
                rm -rf "${D}/usr/share/applications"
        fi

        newinitd "${FILESDIR}"/firewalld.init firewalld
}

pkg_preinst() {
        gnome2_icon_savelist
        gnome2_schemas_savelist
}

pkg_postinst() {
        gnome2_icon_cache_update
        gnome2_schemas_update
}

pkg_postrm() {
        gnome2_icon_cache_update
        gnome2_schemas_update
}




Reply via email to