pinkbyte    14/06/29 12:08:23

  Modified:             ChangeLog
  Added:                gloox-1.0.10-r1.ebuild
  Removed:              gloox-1.0.10.ebuild
  Log:
  Revision bump: add support for user patches, do not build examples, prune 
unneeded libtool files, conditionally build static library, set proper 
condition on debug builds, build tests only when it's needed. Drop old revision
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
0x1F357D42)

Revision  Changes    Path
1.24                 net-libs/gloox/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/gloox/ChangeLog?rev=1.24&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/gloox/ChangeLog?rev=1.24&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/gloox/ChangeLog?r1=1.23&r2=1.24

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/net-libs/gloox/ChangeLog,v
retrieving revision 1.23
retrieving revision 1.24
diff -u -r1.23 -r1.24
--- ChangeLog   29 Jun 2014 11:15:19 -0000      1.23
+++ ChangeLog   29 Jun 2014 12:08:23 -0000      1.24
@@ -1,6 +1,15 @@
 # ChangeLog for net-libs/gloox
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gloox/ChangeLog,v 1.23 2014/06/29 
11:15:19 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gloox/ChangeLog,v 1.24 2014/06/29 
12:08:23 pinkbyte Exp $
+
+*gloox-1.0.10-r1 (29 Jun 2014)
+
+  29 Jun 2014; Sergey Popov <pinkb...@gentoo.org> -gloox-1.0.10.ebuild,
+  +gloox-1.0.10-r1.ebuild:
+  Revision bump: add support for user patches, do not build examples, prune
+  unneeded libtool files, conditionally build static library, set proper
+  condition on debug builds, build tests only when it's needed. Drop old
+  revision
 
   29 Jun 2014; Sergey Popov <pinkb...@gentoo.org> gloox-1.0.9.ebuild:
   Stable on x86, wrt bug #495850



1.1                  net-libs/gloox/gloox-1.0.10-r1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/gloox/gloox-1.0.10-r1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/gloox/gloox-1.0.10-r1.ebuild?rev=1.1&content-type=text/plain

Index: gloox-1.0.10-r1.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-libs/gloox/gloox-1.0.10-r1.ebuild,v 1.1 
2014/06/29 12:08:23 pinkbyte Exp $

EAPI=5

inherit eutils

MY_P="${P/_/-}"
DESCRIPTION="A portable high-level Jabber/XMPP library for C++"
HOMEPAGE="http://camaya.net/gloox";
SRC_URI="http://camaya.net/download/${MY_P}.tar.bz2";

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~x86"
IUSE="debug gnutls idn ssl static-libs test zlib"

DEPEND="idn? ( net-dns/libidn )
        gnutls? ( net-libs/gnutls )
        ssl? ( dev-libs/openssl )
        zlib? ( sys-libs/zlib )"

RDEPEND="${DEPEND}"

S="${WORKDIR}/${MY_P}"

src_prepare() {
        epatch_user
}

src_configure() {
        # Examples are not installed anyway, so - why should we build them?
        econf \
                --without-examples \
                $(use debug && echo "--enable-debug") \
                $(use_enable static-libs static) \
                $(use_with idn libidn) \
                $(use_with gnutls) \
                $(use_with ssl openssl) \
                $(use_with test tests) \
                $(use_with zlib)
}

src_install() {
        default
        prune_libtool_files
}




Reply via email to