mrueg       14/05/06 21:40:37

  Modified:             ChangeLog
  Added:                libgadu-1.11.3.ebuild
  Removed:              libgadu-1.11.2.ebuild
  Log:
  Version bump. See bug #505558
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key )

Revision  Changes    Path
1.73                 net-libs/libgadu/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/libgadu/ChangeLog?rev=1.73&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/libgadu/ChangeLog?rev=1.73&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/libgadu/ChangeLog?r1=1.72&r2=1.73

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/net-libs/libgadu/ChangeLog,v
retrieving revision 1.72
retrieving revision 1.73
diff -u -r1.72 -r1.73
--- ChangeLog   8 Apr 2013 21:48:13 -0000       1.72
+++ ChangeLog   6 May 2014 21:40:37 -0000       1.73
@@ -1,6 +1,12 @@
 # ChangeLog for net-libs/libgadu
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libgadu/ChangeLog,v 1.72 
2013/04/08 21:48:13 reavertm Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libgadu/ChangeLog,v 1.73 
2014/05/06 21:40:37 mrueg Exp $
+
+*libgadu-1.11.3 (06 May 2014)
+
+  06 May 2014; Manuel RĂ¼ger <mr...@gentoo.org> +libgadu-1.11.3.ebuild,
+  -libgadu-1.11.2.ebuild:
+  Version bump. See bug #505558
 
   08 Apr 2013; Maciej Mrozowski <reave...@gentoo.org> libgadu-1.11.2.ebuild:
   Bump to EAPI5, fix bug 461692.



1.1                  net-libs/libgadu/libgadu-1.11.3.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/libgadu/libgadu-1.11.3.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/libgadu/libgadu-1.11.3.ebuild?rev=1.1&content-type=text/plain

Index: libgadu-1.11.3.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-libs/libgadu/libgadu-1.11.3.ebuild,v 1.1 
2014/05/06 21:40:37 mrueg Exp $

EAPI=5

inherit autotools-utils

DESCRIPTION="This library implements the client side of the Gadu-Gadu protocol"
HOMEPAGE="http://toxygen.net/libgadu/";
SRC_URI="https://github.com/wojtekka/${PN}/archive/${PV}.tar.gz";

# Bug 373215, last checked 2012.01.28
RESTRICT="test"

LICENSE="LGPL-2.1"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 
~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos"
SLOT="0"
IUSE="doc gnutls ssl static-libs threads"

REQUIRED_USE="
        gnutls? ( ssl )
"
COMMON_DEPEND="
        sys-libs/zlib
        ssl? (
                gnutls? ( net-libs/gnutls )
                !gnutls? ( >=dev-libs/openssl-0.9.6m )
        )
"
DEPEND="${COMMON_DEPEND}
        doc? ( app-doc/doxygen )
"
RDEPEND="${COMMON_DEPEND}
        !=net-im/kadu-0.6.0.2
        !=net-im/kadu-0.6.0.1
"

AUTOTOOLS_IN_SOURCE_BUILD=1

DOCS=(AUTHORS ChangeLog NEWS README)

src_prepare() {
        eautoreconf
}

src_configure() {
        local myeconfargs=(
                $(use_with threads pthread)
        )

        if use ssl; then
                myeconfargs+=(
                        $(use_with gnutls gnutls)
                        $(use_with !gnutls openssl)
                )
        else
                myeconfargs+=(
                        --without-gnutls
                        --without-openssl
                )
        fi

        autotools-utils_src_configure
}

src_install() {
        use doc && HTML_DOCS=(docs/html/)
        autotools-utils_src_install
}




Reply via email to