vapier      15/06/17 17:45:20

  Modified:             nghttp2-9999.ebuild ChangeLog
  Added:                nghttp2-1.0.2.ebuild
  Log:
  Version bump.
  
  (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 
D2E96200)

Revision  Changes    Path
1.2                  net-libs/nghttp2/nghttp2-9999.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/nghttp2/nghttp2-9999.ebuild?rev=1.2&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/nghttp2/nghttp2-9999.ebuild?rev=1.2&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/nghttp2/nghttp2-9999.ebuild?r1=1.1&r2=1.2

Index: nghttp2-9999.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/net-libs/nghttp2/nghttp2-9999.ebuild,v
retrieving revision 1.1
retrieving revision 1.2
diff -u -r1.1 -r1.2
--- nghttp2-9999.ebuild 24 May 2015 13:55:00 -0000      1.1
+++ nghttp2-9999.ebuild 17 Jun 2015 17:45:20 -0000      1.2
@@ -1,6 +1,6 @@
 # Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/nghttp2/nghttp2-9999.ebuild,v 1.1 
2015/05/24 13:55:00 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/nghttp2/nghttp2-9999.ebuild,v 1.2 
2015/06/17 17:45:20 vapier Exp $
 
 # TODO: Add python support.
 
@@ -13,8 +13,7 @@
        inherit git-2
 else
        
SRC_URI="https://github.com/tatsuhiro-t/nghttp2/releases/download/v${PV}/${P}.tar.gz";
-       # Disabled until new curl & mod_h2 releases are made for the new API.
-       #KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc 
~ppc64 ~s390 ~sh ~sparc ~x86"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 
~s390 ~sh ~sparc ~x86"
 fi
 
 DESCRIPTION="HTTP/2 C Library"



1.3                  net-libs/nghttp2/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/nghttp2/ChangeLog?rev=1.3&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/nghttp2/ChangeLog?rev=1.3&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/nghttp2/ChangeLog?r1=1.2&r2=1.3

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/net-libs/nghttp2/ChangeLog,v
retrieving revision 1.2
retrieving revision 1.3
diff -u -r1.2 -r1.3
--- ChangeLog   4 Jun 2015 04:13:59 -0000       1.2
+++ ChangeLog   17 Jun 2015 17:45:20 -0000      1.3
@@ -1,6 +1,13 @@
 # ChangeLog for net-libs/nghttp2
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/nghttp2/ChangeLog,v 1.2 2015/06/04 
04:13:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/nghttp2/ChangeLog,v 1.3 2015/06/17 
17:45:20 vapier Exp $
+
+*nghttp2-1.0.2 (17 Jun 2015)
+
+  17 Jun 2015; Mike Frysinger <vap...@gentoo.org>
+  +files/nghttp2-1.0.2-third-party.patch, +nghttp2-1.0.2.ebuild,
+  nghttp2-9999.ebuild:
+  Version bump.
 
   04 Jun 2015; Mike Frysinger <vap...@gentoo.org> nghttp2-0.7.15.ebuild,
   nghttp2-1.0.1.ebuild:



1.1                  net-libs/nghttp2/nghttp2-1.0.2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/nghttp2/nghttp2-1.0.2.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/nghttp2/nghttp2-1.0.2.ebuild?rev=1.1&content-type=text/plain

Index: nghttp2-1.0.2.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-libs/nghttp2/nghttp2-1.0.2.ebuild,v 1.1 
2015/06/17 17:45:20 vapier Exp $

# TODO: Add python support.

EAPI="5"

inherit eutils multilib-minimal

if [[ ${PV} == 9999 ]] ; then
        EGIT_REPO_URI="https://github.com/tatsuhiro-t/nghttp2.git";
        inherit git-2
else
        
SRC_URI="https://github.com/tatsuhiro-t/nghttp2/releases/download/v${PV}/${P}.tar.gz";
        KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 
~s390 ~sh ~sparc ~x86"
fi

DESCRIPTION="HTTP/2 C Library"
HOMEPAGE="https://nghttp2.org/";

LICENSE="MIT"
SLOT="0/1.14" # <C++>.<C> SONAMEs
IUSE="cxx debug hpack-tools jemalloc static-libs test +threads utils xml"

RDEPEND="
        cxx? ( dev-libs/boost[${MULTILIB_USEDEP},threads] )
        hpack-tools? ( >=dev-libs/jansson-2.5 )
        jemalloc? ( dev-libs/jemalloc )
        utils? (
                >=dev-libs/libev-4.15
                >=dev-libs/openssl-1.0.2
                >=sys-libs/zlib-1.2.3
        )
        xml? ( >=dev-libs/libxml2-2.7.7 )"
DEPEND="${RDEPEND}
        virtual/pkgconfig
        test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"

src_prepare() {
        epatch "${FILESDIR}"/${P}-third-party.patch
}

multilib_src_configure() {
        ECONF_SOURCE=${S} \
        econf \
                --disable-examples \
                --disable-failmalloc \
                --disable-werror \
                --without-cython \
                --disable-python-bindings \
                --without-spdylay \
                $(use_enable cxx asio-lib) \
                $(use_enable debug) \
                $(multilib_native_use_enable hpack-tools) \
                $(use_enable static-libs static) \
                $(use_enable threads) \
                $(multilib_native_use_enable utils app) \
                $(multilib_native_use_with jemalloc) \
                $(multilib_native_use_with xml libxml2)
}

multilib_src_install_all() {
        use static-libs || find "${ED}" -name '*.la' -delete
}




Reply via email to