hwoarang    15/04/19 19:21:59

  Modified:             ChangeLog
  Added:                rb_libtorrent-1.0.4.ebuild
  Log:
  Version bump
  
  (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 
09BF4F54C2BA7F3C!)

Revision  Changes    Path
1.195                net-libs/rb_libtorrent/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/rb_libtorrent/ChangeLog?rev=1.195&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/rb_libtorrent/ChangeLog?rev=1.195&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/rb_libtorrent/ChangeLog?r1=1.194&r2=1.195

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v
retrieving revision 1.194
retrieving revision 1.195
diff -u -r1.194 -r1.195
--- ChangeLog   12 Apr 2015 17:21:04 -0000      1.194
+++ ChangeLog   19 Apr 2015 19:21:59 -0000      1.195
@@ -1,6 +1,12 @@
 # ChangeLog for net-libs/rb_libtorrent
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.194 
2015/04/12 17:21:04 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.195 
2015/04/19 19:21:59 hwoarang Exp $
+
+*rb_libtorrent-1.0.4 (19 Apr 2015)
+
+  19 Apr 2015; Markos Chandras <hwoar...@gentoo.org>
+  +rb_libtorrent-1.0.4.ebuild:
+  Version bump
 
   12 Apr 2015; Justin Lecher <j...@gentoo.org> 
-rb_libtorrent-0.16.17-r1.ebuild,
   -rb_libtorrent-1.0.2.ebuild, rb_libtorrent-0.16.17-r2.ebuild,



1.1                  net-libs/rb_libtorrent/rb_libtorrent-1.0.4.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-1.0.4.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-1.0.4.ebuild?rev=1.1&content-type=text/plain

Index: rb_libtorrent-1.0.4.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-1.0.4.ebuild,v 1.1 
2015/04/19 19:21:59 hwoarang Exp $

EAPI=5

PYTHON_COMPAT=( python2_7 python3_{3,4} )
PYTHON_REQ_USE="threads"
DISTUTILS_OPTIONAL=true
AUTOTOOLS_AUTORECONF=true

inherit autotools-utils multilib distutils-r1

MY_P=${P/rb_/}
MY_P=${MY_P/torrent/torrent-rasterbar}
S=${WORKDIR}/${MY_P}

DESCRIPTION="C++ BitTorrent implementation focusing on efficiency and 
scalability"
HOMEPAGE="http://www.rasterbar.com/products/libtorrent/";
SRC_URI="mirror://sourceforge/libtorrent/${MY_P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="debug doc examples python ssl static-libs test"

REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"

RDEPEND="
        >=dev-libs/boost-1.53:=[threads]
        sys-libs/zlib
        examples? ( !net-p2p/mldonkey )
        ssl? ( dev-libs/openssl:0= )
        python? (
                ${PYTHON_DEPS}
                dev-libs/boost[python,${PYTHON_USEDEP}]
        )"
DEPEND="${RDEPEND}
        >=sys-devel/libtool-2.2"

RESTRICT="test"

PATCHES=( "${FILESDIR}"/${PN}-1.0.2-python.patch )

AUTOTOOLS_IN_SOURCE_BUILD=1

src_configure() {
        local myeconfargs=(
                --disable-silent-rules # bug 441842
                --with-boost-libdir=/usr/$(get_libdir)
                $(use_enable debug)
                $(use_enable test tests)
                $(use_enable examples)
                $(use_enable ssl encryption)
                $(use_enable python python-binding)
                $(usex debug "--enable-logging=verbose" "")
        )

        use python && python_setup

        autotools-utils_src_configure
        use python && cd "${BUILD_DIR}"/bindings/python && 
distutils-r1_src_configure
}

src_compile() {
        autotools-utils_src_compile
        use python && cd "${BUILD_DIR}"/bindings/python && 
distutils-r1_src_compile
}

src_install() {
        use doc && HTML_DOCS=( docs/. )

        autotools-utils_src_install
        use python && cd "${BUILD_DIR}"/bindings/python && 
distutils-r1_src_install
}




Reply via email to