patrick     15/06/18 04:45:15

  Modified:             ChangeLog
  Added:                libpst-0.6.64.ebuild
  Log:
  Bump
  
  (Portage version: 2.2.20/cvs/Linux x86_64, unsigned Manifest commit)

Revision  Changes    Path
1.50                 net-mail/libpst/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-mail/libpst/ChangeLog?rev=1.50&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-mail/libpst/ChangeLog?rev=1.50&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-mail/libpst/ChangeLog?r1=1.49&r2=1.50

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/net-mail/libpst/ChangeLog,v
retrieving revision 1.49
retrieving revision 1.50
diff -u -r1.49 -r1.50
--- ChangeLog   4 Mar 2014 20:12:19 -0000       1.49
+++ ChangeLog   18 Jun 2015 04:45:15 -0000      1.50
@@ -1,6 +1,11 @@
 # ChangeLog for net-mail/libpst
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/libpst/ChangeLog,v 1.49 2014/03/04 
20:12:19 ago Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/libpst/ChangeLog,v 1.50 2015/06/18 
04:45:15 patrick Exp $
+
+*libpst-0.6.64 (18 Jun 2015)
+
+  18 Jun 2015; Patrick Lauer <patr...@gentoo.org> +libpst-0.6.64.ebuild:
+  Bump
 
   04 Mar 2014; Agostino Sarubbo <a...@gentoo.org> libpst-0.6.63.ebuild:
   Stable for x86, wrt bug #502890



1.1                  net-mail/libpst/libpst-0.6.64.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-mail/libpst/libpst-0.6.64.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-mail/libpst/libpst-0.6.64.ebuild?rev=1.1&content-type=text/plain

Index: libpst-0.6.64.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-mail/libpst/libpst-0.6.64.ebuild,v 1.1 
2015/06/18 04:45:15 patrick Exp $

EAPI=4
PYTHON_DEPEND="python? 2"

inherit autotools eutils python

DESCRIPTION="Tools and library for reading Outlook files (.pst format)"
HOMEPAGE="http://www.five-ten-sg.com/libpst/";
SRC_URI="http://www.five-ten-sg.com/${PN}/packages/${P}.tar.gz";

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="debug dii doc python static-libs"

RDEPEND="dii? ( media-gfx/imagemagick[png] )
        gnome-extra/libgsf"
DEPEND="${RDEPEND}
        virtual/libiconv
        virtual/pkgconfig
        dii? ( media-libs/gd[png] )
        python? ( >=dev-libs/boost-1.48[python] )"

pkg_setup() {
        if use python; then
                python_set_active_version 2
                python_pkg_setup
        fi
}

src_prepare() {
        # don't build the static python library
        epatch "${FILESDIR}"/${PN}-0.6.52-no-static-python-lib.patch

        # fix pkgconfig file for static linking
        epatch "${FILESDIR}"/${PN}-0.6.53-pkgconfig-static.patch

        # conditionally install the extra documentation
        use doc || { sed -i -e "/SUBDIRS/s: html::" Makefile.am || die; }

        # don't install duplicate docs
        sed -i -e "/^html_DATA =/d" Makefile.am || die

        eautoreconf
}

src_configure() {
        econf \
                --enable-libpst-shared \
                $(use_enable debug pst-debug) \
                $(use_enable dii) \
                $(use_enable python) \
                $(use_enable static-libs static) \
                $(use python && echo 
--with-boost-python=boost_python-${PYTHON_ABI})
}

src_install() {
        default
        prune_libtool_files --all
}




Reply via email to