jer         14/10/27 09:17:33

  Modified:             ChangeLog
  Added:                youtube-dl-2014.10.27.ebuild
  Removed:              youtube-dl-2014.10.24.ebuild
  Log:
  Version bump.
  
  (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 
A792A613)

Revision  Changes    Path
1.407                net-misc/youtube-dl/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/youtube-dl/ChangeLog?rev=1.407&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/youtube-dl/ChangeLog?rev=1.407&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/youtube-dl/ChangeLog?r1=1.406&r2=1.407

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/net-misc/youtube-dl/ChangeLog,v
retrieving revision 1.406
retrieving revision 1.407
diff -u -r1.406 -r1.407
--- ChangeLog   25 Oct 2014 13:29:41 -0000      1.406
+++ ChangeLog   27 Oct 2014 09:17:33 -0000      1.407
@@ -1,6 +1,12 @@
 # ChangeLog for net-misc/youtube-dl
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/youtube-dl/ChangeLog,v 1.406 
2014/10/25 13:29:41 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/youtube-dl/ChangeLog,v 1.407 
2014/10/27 09:17:33 jer Exp $
+
+*youtube-dl-2014.10.27 (27 Oct 2014)
+
+  27 Oct 2014; Jeroen Roovers <j...@gentoo.org> -youtube-dl-2014.10.24.ebuild,
+  +youtube-dl-2014.10.27.ebuild:
+  Version bump.
 
 *youtube-dl-2014.10.25 (25 Oct 2014)
 



1.1                  net-misc/youtube-dl/youtube-dl-2014.10.27.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/youtube-dl/youtube-dl-2014.10.27.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/youtube-dl/youtube-dl-2014.10.27.ebuild?rev=1.1&content-type=text/plain

Index: youtube-dl-2014.10.27.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/net-misc/youtube-dl/youtube-dl-2014.10.27.ebuild,v 1.1 
2014/10/27 09:17:33 jer Exp $

EAPI=5

PYTHON_COMPAT=(python{2_6,2_7,3_3,3_4})
DISTUTILS_SINGLE_IMPL=true
inherit bash-completion-r1 distutils-r1 eutils

DESCRIPTION="Download videos from YouTube.com (and more sites...)"
HOMEPAGE="http://rg3.github.com/youtube-dl/";
SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz";

LICENSE="public-domain"
SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux 
~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
IUSE="offensive test"

DEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
        test? ( dev-python/nose[coverage(+)] )
"

S="${WORKDIR}/${PN}"

src_prepare() {
        if ! use offensive; then
                sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
                        youtube_dl/version.py || die
                local xxx=(
                        anysex behindkink drtuber eporner extremetube fourtube 
goshgay
                        hentaistigma hornbunny mofosex motherless pornhd 
pornhub pornotube
                        pornoxo redtube sexykarma sunporno slutload spankwire 
thisav
                        trutube tube8 vporn xbef xhamster xnxx xtube xvideos 
youjizz
                        youporn
                )
                sed -i -e $( printf '/%s/d;' ${xxx[@]} ) 
youtube_dl/extractor/__init__.py || die
                rm $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
                        test/test_age_restriction.py || die
        fi
}

src_compile() {
        distutils-r1_src_compile
}

src_test() {
        emake test
}

src_install() {
        python_domodule youtube_dl
        dobin bin/${PN}
        dodoc README.txt
        doman ${PN}.1
        newbashcomp ${PN}.bash-completion ${PN}
        python_fix_shebang "${ED}"
}




Reply via email to