blueness    14/07/29 16:30:45

  Modified:             metadata.xml ChangeLog
  Added:                bitcoind-0.9.2.1.ebuild
  Log:
  Version bump, bug #505096
  
  (Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 
0xF52D4BBA)

Revision  Changes    Path
1.10                 net-p2p/bitcoind/metadata.xml

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-p2p/bitcoind/metadata.xml?rev=1.10&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-p2p/bitcoind/metadata.xml?rev=1.10&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-p2p/bitcoind/metadata.xml?r1=1.9&r2=1.10

Index: metadata.xml
===================================================================
RCS file: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/metadata.xml,v
retrieving revision 1.9
retrieving revision 1.10
diff -u -r1.9 -r1.10
--- metadata.xml        10 Oct 2013 05:19:24 -0000      1.9
+++ metadata.xml        29 Jul 2014 16:30:45 -0000      1.10
@@ -12,5 +12,7 @@
        </maintainer>
        <use>
                <flag name='logrotate'>Use app-admin/logrotate for rotating 
logs</flag>
+               <flag name='upnp'>Enable Universal Plug and Play</flag>
+               <flag name='wallet'>Enable wallet support</flag>
        </use>
 </pkgmetadata>



1.85                 net-p2p/bitcoind/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-p2p/bitcoind/ChangeLog?rev=1.85&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-p2p/bitcoind/ChangeLog?rev=1.85&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-p2p/bitcoind/ChangeLog?r1=1.84&r2=1.85

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/ChangeLog,v
retrieving revision 1.84
retrieving revision 1.85
diff -u -r1.84 -r1.85
--- ChangeLog   21 Feb 2014 14:22:42 -0000      1.84
+++ ChangeLog   29 Jul 2014 16:30:45 -0000      1.85
@@ -1,6 +1,12 @@
 # ChangeLog for net-p2p/bitcoind
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/ChangeLog,v 1.84 
2014/02/21 14:22:42 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/ChangeLog,v 1.85 
2014/07/29 16:30:45 blueness Exp $
+
+*bitcoind-0.9.2.1 (29 Jul 2014)
+
+  29 Jul 2014; Anthony G. Basile <bluen...@gentoo.org> 
+bitcoind-0.9.2.1.ebuild,
+  +files/0.9.0-sys_leveldb.patch, metadata.xml:
+  Version bump, bug #505096
 
 *bitcoind-0.8.6-r1 (21 Feb 2014)
 



1.1                  net-p2p/bitcoind/bitcoind-0.9.2.1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-p2p/bitcoind/bitcoind-0.9.2.1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-p2p/bitcoind/bitcoind-0.9.2.1.ebuild?rev=1.1&content-type=text/plain

Index: bitcoind-0.9.2.1.ebuild
===================================================================
# Copyright 2010-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.9.2.1.ebuild,v 
1.1 2014/07/29 16:30:45 blueness Exp $

EAPI=4

DB_VER="4.8"

inherit autotools bash-completion-r1 db-use eutils user versionator systemd

MyPV="${PV/_/}"
MyPN="bitcoin"
MyP="${MyPN}-${MyPV}"

DESCRIPTION="Original Bitcoin crypto-currency wallet for automated services"
HOMEPAGE="http://bitcoin.org/";
SRC_URI="https://github.com/${MyPN}/${MyPN}/archive/v${MyPV}.tar.gz -> 
${MyPN}-v${PV}.tgz
"

LICENSE="MIT ISC GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="bash-completion examples logrotate test upnp +wallet"

RDEPEND="
        >=dev-libs/boost-1.41.0[threads(+)]
        dev-libs/openssl:0[-bindist]
        logrotate? (
                app-admin/logrotate
        )
        upnp? (
                net-libs/miniupnpc
        )
        wallet? (
                sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
        )
        virtual/bitcoin-leveldb
"
DEPEND="${RDEPEND}
        >=app-shells/bash-4.1
        sys-apps/sed
"

S="${WORKDIR}/${MyP}"

pkg_setup() {
        local UG='bitcoin'
        enewgroup "${UG}"
        enewuser "${UG}" -1 -1 /var/lib/bitcoin "${UG}"
}

src_prepare() {
        epatch "${FILESDIR}/0.9.0-sys_leveldb.patch"
        rm -r src/leveldb
        eautoreconf
}

src_configure() {
        econf \
                $(use_with upnp miniupnpc) $(use_enable upnp upnp-default) \
                $(use_enable test tests)  \
                $(use_enable wallet)  \
                --with-system-leveldb  \
                --without-cli  \
                --without-gui
}

src_test() {
        emake check
}

src_install() {
        einstall

        insinto /etc/bitcoin
        newins "${FILESDIR}/bitcoin.conf" bitcoin.conf
        fowners bitcoin:bitcoin /etc/bitcoin/bitcoin.conf
        fperms 600 /etc/bitcoin/bitcoin.conf

        newconfd "${FILESDIR}/bitcoin.confd" ${PN}
        newinitd "${FILESDIR}/bitcoin.initd" ${PN}
        systemd_dounit "${FILESDIR}/bitcoind.service"

        keepdir /var/lib/bitcoin/.bitcoin
        fperms 700 /var/lib/bitcoin
        fowners bitcoin:bitcoin /var/lib/bitcoin/
        fowners bitcoin:bitcoin /var/lib/bitcoin/.bitcoin
        dosym /etc/bitcoin/bitcoin.conf /var/lib/bitcoin/.bitcoin/bitcoin.conf

        dodoc doc/README.md doc/release-notes.md
        dodoc doc/assets-attribution.md doc/tor.md
        doman contrib/debian/manpages/{bitcoind.1,bitcoin.conf.5}

        if use bash-completion; then
                newbashcomp contrib/${PN}.bash-completion ${PN}
        fi

        if use examples; then
                docinto examples
                dodoc -r contrib/{bitrpc,pyminer,qos,spendfrom,tidy_datadir.sh}
        fi

        if use logrotate; then
                insinto /etc/logrotate.d
                newins "${FILESDIR}/bitcoind.logrotate" bitcoind
        fi
}




Reply via email to