bicatali    14/05/06 15:55:36

  Modified:             ChangeLog
  Added:                wcslib-4.22.ebuild
  Removed:              wcslib-4.19.ebuild wcslib-4.20.ebuild
  Log:
  Version bump
  
  (Portage version: 2.2.8-prefix/cvs/Linux x86_64, signed Manifest commit with 
key 0x13CB1360)

Revision  Changes    Path
1.40                 sci-astronomy/wcslib/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-astronomy/wcslib/ChangeLog?rev=1.40&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-astronomy/wcslib/ChangeLog?rev=1.40&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-astronomy/wcslib/ChangeLog?r1=1.39&r2=1.40

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sci-astronomy/wcslib/ChangeLog,v
retrieving revision 1.39
retrieving revision 1.40
diff -u -r1.39 -r1.40
--- ChangeLog   3 Apr 2014 16:38:50 -0000       1.39
+++ ChangeLog   6 May 2014 15:55:36 -0000       1.40
@@ -1,6 +1,12 @@
 # ChangeLog for sci-astronomy/wcslib
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcslib/ChangeLog,v 1.39 
2014/04/03 16:38:50 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcslib/ChangeLog,v 1.40 
2014/05/06 15:55:36 bicatali Exp $
+
+*wcslib-4.22 (06 May 2014)
+
+  06 May 2014; Sébastien Fabbro <bicat...@gentoo.org> +wcslib-4.22.ebuild,
+  -wcslib-4.19.ebuild, -wcslib-4.20.ebuild:
+  Version bump
 
 *wcslib-4.21 (03 Apr 2014)
 



1.1                  sci-astronomy/wcslib/wcslib-4.22.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-astronomy/wcslib/wcslib-4.22.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-astronomy/wcslib/wcslib-4.22.ebuild?rev=1.1&content-type=text/plain

Index: wcslib-4.22.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcslib/wcslib-4.22.ebuild,v 
1.1 2014/05/06 15:55:36 bicatali Exp $

EAPI=5

FORTRAN_NEEDED=fortran

inherit eutils fortran-2 multilib

DESCRIPTION="Astronomical World Coordinate System transformations library"
HOMEPAGE="http://www.atnf.csiro.au/people/mcalabre/WCS/";
SRC_URI="ftp://ftp.atnf.csiro.au/pub/software/${PN}/${P}.tar.bz2";

SLOT="0/4"
LICENSE="LGPL-3"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc fortran fits pgplot static-libs"

RDEPEND="
        fits? ( sci-libs/cfitsio:0= )
        pgplot? ( sci-libs/pgplot:0= )"
DEPEND="${RDEPEND}
        sys-devel/flex
        virtual/pkgconfig"

src_prepare() {
        sed -i -e 's/COPYING\*//' GNUmakefile || die
}

src_configure() {
        local myconf=(
                --docdir="${EPREFIX}"/usr/share/doc/${PF}
                $(use_enable static-libs static)
                $(use_enable fortran)
        )
        # hacks because cfitsio and pgplot directories are hard-coded
        if use fits; then
                myconf+=(
                        --with-cfitsioinc="${EPREFIX}/usr/include"
                        --with-cfitsiolib="${EPREFIX}/usr/$(get_libdir)"
                )
        else
                myconf+=( --without-cfitsio )
        fi
        if use pgplot; then
                myconf+=(
                        --with-pgplotinc="${EPREFIX}/usr/include"
                        --with-pgplotlib="${EPREFIX}/usr/$(get_libdir)"
                )
        else
                myconf+=( --without-pgplot )
        fi
        econf ${myconf[@]}
}

src_compile() {
        # nasty makefile, debugging means probably full rewrite
        emake -j1
}

src_test() {
        emake -j1 check
}

src_install () {
        default
        # static libs are same as shared (compiled with PIC)
        # so they are not compiled twice
        use static-libs || rm "${ED}"/usr/$(get_libdir)/lib*.a
        use doc || rm -r \
                "${ED}"/usr/share/doc/${PF}/html \
                "${ED}"/usr/share/doc/${PF}/*.pdf
}




Reply via email to