dilfridge    15/07/25 20:53:53

  Modified:             ChangeLog
  Added:                armadillo-5.200.2.ebuild
  Log:
  Version bump
  
  (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 
0B08240A96F66571)

Revision  Changes    Path
1.36                 sci-libs/armadillo/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-libs/armadillo/ChangeLog?rev=1.36&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-libs/armadillo/ChangeLog?rev=1.36&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-libs/armadillo/ChangeLog?r1=1.35&r2=1.36

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sci-libs/armadillo/ChangeLog,v
retrieving revision 1.35
retrieving revision 1.36
diff -u -r1.35 -r1.36
--- ChangeLog   21 May 2015 15:47:50 -0000      1.35
+++ ChangeLog   25 Jul 2015 20:53:53 -0000      1.36
@@ -1,6 +1,12 @@
 # ChangeLog for sci-libs/armadillo
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/armadillo/ChangeLog,v 1.35 
2015/05/21 15:47:50 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/armadillo/ChangeLog,v 1.36 
2015/07/25 20:53:53 dilfridge Exp $
+
+*armadillo-5.200.2 (25 Jul 2015)
+
+  25 Jul 2015; Andreas K. Huettel <dilfri...@gentoo.org>
+  +armadillo-5.200.2.ebuild:
+  Version bump
 
   21 May 2015; Andreas K. Hüttel <dilfri...@gentoo.org>
   -armadillo-4.600.4.ebuild, -armadillo-4.650.2.ebuild:



1.1                  sci-libs/armadillo/armadillo-5.200.2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-libs/armadillo/armadillo-5.200.2.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-libs/armadillo/armadillo-5.200.2.ebuild?rev=1.1&content-type=text/plain

Index: armadillo-5.200.2.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/sci-libs/armadillo/armadillo-5.200.2.ebuild,v 1.1 
2015/07/25 20:53:53 dilfridge Exp $

EAPI=5

CMAKE_IN_SOURCE_BUILD=1

inherit cmake-utils toolchain-funcs multilib eutils

DESCRIPTION="Streamlined C++ linear algebra library"
HOMEPAGE="http://arma.sourceforge.net/";
SRC_URI="mirror://sourceforge/arma/${P}.tar.gz"

LICENSE="MPL-2.0"
SLOT="0/5"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="arpack blas debug doc examples hdf5 lapack mkl superlu tbb test"
REQUIRED_USE="test? ( lapack )"

RDEPEND="
        dev-libs/boost
        arpack? ( sci-libs/arpack )
        blas? ( virtual/blas )
        lapack? ( virtual/lapack )
        superlu? ( sci-libs/superlu )
"
DEPEND="${RDEPEND}
        arpack? ( virtual/pkgconfig )
        blas? ( virtual/pkgconfig )
        hdf5? ( sci-libs/hdf5 )
        lapack? ( virtual/pkgconfig )
        mkl? ( sci-libs/mkl )
        tbb? ( dev-cpp/tbb )"
PDEPEND="${RDEPEND}
        hdf5? ( sci-libs/hdf5 )
        mkl? ( sci-libs/mkl )
        tbb? ( dev-cpp/tbb )"

src_prepare() {
        # avoid the automagic cmake macros
        sed -i -e '/ARMA_Find/d' CMakeLists.txt || die
        cmake-utils_src_prepare
}

src_configure() {
        local mycmakeargs=(
                -DINSTALL_LIB_DIR="${EPREFIX}/usr/$(get_libdir)"
                $(cmake-utils_use debug ARMA_EXTRA_DEBUG)
                $(cmake-utils_use mkl ARMA_USE_MKL_ALLOC)
                $(cmake-utils_use tbb ARMA_USE_TBB_ALLOC)
        )
        if use arpack; then
                mycmakeargs+=(
                        -DARPACK_FOUND=ON
                        -DARPACK_LIBRARY="$($(tc-getPKG_CONFIG) --libs arpack)"
                )
        fi
#       if use atlas; then
#               local c=atlas-cblas l=atlas-clapack
#               $(tc-getPKG_CONFIG) --exists ${c}-threads && c+=-threads
#               $(tc-getPKG_CONFIG) --exists ${l}-threads && l+=-threads
#               mycmakeargs+=(
#                       -DCBLAS_FOUND=ON
#                       -DCBLAS_INCLUDE_DIR="$($(tc-getPKG_CONFIG) 
--cflags-only-I ${c} | sed 's/-I//')"
#                       -DCBLAS_LIBRARIES="$($(tc-getPKG_CONFIG) --libs ${c})"
#                       -DCLAPACK_FOUND=ON
#                       -DCLAPACK_INCLUDE_DIR="$($(tc-getPKG_CONFIG) 
--cflags-only-I ${l} | sed 's/-I//')"
#                       -DCLAPACK_LIBRARIES="$($(tc-getPKG_CONFIG) --libs ${l})"
#               )
#       fi
        if use blas; then
                mycmakeargs+=(
                        -DBLAS_FOUND=ON
                        -DBLAS_LIBRARIES="$($(tc-getPKG_CONFIG) --libs blas)"
                )
        fi
        if use hdf5; then
                mycmakeargs+=(
                        -DHDF5_FOUND=ON
                        -DHDF5_LIBRARIES="-lhdf5"
                )
        fi
        if use lapack; then
                mycmakeargs+=(
                        -DLAPACK_FOUND=ON
                        -DLAPACK_LIBRARIES="$($(tc-getPKG_CONFIG) --libs 
lapack)"
                )
        fi
        if use superlu; then
                mycmakeargs+=(
                        -DSuperLU_FOUND=ON
                        -DSuperLU_LIBRARIES="$($(tc-getPKG_CONFIG) --libs 
superlu)"
                )
        fi

        cmake-utils_src_configure
}

src_test() {
        pushd examples > /dev/null
        emake \
                CXXFLAGS="-I../include ${CXXFLAGS} -DARMA_USE_BLAS 
-DARMA_USE_LAPACK" \
                EXTRA_LIB_FLAGS="-L.. $($(tc-getPKG_CONFIG) --libs blas lapack)"
        LD_LIBRARY_PATH="..:${LD_LIBRARY_PATH}" ./example1 || die
        LD_LIBRARY_PATH="..:${LD_LIBRARY_PATH}" ./example2 || die
        emake clean
        popd > /dev/null
}

src_install() {
        cmake-utils_src_install
        dodoc README.txt
        use doc && dodoc *pdf && dohtml *html
        if use examples; then
                insinto /usr/share/examples/${PF}
                doins -r examples/*
        fi
}




Reply via email to