jlec        14/05/10 17:20:59

  Modified:             gentoo-functions-0.4.ebuild ChangeLog
                        gentoo-functions-0.5.ebuild
                        gentoo-functions-9999.ebuild metadata.xml
  Log:
  sys-apps/gentoo-functions: Respect CC
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
B9D4F231BD1558AB!)

Revision  Changes    Path
1.2                  sys-apps/gentoo-functions/gentoo-functions-0.4.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/gentoo-functions/gentoo-functions-0.4.ebuild?rev=1.2&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/gentoo-functions/gentoo-functions-0.4.ebuild?rev=1.2&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/gentoo-functions/gentoo-functions-0.4.ebuild?r1=1.1&r2=1.2

Index: gentoo-functions-0.4.ebuild
===================================================================
RCS file: 
/var/cvsroot/gentoo-x86/sys-apps/gentoo-functions/gentoo-functions-0.4.ebuild,v
retrieving revision 1.1
retrieving revision 1.2
diff -u -r1.1 -r1.2
--- gentoo-functions-0.4.ebuild 8 May 2014 06:28:20 -0000       1.1
+++ gentoo-functions-0.4.ebuild 10 May 2014 17:20:59 -0000      1.2
@@ -1,17 +1,19 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: 
/var/cvsroot/gentoo-x86/sys-apps/gentoo-functions/gentoo-functions-0.4.ebuild,v 
1.1 2014/05/08 06:28:20 williamh Exp $
+# $Header: 
/var/cvsroot/gentoo-x86/sys-apps/gentoo-functions/gentoo-functions-0.4.ebuild,v 
1.2 2014/05/10 17:20:59 jlec Exp $
 
 EAPI=5
 
 if [[ ${PV} = 9999* ]]; then
-       inherit git-r3
+       vcs=git-r3
        EGIT_REPO_URI="git://github.com/gentoo/${PN}.git"
 else
        SRC_URI="http://dev.gentoo.org/~williamh/dist/${P}.tar.bz2";
        KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 
~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd 
~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux 
~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint 
~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
 fi
 
+inherit ${vcs} toolchain-funcs
+
 DESCRIPTION="base functions required by all gentoo systems"
 HOMEPAGE="http://www.gentoo.org";
 
@@ -19,5 +21,6 @@
 SLOT="0"
 IUSE=""
 
-DEPEND=""
-RDEPEND=""
+src_prepare() {
+       tc-export CC
+}



1.13                 sys-apps/gentoo-functions/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/gentoo-functions/ChangeLog?rev=1.13&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/gentoo-functions/ChangeLog?rev=1.13&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/gentoo-functions/ChangeLog?r1=1.12&r2=1.13

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sys-apps/gentoo-functions/ChangeLog,v
retrieving revision 1.12
retrieving revision 1.13
diff -u -r1.12 -r1.13
--- ChangeLog   9 May 2014 00:03:34 -0000       1.12
+++ ChangeLog   10 May 2014 17:20:59 -0000      1.13
@@ -1,6 +1,10 @@
 # ChangeLog for sys-apps/gentoo-functions
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gentoo-functions/ChangeLog,v 1.12 
2014/05/09 00:03:34 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gentoo-functions/ChangeLog,v 1.13 
2014/05/10 17:20:59 jlec Exp $
+
+  10 May 2014; Justin Lecher <j...@gentoo.org> gentoo-functions-0.4.ebuild,
+  gentoo-functions-0.5.ebuild, gentoo-functions-9999.ebuild, metadata.xml:
+  Respect CC
 
   09 May 2014; William Hubbs <willi...@gentoo.org> 
gentoo-functions-9999.ebuild:
   sync live ebuild



1.2                  sys-apps/gentoo-functions/gentoo-functions-0.5.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/gentoo-functions/gentoo-functions-0.5.ebuild?rev=1.2&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/gentoo-functions/gentoo-functions-0.5.ebuild?rev=1.2&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/gentoo-functions/gentoo-functions-0.5.ebuild?r1=1.1&r2=1.2

Index: gentoo-functions-0.5.ebuild
===================================================================
RCS file: 
/var/cvsroot/gentoo-x86/sys-apps/gentoo-functions/gentoo-functions-0.5.ebuild,v
retrieving revision 1.1
retrieving revision 1.2
diff -u -r1.1 -r1.2
--- gentoo-functions-0.5.ebuild 9 May 2014 00:01:27 -0000       1.1
+++ gentoo-functions-0.5.ebuild 10 May 2014 17:20:59 -0000      1.2
@@ -1,17 +1,19 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: 
/var/cvsroot/gentoo-x86/sys-apps/gentoo-functions/gentoo-functions-0.5.ebuild,v 
1.1 2014/05/09 00:01:27 williamh Exp $
+# $Header: 
/var/cvsroot/gentoo-x86/sys-apps/gentoo-functions/gentoo-functions-0.5.ebuild,v 
1.2 2014/05/10 17:20:59 jlec Exp $
 
 EAPI=5
 
 if [[ ${PV} = 9999* ]]; then
-       inherit git-r3
+       vcs=git-r3
        EGIT_REPO_URI="git://github.com/gentoo/${PN}.git"
 else
        SRC_URI="http://dev.gentoo.org/~williamh/dist/${P}.tar.bz2";
        KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 
~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd 
~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux 
~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint 
~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
 fi
 
+inherit ${vcs} toolchain-funcs
+
 DESCRIPTION="base functions required by all gentoo systems"
 HOMEPAGE="http://www.gentoo.org";
 
@@ -19,5 +21,6 @@
 SLOT="0"
 IUSE=""
 
-DEPEND=""
-RDEPEND=""
+src_prepare() {
+       tc-export CC
+}



1.3                  sys-apps/gentoo-functions/gentoo-functions-9999.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild?rev=1.3&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild?rev=1.3&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild?r1=1.2&r2=1.3

Index: gentoo-functions-9999.ebuild
===================================================================
RCS file: 
/var/cvsroot/gentoo-x86/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild,v
retrieving revision 1.2
retrieving revision 1.3
diff -u -r1.2 -r1.3
--- gentoo-functions-9999.ebuild        9 May 2014 00:03:34 -0000       1.2
+++ gentoo-functions-9999.ebuild        10 May 2014 17:20:59 -0000      1.3
@@ -1,17 +1,19 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: 
/var/cvsroot/gentoo-x86/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild,v
 1.2 2014/05/09 00:03:34 williamh Exp $
+# $Header: 
/var/cvsroot/gentoo-x86/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild,v
 1.3 2014/05/10 17:20:59 jlec Exp $
 
 EAPI=5
 
 if [[ ${PV} = 9999* ]]; then
-       inherit git-r3
+       vcs=git-r3
        EGIT_REPO_URI="git://github.com/gentoo/${PN}.git"
 else
        SRC_URI="http://dev.gentoo.org/~williamh/dist/${P}.tar.bz2";
        KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 
~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd 
~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux 
~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint 
~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
 fi
 
+inherit ${vcs} toolchain-funcs
+
 DESCRIPTION="base functions required by all gentoo systems"
 HOMEPAGE="http://www.gentoo.org";
 
@@ -19,5 +21,6 @@
 SLOT="0"
 IUSE=""
 
-DEPEND=""
-RDEPEND=""
+src_prepare() {
+       tc-export CC
+}



1.3                  sys-apps/gentoo-functions/metadata.xml

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/gentoo-functions/metadata.xml?rev=1.3&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/gentoo-functions/metadata.xml?rev=1.3&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/gentoo-functions/metadata.xml?r1=1.2&r2=1.3

Index: metadata.xml
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sys-apps/gentoo-functions/metadata.xml,v
retrieving revision 1.2
retrieving revision 1.3
diff -u -r1.2 -r1.3
--- metadata.xml        11 Mar 2014 02:49:35 -0000      1.2
+++ metadata.xml        10 May 2014 17:20:59 -0000      1.3
@@ -1,12 +1,12 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd";>
 <pkgmetadata>
-       <maintainer>
-               <email>willi...@gentoo.org</email>
-               <name>William Hubbs</name>
-       </maintainer>
-       <herd>base-system</herd>
-       <longdescription lang="en">
+  <maintainer>
+    <email>willi...@gentoo.org</email>
+    <name>William Hubbs</name>
+  </maintainer>
+  <herd>base-system</herd>
+  <longdescription lang="en">
                This package contains base shell functions which are required by
                all Gentoo systems.
        </longdescription>




Reply via email to