rhill       14/08/07 00:40:11

  Modified:             ChangeLog
  Added:                gcc-4.9.1.ebuild
  Log:
  4.9.1 p1.0 (bug #517262). Patch for bug #519172, might also fix bug #518580.
  
  Signed-off-by: Ryan Hill <rh...@gentoo.org>
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
957A8463)

Revision  Changes    Path
1.1016               sys-devel/gcc/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/gcc/ChangeLog?rev=1.1016&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/gcc/ChangeLog?rev=1.1016&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/gcc/ChangeLog?r1=1.1015&r2=1.1016

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v
retrieving revision 1.1015
retrieving revision 1.1016
diff -u -r1.1015 -r1.1016
--- ChangeLog   5 Aug 2014 15:35:44 -0000       1.1015
+++ ChangeLog   7 Aug 2014 00:40:11 -0000       1.1016
@@ -1,6 +1,11 @@
 # ChangeLog for sys-devel/gcc
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.1015 2014/08/05 
15:35:44 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.1016 2014/08/07 
00:40:11 rhill Exp $
+
+*gcc-4.9.1 (07 Aug 2014)
+
+  07 Aug 2014; Ryan Hill <rh...@gentoo.org> +gcc-4.9.1.ebuild:
+  4.9.1 p1.0 (bug #517262). Patch for bug #519172, might also fix bug #518580.
 
   05 Aug 2014; Raúl Porcel <armi...@gentoo.org> gcc-4.8.0.ebuild,
   gcc-4.8.1-r1.ebuild, gcc-4.8.2.ebuild, gcc-4.8.3.ebuild:



1.1                  sys-devel/gcc/gcc-4.9.1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/gcc/gcc-4.9.1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/gcc/gcc-4.9.1.ebuild?rev=1.1&content-type=text/plain

Index: gcc-4.9.1.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.9.1.ebuild,v 1.1 
2014/08/07 00:40:11 rhill Exp $

EAPI="4"

PATCH_VER="1.0"
UCLIBC_VER="1.0"

# Hardened gcc 4 stuff
PIE_VER="0.6.0"
SPECS_VER="0.2.0"
SPECS_GCC_VER="4.4.3"
# arch/libc configurations known to be stable with {PIE,SSP}-by-default
PIE_GLIBC_STABLE="x86 amd64 mips ppc ppc64 arm ia64"
PIE_UCLIBC_STABLE="x86 arm amd64 mips ppc ppc64"
SSP_STABLE="amd64 x86 mips ppc ppc64 arm"
# uclibc need tls and nptl support for SSP support
# uclibc need to be >= 0.9.33
SSP_UCLIBC_STABLE="x86 amd64 mips ppc ppc64 arm"
#end Hardened stuff

inherit eutils toolchain

DESCRIPTION="The GNU Compiler Collection"

LICENSE="GPL-3+ LGPL-3+ || ( GPL-3+ libgcc libstdc++ 
gcc-runtime-library-exception-3.1 ) FDL-1.3+"

KEYWORDS=""

RDEPEND=""
DEPEND="${RDEPEND}
        elibc_glibc? ( >=sys-libs/glibc-2.8 )
        >=${CATEGORY}/binutils-2.20"

if [[ ${CATEGORY} != cross-* ]] ; then
        PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"
fi

src_prepare() {
        if has_version '<sys-libs/glibc-2.12' ; then
                ewarn "Your host glibc is too old; disabling automatic fortify."
                ewarn "Please rebuild gcc after upgrading to >=glibc-2.12 
#362315"
                EPATCH_EXCLUDE+=" 10_all_default-fortify-source.patch"
        fi

        toolchain_src_prepare

        use vanilla && return 0
        #Use -r1 for newer piepatchet that use DRIVER_SELF_SPECS for the 
hardened specs.
        [[ ${CHOST} == ${CTARGET} ]] && epatch 
"${FILESDIR}"/gcc-spec-env-r1.patch
}




Reply via email to