jlec        14/12/15 08:37:24

  Modified:             ChangeLog
  Added:                aufs-sources-3.18.0.ebuild
                        aufs-sources-3.12.34.ebuild
  Removed:              aufs-sources-3.10.60.ebuild
                        aufs-sources-3.14.24.ebuild
                        aufs-sources-3.10.58.ebuild
                        aufs-sources-3.12.31.ebuild
                        aufs-sources-3.12.32.ebuild
                        aufs-sources-3.14.21.ebuild
                        aufs-sources-3.14.23.ebuild
                        aufs-sources-3.16.5.ebuild
  Log:
  sys-kernel/aufs-sources: Bump to latest aufs3, genpatches and linux release; 
drop old
  
  (Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 
B9D4F231BD1558AB!)

Revision  Changes    Path
1.163                sys-kernel/aufs-sources/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-kernel/aufs-sources/ChangeLog?rev=1.163&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-kernel/aufs-sources/ChangeLog?rev=1.163&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-kernel/aufs-sources/ChangeLog?r1=1.162&r2=1.163

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sys-kernel/aufs-sources/ChangeLog,v
retrieving revision 1.162
retrieving revision 1.163
diff -u -r1.162 -r1.163
--- ChangeLog   11 Dec 2014 09:04:23 -0000      1.162
+++ ChangeLog   15 Dec 2014 08:37:23 -0000      1.163
@@ -1,6 +1,17 @@
 # ChangeLog for sys-kernel/aufs-sources
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aufs-sources/ChangeLog,v 1.162 
2014/12/11 09:04:23 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aufs-sources/ChangeLog,v 1.163 
2014/12/15 08:37:23 jlec Exp $
+
+*aufs-sources-3.18.0 (15 Dec 2014)
+*aufs-sources-3.12.34 (15 Dec 2014)
+
+  15 Dec 2014; Justin Lecher <j...@gentoo.org> -aufs-sources-3.10.58.ebuild,
+  -aufs-sources-3.10.60.ebuild, -aufs-sources-3.12.31.ebuild,
+  -aufs-sources-3.12.32.ebuild, +aufs-sources-3.12.34.ebuild,
+  -aufs-sources-3.14.21.ebuild, -aufs-sources-3.14.23.ebuild,
+  -aufs-sources-3.14.24.ebuild, -aufs-sources-3.16.5.ebuild,
+  +aufs-sources-3.18.0.ebuild:
+  Bump to latest aufs3, genpatches and linux release; drop old
 
 *aufs-sources-3.14.26 (11 Dec 2014)
 *aufs-sources-3.10.62 (11 Dec 2014)



1.1                  sys-kernel/aufs-sources/aufs-sources-3.18.0.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-kernel/aufs-sources/aufs-sources-3.18.0.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-kernel/aufs-sources/aufs-sources-3.18.0.ebuild?rev=1.1&content-type=text/plain

Index: aufs-sources-3.18.0.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/sys-kernel/aufs-sources/aufs-sources-3.18.0.ebuild,v 
1.1 2014/12/15 08:37:23 jlec Exp $

EAPI=5

ETYPE="sources"
K_WANT_GENPATCHES="base extras experimental"
K_GENPATCHES_VER="2"
K_DEBLOB_AVAILABLE="1"
UNIPATCH_STRICTORDER=1
inherit kernel-2 eutils readme.gentoo
detect_version
detect_arch

AUFS_VERSION=3.18_p20141215
AUFS_TARBALL="aufs-sources-${AUFS_VERSION}.tar.xz"
# git archive -v --remote=git://git.code.sf.net/p/aufs/aufs3-standalone 
aufs${AUFS_VERSION/_p*} > aufs-sources-${AUFS_VERSION}.tar
AUFS_URI="http://dev.gentoo.org/~jlec/distfiles/${AUFS_TARBALL}";

KEYWORDS="~amd64 ~x86"
HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches 
http://aufs.sourceforge.net/";
IUSE="deblob experimental module vanilla"

DESCRIPTION="Full sources including the Gentoo patchset for the 
${KV_MAJOR}.${KV_MINOR} kernel tree and aufs3 support"
SRC_URI="
        ${KERNEL_URI}
        ${ARCH_URI}
        ${AUFS_URI}
        !vanilla? ( ${GENPATCHES_URI} )
        "

PDEPEND=">=sys-fs/aufs-util-3.9"

README_GENTOO_SUFFIX="-r1"

src_unpack() {
        if use vanilla; then
                unset UNIPATCH_LIST_GENPATCHES UNIPATCH_LIST_DEFAULT
                ewarn "You are using USE=vanilla"
                ewarn "This will drop all support from the gentoo kernel 
security team"
        fi

        UNIPATCH_LIST="
                "${WORKDIR}"/aufs3-kbuild.patch
                "${WORKDIR}"/aufs3-base.patch
                "${WORKDIR}"/aufs3-mmap.patch"

        use module && UNIPATCH_LIST+=" "${WORKDIR}"/aufs3-standalone.patch"

        unpack ${AUFS_TARBALL}

        einfo "Using aufs3 version: ${AUFS_VERSION}"

        kernel-2_src_unpack
}

src_prepare() {
        if ! use module; then
                sed -e 's:tristate:bool:g' -i "${WORKDIR}"/fs/aufs/Kconfig || 
die
        fi
        cp -f "${WORKDIR}"/include/uapi/linux/aufs_type.h 
include/uapi/linux/aufs_type.h || die
        cp -rf "${WORKDIR}"/{Documentation,fs} . || die
}

src_install() {
        kernel-2_src_install
        dodoc "${WORKDIR}"/{aufs3-loopback,vfs-ino,tmpfs-idr}.patch
        docompress -x 
/usr/share/doc/${PF}/{aufs3-loopback,vfs-ino,tmpfs-idr}.patch
        readme.gentoo_create_doc
}

pkg_postinst() {
        kernel-2_pkg_postinst
        einfo "For more info on this patchset, and how to report problems, see:"
        einfo "${HOMEPAGE}"
        has_version sys-fs/aufs-util || \
                elog "In order to use aufs FS you need to install 
sys-fs/aufs-util"

        readme.gentoo_pkg_postinst
}

pkg_postrm() {
        kernel-2_pkg_postrm
}



1.1                  sys-kernel/aufs-sources/aufs-sources-3.12.34.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-kernel/aufs-sources/aufs-sources-3.12.34.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-kernel/aufs-sources/aufs-sources-3.12.34.ebuild?rev=1.1&content-type=text/plain

Index: aufs-sources-3.12.34.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/sys-kernel/aufs-sources/aufs-sources-3.12.34.ebuild,v 
1.1 2014/12/15 08:37:23 jlec Exp $

EAPI=5

ETYPE="sources"
K_WANT_GENPATCHES="base extras experimental"
K_GENPATCHES_VER="35"
K_DEBLOB_AVAILABLE="1"
UNIPATCH_STRICTORDER=1
inherit kernel-2 eutils readme.gentoo
detect_version
detect_arch

AUFS_VERSION=3.12.31+_p20141215
AUFS_TARBALL="aufs-sources-${AUFS_VERSION}.tar.xz"
# git archive -v --remote=git://git.code.sf.net/p/aufs/aufs3-standalone 
aufs${AUFS_VERSION/_p*} > aufs-sources-${AUFS_VERSION}.tar
AUFS_URI="http://dev.gentoo.org/~jlec/distfiles/${AUFS_TARBALL}";

KEYWORDS="~amd64 ~x86"
HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches 
http://aufs.sourceforge.net/";
IUSE="deblob experimental module vanilla"

DESCRIPTION="Full sources including the Gentoo patchset for the 
${KV_MAJOR}.${KV_MINOR} kernel tree and aufs3 support"
SRC_URI="
        ${KERNEL_URI}
        ${ARCH_URI}
        ${AUFS_URI}
        !vanilla? ( ${GENPATCHES_URI} )
        "

PDEPEND=">=sys-fs/aufs-util-3.9"

README_GENTOO_SUFFIX="-r1"

src_unpack() {
        if use vanilla; then
                unset UNIPATCH_LIST_GENPATCHES UNIPATCH_LIST_DEFAULT
                ewarn "You are using USE=vanilla"
                ewarn "This will drop all support from the gentoo kernel 
security team"
        fi

        UNIPATCH_LIST="
                "${WORKDIR}"/aufs3-kbuild.patch
                "${WORKDIR}"/aufs3-base.patch
                "${WORKDIR}"/aufs3-mmap.patch"

        use module && UNIPATCH_LIST+=" "${WORKDIR}"/aufs3-standalone.patch"

        unpack ${AUFS_TARBALL}

        einfo "Using aufs3 version: ${AUFS_VERSION}"

        kernel-2_src_unpack
}

src_prepare() {
        if ! use module; then
                sed -e 's:tristate:bool:g' -i "${WORKDIR}"/fs/aufs/Kconfig || 
die
        fi
        cp -f "${WORKDIR}"/include/uapi/linux/aufs_type.h 
include/uapi/linux/aufs_type.h || die
        cp -rf "${WORKDIR}"/{Documentation,fs} . || die
}

src_install() {
        kernel-2_src_install
        dodoc "${WORKDIR}"/{aufs3-loopback,vfs-ino,tmpfs-idr}.patch
        docompress -x 
/usr/share/doc/${PF}/{aufs3-loopback,vfs-ino,tmpfs-idr}.patch
        readme.gentoo_create_doc
}

pkg_postinst() {
        kernel-2_pkg_postinst
        einfo "For more info on this patchset, and how to report problems, see:"
        einfo "${HOMEPAGE}"
        has_version sys-fs/aufs-util || \
                elog "In order to use aufs FS you need to install 
sys-fs/aufs-util"

        readme.gentoo_pkg_postinst
}

pkg_postrm() {
        kernel-2_pkg_postrm
}




Reply via email to