chainsaw    14/05/06 12:52:04

  Modified:             ChangeLog
  Added:                libutempter-1.1.6-r2.ebuild
  Log:
  Respect system AR, as requested by Agostino "ago" Sarubbo in bug #484868.
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
0xB5058F9A)

Revision  Changes    Path
1.52                 sys-libs/libutempter/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-libs/libutempter/ChangeLog?rev=1.52&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-libs/libutempter/ChangeLog?rev=1.52&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-libs/libutempter/ChangeLog?r1=1.51&r2=1.52

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sys-libs/libutempter/ChangeLog,v
retrieving revision 1.51
retrieving revision 1.52
diff -u -r1.51 -r1.52
--- ChangeLog   1 Feb 2014 23:25:17 -0000       1.51
+++ ChangeLog   6 May 2014 12:52:04 -0000       1.52
@@ -1,6 +1,11 @@
 # ChangeLog for sys-libs/libutempter
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libutempter/ChangeLog,v 1.51 
2014/02/01 23:25:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libutempter/ChangeLog,v 1.52 
2014/05/06 12:52:04 chainsaw Exp $
+
+*libutempter-1.1.6-r2 (06 May 2014)
+
+  06 May 2014; Tony Vroon <chain...@gentoo.org> +libutempter-1.1.6-r2.ebuild:
+  Respect system AR, as requested by Agostino "ago" Sarubbo in bug #484868.
 
   01 Feb 2014; Mike Frysinger <vap...@gentoo.org> libutempter-1.1.6-r1.ebuild:
   Mark m68k/s390/sh stable.



1.1                  sys-libs/libutempter/libutempter-1.1.6-r2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-libs/libutempter/libutempter-1.1.6-r2.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-libs/libutempter/libutempter-1.1.6-r2.ebuild?rev=1.1&content-type=text/plain

Index: libutempter-1.1.6-r2.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/sys-libs/libutempter/libutempter-1.1.6-r2.ebuild,v 1.1 
2014/05/06 12:52:04 chainsaw Exp $

EAPI="4"

inherit user multilib flag-o-matic

DESCRIPTION="Library that allows non-privileged apps to write utmp (login) 
info, which need root access"
HOMEPAGE="http://altlinux.org/index.php?module=sisyphus&package=libutempter";
SRC_URI="ftp://ftp.altlinux.org/pub/people/ldv/${PN}/${P}.tar.bz2";

LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 
~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
IUSE="static-libs elibc_FreeBSD"

RDEPEND="!sys-apps/utempter"

pkg_setup() {
        enewgroup utmp 406
}

src_prepare() {
        local args=(
                -e "/^libdir /s:/usr/lib:${EPREFIX}/usr/$(get_libdir):"
                -e '/^libexecdir /s:=.*:= $(libdir)/misc:'
                -e '/^CFLAGS = $(RPM_OPT_FLAGS)/d'
                -e 's:,-stats::'
                -e "/^includedir /s:/usr/include:${EPREFIX}/usr/include:"
                -e "/^mandir /s:=.*:= ${EPREFIX}/usr/share/man:"
        )
        use static-libs || args+=(
                        -e '/^STATICLIB/d'
                        -e '/INSTALL.*STATICLIB/d'
                )
        sed -i "${args[@]}" Makefile || die
}

src_configure() {
        use elibc_FreeBSD && append-libs -lutil
        tc-export AR CC
}

src_compile() {
        emake LDLIBS="${LIBS}"
}

src_install() {
        default

        if ! use prefix ; then
                fowners root:utmp /usr/$(get_libdir)/misc/utempter/utempter
                fperms 2755 /usr/$(get_libdir)/misc/utempter/utempter
        fi
        dodir /usr/sbin
        dosym ../$(get_libdir)/misc/utempter/utempter /usr/sbin/utempter
}

pkg_postinst() {
        if [ -f "${EROOT}/var/log/wtmp" ] ; then
                chown root:utmp "${EROOT}/var/log/wtmp"
                chmod 664 "${EROOT}/var/log/wtmp"
        fi

        if [ -f "${EROOT}/var/run/utmp" ] ; then
                chown root:utmp "${EROOT}/var/run/utmp"
                chmod 664 "${EROOT}/var/run/utmp"
        fi
}




Reply via email to