graaff      14/05/10 07:20:55

  Modified:             ChangeLog
  Added:                passenger-4.0.42.ebuild
  Log:
  Version bump.
  
  (Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 
0x8883FA56A308A8D7!)

Revision  Changes    Path
1.92                 www-apache/passenger/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/www-apache/passenger/ChangeLog?rev=1.92&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/www-apache/passenger/ChangeLog?rev=1.92&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/www-apache/passenger/ChangeLog?r1=1.91&r2=1.92

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/www-apache/passenger/ChangeLog,v
retrieving revision 1.91
retrieving revision 1.92
diff -u -r1.91 -r1.92
--- ChangeLog   4 May 2014 18:30:08 -0000       1.91
+++ ChangeLog   10 May 2014 07:20:55 -0000      1.92
@@ -1,6 +1,11 @@
 # ChangeLog for www-apache/passenger
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/passenger/ChangeLog,v 1.91 
2014/05/04 18:30:08 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/passenger/ChangeLog,v 1.92 
2014/05/10 07:20:55 graaff Exp $
+
+*passenger-4.0.42 (10 May 2014)
+
+  10 May 2014; Hans de Graaff <gra...@gentoo.org> +passenger-4.0.42.ebuild:
+  Version bump.
 
   04 May 2014; Diego E. Pettenò <flamee...@gentoo.org>
   passenger-3.0.21-r1.ebuild, passenger-4.0.41.ebuild:



1.1                  www-apache/passenger/passenger-4.0.42.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/www-apache/passenger/passenger-4.0.42.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/www-apache/passenger/passenger-4.0.42.ebuild?rev=1.1&content-type=text/plain

Index: passenger-4.0.42.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/www-apache/passenger/passenger-4.0.42.ebuild,v 1.1 
2014/05/10 07:20:55 graaff Exp $

EAPI=5
USE_RUBY="ruby19 ruby20 ruby21"

inherit apache-module flag-o-matic multilib ruby-ng toolchain-funcs

DESCRIPTION="Passenger (a.k.a. mod_rails) makes deployment of Ruby on Rails 
applications a breeze"
HOMEPAGE="http://modrails.com/";
SRC_URI="http://s3.amazonaws.com/phusion-passenger/releases/${P}.tar.gz";

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug"

ruby_add_bdepend "dev-ruby/rake"

ruby_add_rdepend "
        >=dev-ruby/daemon_controller-1.1.0
        >=dev-ruby/rack-1.0.0"

CDEPEND=">=dev-libs/libev-4.11 net-misc/curl[ssl]
        www-servers/apache[apache2_modules_unixd(+)]"

RDEPEND="${RDEPEND} ${CDEPEND}"
DEPEND="${DEPEND} ${CDEPEND}"

APACHE2_MOD_CONF="30_mod_${PN}-4.0.0 30_mod_${PN}"
APACHE2_MOD_DEFINE="PASSENGER"

need_apache2

pkg_setup() {
        use debug && append-flags -DPASSENGER_DEBUG
}

all_ruby_prepare() {
        epatch "${FILESDIR}"/${PN}-4.0.33-gentoo.patch

        # Change these with sed instead of a patch so that we can easily use
        # the toolchain-funcs methods.
        sed -i -e "s/gcc/$(tc-getCC)/" \
                -e "s/g++/$(tc-getCXX)/" \
                -e 's/PlatformInfo.debugging_cflags//' build/basics.rb || die

        # Use sed here so that we can dynamically set the documentation 
directory.
        sed -i -e "s:/usr/share/doc/passenger:/usr/share/doc/${P}:" \
                -e 
"s:/usr/lib/apache2/modules/mod_passenger.so:${APACHE_MODULESDIR}/mod_passenger.so:"
 \
                -e 
"s:/usr/lib/phusion-passenger/agents:/usr/libexec/phusion-passenger/agents:" \
                lib/phusion_passenger.rb || die
        sed -i -e 
"s:/usr/lib/phusion-passenger/agents:/usr/libexec/phusion-passenger/agents:" 
ext/common/ResourceLocator.h || die

        # Don't install a tool that won't work in our setup.
        sed -i -e '/passenger-install-apache2-module/d' 
lib/phusion_passenger/packaging.rb || die
        rm -f bin/passenger-install-apache2-module || die "Unable to remove 
unneeded install script."

        # Make sure we use the system-provided version.
        rm -rf ext/libev || die "Unable to remove vendored libev."

        # Avoid building documentation to avoid a dependency on mizuho.
        #sed -i -e 's/, :doc//' build/packaging.rb || die
        touch doc/*.html || die

        # Use the correct arch-specific lib directory
        sed -i -e 's:/usr/lib/:/usr/'$(get_libdir)'/:' build/packaging.rb || die

        # Fix hard-coded use of AR
        sed -i -e "s/ar cru/"$(tc-getAR)" cru/" build/cplusplus_support.rb || 
die
}

all_ruby_compile() {
        V=1 EXTRA_LDFLAGS="${LDFLAGS}" \
        APXS2="${APXS}" \
        HTTPD="${APACHE_BIN}" \
        USE_VENDORED_LIBEV="no" LIBEV_LIBS="-lev" \
        ruby -S rake apache2 || die "rake failed"
}

each_ruby_compile() {
        append-flags -fno-strict-aliasing

        V=1 EXTRA_LDFLAGS="${LDFLAGS}" \
        APXS2="${APXS}" \
        HTTPD="${APACHE_BIN}" \
        USE_VENDORED_LIBEV="no" LIBEV_LIBS="-lev" \
        ${RUBY} -S rake native_support || die "rake failed"
}

all_ruby_install() {
        APACHE2_MOD_FILE="${S}/buildout/apache2/mod_${PN}.so"
        apache-module_src_install

        # Patch in the correct libdir
        sed -i -e 's:/usr/lib/:/usr/'$(get_libdir)'/:' 
"${D}${APACHE_MODULES_CONFDIR}/30_mod_${PN}.conf" || die
}

each_ruby_install() {
        DISTDIR="${D}" \
        RUBYLIBDIR="$(ruby_rbconfig_value vendordir)" \
        RUBYARCHDIR="$(ruby_rbconfig_value archdir)" \
        APXS2="${APXS}" \
        HTTPD="${APACHE_BIN}" \
        EXTRA_LDFLAGS="${LDFLAGS}" \
        USE_VENDORED_LIBEV="no" LIBEV_LIBS="-lev" \
        ${RUBY} -S rake fakeroot || die "rake failed"
}

pkg_postint() {
        einfo "The apache module is compiled for the currently eselected ruby."
        einfo" If you eselect another ruby you must recompile passenger as 
well."
}




Reply via email to