jmbsvicetto    14/10/17 13:02:55

  Modified:             ChangeLog
  Added:                drupal-7.32.ebuild
  Removed:              drupal-7.31.ebuild
  Log:
  Bump to release 7.32 - fixes bug 525514 (CVE-2014-3704).
  
  (Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 
BB0E6E98)

Revision  Changes    Path
1.109                www-apps/drupal/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/www-apps/drupal/ChangeLog?rev=1.109&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/www-apps/drupal/ChangeLog?rev=1.109&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/www-apps/drupal/ChangeLog?r1=1.108&r2=1.109

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/www-apps/drupal/ChangeLog,v
retrieving revision 1.108
retrieving revision 1.109
diff -u -r1.108 -r1.109
--- ChangeLog   14 Aug 2014 12:59:01 -0000      1.108
+++ ChangeLog   17 Oct 2014 13:02:55 -0000      1.109
@@ -1,6 +1,12 @@
 # ChangeLog for www-apps/drupal
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/drupal/ChangeLog,v 1.108 
2014/08/14 12:59:01 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/drupal/ChangeLog,v 1.109 
2014/10/17 13:02:55 jmbsvicetto Exp $
+
+*drupal-7.32 (17 Oct 2014)
+
+  17 Oct 2014; Jorge Manuel B. S. Vicetto <jmbsvice...@gentoo.org>
+  +drupal-7.32.ebuild, -drupal-7.31.ebuild:
+  Bump to release 7.32 - fixes bug 525514 (CVE-2014-3704).
 
 *drupal-6.33 (14 Aug 2014)
 *drupal-7.31 (14 Aug 2014)



1.1                  www-apps/drupal/drupal-7.32.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/www-apps/drupal/drupal-7.32.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/www-apps/drupal/drupal-7.32.ebuild?rev=1.1&content-type=text/plain

Index: drupal-7.32.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/www-apps/drupal/drupal-7.32.ebuild,v 1.1 
2014/10/17 13:02:55 jmbsvicetto Exp $

EAPI=5

inherit webapp

MY_PV=${PV:0:3}.0

DESCRIPTION="PHP-based open-source platform and content management system"
HOMEPAGE="http://drupal.org/";
SRC_URI="http://drupal.org/files/projects/${P}.tar.gz";

LICENSE="GPL-2"
KEYWORDS="~alpha ~amd64 ~ppc ~x86"
IUSE="+accelerator +mysql postgres sqlite +uploadprogress"

RDEPEND="
        dev-lang/php[gd,hash,pdo,postgres?,simplexml,xml]
        virtual/httpd-php
        accelerator? ( ||
                (
                        (
                                <dev-lang/php-5.5
                                dev-php/pecl-apc
                        )
                        dev-php/xcache
                        dev-php/eaccelerator
                        (
                                >=dev-lang/php-5.5[opcache]
                                dev-php/pecl-apcu
                        )
                )
        )
        uploadprogress? ( dev-php/pecl-uploadprogress )
        mysql? (
                || (
                        dev-lang/php[mysql]
                        dev-lang/php[mysqli]
                )
        )
        sqlite? (
                || (
                        dev-lang/php[sqlite]
                        dev-lang/php[sqlite3]
                )
        )
"

need_httpd_cgi

REQUIRED_USE="|| ( mysql postgres sqlite )"

src_install() {
        webapp_src_preinst

        local docs="MAINTAINERS.txt LICENSE.txt INSTALL.txt CHANGELOG.txt 
INSTALL.mysql.txt INSTALL.pgsql.txt INSTALL.sqlite.txt UPGRADE.txt "
        dodoc ${docs}
        rm -f ${docs} INSTALL COPYRIGHT.txt || die

        cp sites/default/{default.settings.php,settings.php} || die
        insinto "${MY_HTDOCSDIR}"
        doins -r .

        dodir "${MY_HTDOCSDIR}"/files
        webapp_serverowned "${MY_HTDOCSDIR}"/files
        webapp_serverowned "${MY_HTDOCSDIR}"/sites/default
        webapp_serverowned "${MY_HTDOCSDIR}"/sites/default/settings.php

        webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
        webapp_configfile "${MY_HTDOCSDIR}"/.htaccess

        webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt

        webapp_src_install
}

pkg_postinst() {
        echo
        ewarn "SECURITY NOTICE"
        ewarn "If you plan on using SSL on your Drupal site, please consult the 
postinstall information:"
        ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
        echo
}




Reply via email to