floppym     14/03/17 14:08:25

  Modified:             ChangeLog
  Added:                chrome-binary-plugins-33.0.1750.152_p1.ebuild
  Removed:              chrome-binary-plugins-33.0.1750.149_p1.ebuild
  Log:
  Automated update.
  
  (Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 
0BBEEA1FEA4843A4)

Revision  Changes    Path
1.116                www-plugins/chrome-binary-plugins/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/www-plugins/chrome-binary-plugins/ChangeLog?rev=1.116&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/www-plugins/chrome-binary-plugins/ChangeLog?rev=1.116&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/www-plugins/chrome-binary-plugins/ChangeLog?r1=1.115&r2=1.116

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/www-plugins/chrome-binary-plugins/ChangeLog,v
retrieving revision 1.115
retrieving revision 1.116
diff -u -r1.115 -r1.116
--- ChangeLog   13 Mar 2014 02:11:07 -0000      1.115
+++ ChangeLog   17 Mar 2014 14:08:25 -0000      1.116
@@ -1,6 +1,13 @@
 # ChangeLog for www-plugins/chrome-binary-plugins
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: 
/var/cvsroot/gentoo-x86/www-plugins/chrome-binary-plugins/ChangeLog,v 1.115 
2014/03/13 02:11:07 floppym Exp $
+# $Header: 
/var/cvsroot/gentoo-x86/www-plugins/chrome-binary-plugins/ChangeLog,v 1.116 
2014/03/17 14:08:25 floppym Exp $
+
+*chrome-binary-plugins-33.0.1750.152_p1 (17 Mar 2014)
+
+  17 Mar 2014; Mike Gilbert <flop...@gentoo.org>
+  +chrome-binary-plugins-33.0.1750.152_p1.ebuild,
+  -chrome-binary-plugins-33.0.1750.149_p1.ebuild:
+  Automated update.
 
 *chrome-binary-plugins-34.0.1847.60_beta1 (13 Mar 2014)
 



1.1                  
www-plugins/chrome-binary-plugins/chrome-binary-plugins-33.0.1750.152_p1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/www-plugins/chrome-binary-plugins/chrome-binary-plugins-33.0.1750.152_p1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/www-plugins/chrome-binary-plugins/chrome-binary-plugins-33.0.1750.152_p1.ebuild?rev=1.1&content-type=text/plain

Index: chrome-binary-plugins-33.0.1750.152_p1.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/www-plugins/chrome-binary-plugins/chrome-binary-plugins-33.0.1750.152_p1.ebuild,v
 1.1 2014/03/17 14:08:25 floppym Exp $

EAPI=4

inherit multilib unpacker

DESCRIPTION="Binary plugins -- native API Flash and PDF -- from Google Chrome 
for use in Chromium."
HOMEPAGE="http://www.google.com/chrome";

case ${PV} in
        *_alpha*)
                SLOT="unstable"
                MY_PV=${PV/_alpha/-}
                ;;
        *_beta*)
                SLOT="beta"
                MY_PV=${PV/_beta/-}
                ;;
        *_p*)
                SLOT="stable"
                MY_PV=${PV/_p/-}
                ;;
        *)
                die "Invalid value for \${PV}: ${PV}"
                ;;
esac

MY_PN="google-chrome-${SLOT}"
MY_P="${MY_PN}_${MY_PV}"

SRC_URI="
        amd64? (
                
http://dl.google.com/linux/chrome/deb/pool/main/g/${MY_PN}/${MY_P}_amd64.deb
        )
        x86? (
                
http://dl.google.com/linux/chrome/deb/pool/main/g/${MY_PN}/${MY_P}_i386.deb
        )
"

LICENSE="google-chrome"
KEYWORDS="~amd64 ~x86"
IUSE="+flash +pdf"
RESTRICT="bindist mirror strip"

RDEPEND="www-client/chromium"

for x in 0 beta stable unstable; do
        if [[ ${SLOT} != ${x} ]]; then
                RDEPEND+=" !${CATEGORY}/${PN}:${x}"
        fi
done

S="${WORKDIR}/opt/google/chrome"
QA_PREBUILT="*"

src_install() {
        local version flapper

        insinto /usr/$(get_libdir)/chromium-browser/

        use pdf && doins libpdf.so

        if use flash; then
                doins -r PepperFlash

                # Since this is a live ebuild, we're forced to, unfortuantely,
                # dynamically construct the command line args for Chromium.
                version=$(sed -n 's/.*"version": "\(.*\)",.*/\1/p' 
PepperFlash/manifest.json)
                
flapper="${ROOT}usr/$(get_libdir)/chromium-browser/PepperFlash/libpepflashplayer.so"
                echo -n "CHROMIUM_FLAGS=\"\${CHROMIUM_FLAGS} " > pepper-flash
                echo -n "--ppapi-flash-path=$flapper " >> pepper-flash
                echo "--ppapi-flash-version=$version\"" >> pepper-flash

                insinto /etc/chromium/
                doins pepper-flash
        fi
}




Reply via email to