floppym     14/10/04 00:01:42

  Modified:             ChangeLog
  Added:                chrome-binary-plugins-39.0.2171.7_alpha1.ebuild
  Removed:              chrome-binary-plugins-39.0.2171.2_alpha1.ebuild
  Log:
  Automated update.
  
  (Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with 
key 0BBEEA1FEA4843A4)

Revision  Changes    Path
1.186                www-plugins/chrome-binary-plugins/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/www-plugins/chrome-binary-plugins/ChangeLog?rev=1.186&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/www-plugins/chrome-binary-plugins/ChangeLog?rev=1.186&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/www-plugins/chrome-binary-plugins/ChangeLog?r1=1.185&r2=1.186

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/www-plugins/chrome-binary-plugins/ChangeLog,v
retrieving revision 1.185
retrieving revision 1.186
diff -u -r1.185 -r1.186
--- ChangeLog   1 Oct 2014 20:48:23 -0000       1.185
+++ ChangeLog   4 Oct 2014 00:01:42 -0000       1.186
@@ -1,6 +1,13 @@
 # ChangeLog for www-plugins/chrome-binary-plugins
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: 
/var/cvsroot/gentoo-x86/www-plugins/chrome-binary-plugins/ChangeLog,v 1.185 
2014/10/01 20:48:23 floppym Exp $
+# $Header: 
/var/cvsroot/gentoo-x86/www-plugins/chrome-binary-plugins/ChangeLog,v 1.186 
2014/10/04 00:01:42 floppym Exp $
+
+*chrome-binary-plugins-39.0.2171.7_alpha1 (04 Oct 2014)
+
+  04 Oct 2014; Mike Gilbert <flop...@gentoo.org>
+  +chrome-binary-plugins-39.0.2171.7_alpha1.ebuild,
+  -chrome-binary-plugins-39.0.2171.2_alpha1.ebuild:
+  Automated update.
 
 *chrome-binary-plugins-38.0.2125.101_beta1 (01 Oct 2014)
 



1.1                  
www-plugins/chrome-binary-plugins/chrome-binary-plugins-39.0.2171.7_alpha1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/www-plugins/chrome-binary-plugins/chrome-binary-plugins-39.0.2171.7_alpha1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/www-plugins/chrome-binary-plugins/chrome-binary-plugins-39.0.2171.7_alpha1.ebuild?rev=1.1&content-type=text/plain

Index: chrome-binary-plugins-39.0.2171.7_alpha1.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/www-plugins/chrome-binary-plugins/chrome-binary-plugins-39.0.2171.7_alpha1.ebuild,v
 1.1 2014/10/04 00:01:42 floppym Exp $

EAPI=5

inherit multilib unpacker

DESCRIPTION="Binary plugins from Google Chrome for use in Chromium"
HOMEPAGE="http://www.google.com/chrome";

case ${PV} in
        *_alpha*|9999*)
                SLOT="unstable"
                CHROMEDIR="opt/google/chrome-${SLOT}"
                MY_PV=${PV/_alpha/-}
                ;;
        *_beta*)
                SLOT="beta"
                CHROMEDIR="opt/google/chrome-${SLOT}"
                MY_PV=${PV/_beta/-}
                ;;
        *_p*)
                SLOT="stable"
                CHROMEDIR="opt/google/chrome"
                MY_PV=${PV/_p/-}
                ;;
        *)
                die "Invalid value for \${PV}: ${PV}"
                ;;
esac

MY_PN="google-chrome-${SLOT}"
MY_P="${MY_PN}_${MY_PV}"

if [[ ${PV} != 9999* ]]; then
SRC_URI="
        amd64? (
                
https://dl.google.com/linux/chrome/deb/pool/main/g/${MY_PN}/${MY_P}_amd64.deb
        )
        x86? (
                
https://dl.google.com/linux/chrome/deb/pool/main/g/${MY_PN}/${MY_P}_i386.deb
        )
"
KEYWORDS="~amd64 ~x86"
fi

LICENSE="google-chrome"
IUSE="+flash"
RESTRICT="bindist mirror strip"

for x in 0 beta stable unstable; do
        if [[ ${SLOT} != ${x} ]]; then
                RDEPEND+=" !${CATEGORY}/${PN}:${x}"
        fi
done

S="${WORKDIR}/${CHROMEDIR}"
QA_PREBUILT="*"

pkg_nofetch() {
        eerror "Please wait 24 hours and sync your portage tree before 
reporting fetch failures."
}

if [[ ${PV} == 9999* ]]; then
src_unpack() {
        local base="https://dl.google.com/linux/direct";
        local debarch=${ARCH/x86/i386}
        wget -O google-chrome.deb 
"${base}/google-chrome-${SLOT}_current_${debarch}.deb" || die
        unpack_deb ./google-chrome.deb
}
fi

src_install() {
        local version flapper

        insinto /usr/$(get_libdir)/chromium-browser/

        if use flash; then
                doins -r PepperFlash

                # Since this is a live ebuild, we're forced to, unfortuantely,
                # dynamically construct the command line args for Chromium.
                version=$(sed -n 's/.*"version": "\(.*\)",.*/\1/p' 
PepperFlash/manifest.json)
                
flapper="${ROOT}usr/$(get_libdir)/chromium-browser/PepperFlash/libpepflashplayer.so"
                echo -n "CHROMIUM_FLAGS=\"\${CHROMIUM_FLAGS} " > pepper-flash
                echo -n "--ppapi-flash-path=$flapper " >> pepper-flash
                echo "--ppapi-flash-version=$version\"" >> pepper-flash

                insinto /etc/chromium/
                doins pepper-flash
        fi
}




Reply via email to