floppym     15/08/01 16:08:26

  Modified:             ChangeLog
  Added:                chrome-binary-plugins-46.0.2467.2_alpha1.ebuild
  Removed:              chrome-binary-plugins-45.0.2454.15_alpha1.ebuild
  Log:
  Automated update.
  
  (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 
0BBEEA1FEA4843A4)

Revision  Changes    Path
1.276                www-plugins/chrome-binary-plugins/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/www-plugins/chrome-binary-plugins/ChangeLog?rev=1.276&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/www-plugins/chrome-binary-plugins/ChangeLog?rev=1.276&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/www-plugins/chrome-binary-plugins/ChangeLog?r1=1.275&r2=1.276

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/www-plugins/chrome-binary-plugins/ChangeLog,v
retrieving revision 1.275
retrieving revision 1.276
diff -u -r1.275 -r1.276
--- ChangeLog   29 Jul 2015 00:15:03 -0000      1.275
+++ ChangeLog   1 Aug 2015 16:08:26 -0000       1.276
@@ -1,6 +1,13 @@
 # ChangeLog for www-plugins/chrome-binary-plugins
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: 
/var/cvsroot/gentoo-x86/www-plugins/chrome-binary-plugins/ChangeLog,v 1.275 
2015/07/29 00:15:03 floppym Exp $
+# $Header: 
/var/cvsroot/gentoo-x86/www-plugins/chrome-binary-plugins/ChangeLog,v 1.276 
2015/08/01 16:08:26 floppym Exp $
+
+*chrome-binary-plugins-46.0.2467.2_alpha1 (01 Aug 2015)
+
+  01 Aug 2015; Mike Gilbert <flop...@gentoo.org>
+  +chrome-binary-plugins-46.0.2467.2_alpha1.ebuild,
+  -chrome-binary-plugins-45.0.2454.15_alpha1.ebuild:
+  Automated update.
 
 *chrome-binary-plugins-44.0.2403.125_p1 (29 Jul 2015)
 



1.1                  
www-plugins/chrome-binary-plugins/chrome-binary-plugins-46.0.2467.2_alpha1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/www-plugins/chrome-binary-plugins/chrome-binary-plugins-46.0.2467.2_alpha1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/www-plugins/chrome-binary-plugins/chrome-binary-plugins-46.0.2467.2_alpha1.ebuild?rev=1.1&content-type=text/plain

Index: chrome-binary-plugins-46.0.2467.2_alpha1.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/www-plugins/chrome-binary-plugins/chrome-binary-plugins-46.0.2467.2_alpha1.ebuild,v
 1.1 2015/08/01 16:08:26 floppym Exp $

EAPI=5

inherit multilib unpacker

DESCRIPTION="Binary plugins from Google Chrome for use in Chromium"
HOMEPAGE="http://www.google.com/chrome";

case ${PV} in
        *_alpha*|9999*)
                SLOT="unstable"
                CHROMEDIR="opt/google/chrome-${SLOT}"
                MY_PV=${PV/_alpha/-}
                ;;
        *_beta*)
                SLOT="beta"
                CHROMEDIR="opt/google/chrome-${SLOT}"
                MY_PV=${PV/_beta/-}
                ;;
        *_p*)
                SLOT="stable"
                CHROMEDIR="opt/google/chrome"
                MY_PV=${PV/_p/-}
                ;;
        *)
                die "Invalid value for \${PV}: ${PV}"
                ;;
esac

MY_PN="google-chrome-${SLOT}"
MY_P="${MY_PN}_${MY_PV}"

if [[ ${PV} != 9999* ]]; then
SRC_URI="
        amd64? (
                
https://dl.google.com/linux/chrome/deb/pool/main/g/${MY_PN}/${MY_P}_amd64.deb
        )
        x86? (
                
https://dl.google.com/linux/chrome/deb/pool/main/g/${MY_PN}/${MY_P}_i386.deb
        )
"
KEYWORDS="~amd64 ~x86"
fi

LICENSE="google-chrome"
IUSE="+flash +widevine"
RESTRICT="bindist mirror strip"

for x in 0 beta stable unstable; do
        if [[ ${SLOT} != ${x} ]]; then
                RDEPEND+=" !${CATEGORY}/${PN}:${x}"
        fi
done

S="${WORKDIR}/${CHROMEDIR}"
QA_PREBUILT="*"

pkg_nofetch() {
        eerror "Please wait 24 hours and sync your portage tree before 
reporting fetch failures."
}

if [[ ${PV} == 9999* ]]; then
src_unpack() {
        local base="https://dl.google.com/linux/direct";
        local debarch=${ARCH/x86/i386}
        wget -O google-chrome.deb 
"${base}/google-chrome-${SLOT}_current_${debarch}.deb" || die
        unpack_deb ./google-chrome.deb
}
fi

src_install() {
        local version flapper

        insinto /usr/$(get_libdir)/chromium-browser/

        if use widevine; then
                doins libwidevinecdm.so
                strings ./chrome | grep -C 1 " (version:" | tail -1 > 
widevine.version
                doins widevine.version
                einfo "Please note that if you intend to use this with 
www-clients/chromium,"
                einfo "you'll need to enable the widevine USE flag there as 
well, in order to"
                einfo "utilize the widevine USE flag that's been used here."
        fi

        if use flash; then
                doins -r PepperFlash

                # Since this is a live ebuild, we're forced to, unfortuantely,
                # dynamically construct the command line args for Chromium.
                version=$(sed -n 's/.*"version": "\(.*\)",.*/\1/p' 
PepperFlash/manifest.json)
                
flapper="${ROOT}usr/$(get_libdir)/chromium-browser/PepperFlash/libpepflashplayer.so"
                echo -n "CHROMIUM_FLAGS=\"\${CHROMIUM_FLAGS} " > pepper-flash
                echo -n "--ppapi-flash-path=$flapper " >> pepper-flash
                echo "--ppapi-flash-version=$version\"" >> pepper-flash

                insinto /etc/chromium/
                doins pepper-flash
        fi
}




Reply via email to