hwoarang    15/03/17 20:37:44

  Modified:             ChangeLog
  Added:                lightdm-1.10.5.ebuild lightdm-1.13.2.ebuild
                        lightdm-1.12.3.ebuild
  Removed:              lightdm-1.13.1.ebuild lightdm-1.13.0.ebuild
                        lightdm-1.11.9.ebuild
  Log:
  Version bumps
  
  (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 
09BF4F54C2BA7F3C!)

Revision  Changes    Path
1.109                x11-misc/lightdm/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-misc/lightdm/ChangeLog?rev=1.109&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-misc/lightdm/ChangeLog?rev=1.109&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-misc/lightdm/ChangeLog?r1=1.108&r2=1.109

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/x11-misc/lightdm/ChangeLog,v
retrieving revision 1.108
retrieving revision 1.109
diff -u -r1.108 -r1.109
--- ChangeLog   3 Mar 2015 12:05:18 -0000       1.108
+++ ChangeLog   17 Mar 2015 20:37:44 -0000      1.109
@@ -1,6 +1,15 @@
 # ChangeLog for x11-misc/lightdm
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/lightdm/ChangeLog,v 1.108 
2015/03/03 12:05:18 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/lightdm/ChangeLog,v 1.109 
2015/03/17 20:37:44 hwoarang Exp $
+
+*lightdm-1.12.3 (17 Mar 2015)
+*lightdm-1.10.5 (17 Mar 2015)
+*lightdm-1.13.2 (17 Mar 2015)
+
+  17 Mar 2015; Markos Chandras <hwoar...@gentoo.org> +lightdm-1.10.5.ebuild,
+  +lightdm-1.12.3.ebuild, +lightdm-1.13.2.ebuild, -lightdm-1.11.9.ebuild,
+  -lightdm-1.13.0.ebuild, -lightdm-1.13.1.ebuild:
+  Version bumps
 
   03 Mar 2015; Yixun Lan <d...@gentoo.org> lightdm-1.12.2.ebuild:
   add arm64 support, tested on A53 board



1.1                  x11-misc/lightdm/lightdm-1.10.5.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-misc/lightdm/lightdm-1.10.5.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-misc/lightdm/lightdm-1.10.5.ebuild?rev=1.1&content-type=text/plain

Index: lightdm-1.10.5.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/x11-misc/lightdm/lightdm-1.10.5.ebuild,v 1.1 
2015/03/17 20:37:44 hwoarang Exp $

EAPI=5
inherit autotools eutils pam readme.gentoo systemd

TRUNK_VERSION="1.10"
DESCRIPTION="A lightweight display manager"
HOMEPAGE="http://www.freedesktop.org/wiki/Software/LightDM";
SRC_URI="http://launchpad.net/${PN}/${TRUNK_VERSION}/${PV}/+download/${P}.tar.xz
        mirror://gentoo/introspection-20110205.m4.tar.bz2"

LICENSE="GPL-3 LGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~x86"
IUSE="+gtk +introspection kde qt4"
REQUIRED_USE="|| ( gtk kde )"

COMMON_DEPEND=">=dev-libs/glib-2.32.3:2
        dev-libs/libxml2
        sys-apps/accountsservice
        virtual/pam
        x11-libs/libX11
        >=x11-libs/libxklavier-5
        introspection? ( >=dev-libs/gobject-introspection-1 )
        qt4? (
                dev-qt/qtcore:4
                dev-qt/qtdbus:4
                dev-qt/qtgui:4
                )"
RDEPEND="${COMMON_DEPEND}
        >=sys-auth/pambase-20101024-r2"
DEPEND="${COMMON_DEPEND}
        dev-util/gtk-doc-am
        dev-util/intltool
        gnome-base/gnome-common
        sys-devel/gettext
        virtual/pkgconfig"
PDEPEND="gtk? ( x11-misc/lightdm-gtk-greeter )
        kde? ( x11-misc/lightdm-kde )"

DOCS=( NEWS )
RESTRICT="test"

src_prepare() {
        sed -i -e 's:getgroups:lightdm_&:' tests/src/libsystem.c || die #412369
        sed -i -e '/minimum-uid/s:500:1000:' data/users.conf || die

        einfo "Fixing the session-wrapper variable in lightdm.conf"
        sed -i -e \
                "/session-wrapper/s@^.*@session-wrapper=/etc/${PN}/Xsession@" \
                data/lightdm.conf || die "Failed to fix lightdm.conf"

        epatch_user

        # Remove bogus Makefile statement. This needs to go upstream
        sed -i /"@YELP_HELP_RULES@"/d help/Makefile.am || die
        if has_version dev-libs/gobject-introspection; then
                eautoreconf
        else
                AT_M4DIR=${WORKDIR} eautoreconf
        fi
}

src_configure() {
        # Set default values if global vars unset
        local _greeter _session _user
        _greeter=${LIGHTDM_GREETER:=lightdm-gtk-greeter}
        _session=${LIGHTDM_SESSION:=gnome}
        _user=${LIGHTDM_USER:=root}
        # Let user know how lightdm is configured
        einfo "Gentoo configuration"
        einfo "Default greeter: ${_greeter}"
        einfo "Default session: ${_session}"
        einfo "Greeter user: ${_user}"

        # also disable tests because libsystem.c does not build. Tests are
        # restricted so it does not matter anyway.
        econf \
                --localstatedir=/var \
                --disable-static \
                --disable-tests \
                $(use_enable introspection) \
                $(use_enable qt4 liblightdm-qt) \
                --disable-liblightdm-qt5 \
                --with-user-session=${_session} \
                --with-greeter-session=${_greeter} \
                --with-greeter-user=${_user} \
                --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
}

src_install() {
        default

        # Delete apparmor profiles because they only work with Ubuntu's
        # apparmor package. Bug #494426
        if [[ -d ${D}/etc/apparmor.d ]]; then
                rm -r "${D}/etc/apparmor.d" || die \
                        "Failed to remove apparmor profiles"
        fi

        insinto /etc/${PN}
        doins data/{${PN},keys}.conf
        doins "${FILESDIR}"/Xsession
        fperms +x /etc/${PN}/Xsession

        prune_libtool_files --all
        rm -rf "${ED}"/etc/init

        pamd_mimic system-local-login ${PN} auth account session #372229
        dopamd "${FILESDIR}"/${PN}-autologin #390863, #423163

        readme.gentoo_create_doc

        systemd_dounit "${FILESDIR}/${PN}.service"
}



1.1                  x11-misc/lightdm/lightdm-1.13.2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-misc/lightdm/lightdm-1.13.2.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-misc/lightdm/lightdm-1.13.2.ebuild?rev=1.1&content-type=text/plain

Index: lightdm-1.13.2.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/x11-misc/lightdm/lightdm-1.13.2.ebuild,v 1.1 
2015/03/17 20:37:44 hwoarang Exp $

EAPI=5
inherit autotools eutils pam readme.gentoo systemd versionator

TRUNK_VERSION="$(get_version_component_range 1-2)"
DESCRIPTION="A lightweight display manager"
HOMEPAGE="http://www.freedesktop.org/wiki/Software/LightDM";
SRC_URI="http://launchpad.net/${PN}/${TRUNK_VERSION}/${PV}/+download/${P}.tar.xz
        mirror://gentoo/introspection-20110205.m4.tar.bz2"

LICENSE="GPL-3 LGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~x86"
IUSE="+gtk +introspection kde qt4 +gnome"
REQUIRED_USE="|| ( gtk kde )"

COMMON_DEPEND=">=dev-libs/glib-2.32.3:2
        dev-libs/libxml2
        gnome? ( sys-apps/accountsservice )
        virtual/pam
        x11-libs/libX11
        >=x11-libs/libxklavier-5
        introspection? ( >=dev-libs/gobject-introspection-1 )
        qt4? (
                dev-qt/qtcore:4
                dev-qt/qtdbus:4
                dev-qt/qtgui:4
                )"
RDEPEND="${COMMON_DEPEND}
        >=sys-auth/pambase-20101024-r2"
DEPEND="${COMMON_DEPEND}
        dev-util/gtk-doc-am
        dev-util/intltool
        gnome? ( gnome-base/gnome-common )
        sys-devel/gettext
        virtual/pkgconfig"
PDEPEND="gtk? ( x11-misc/lightdm-gtk-greeter )
        kde? ( x11-misc/lightdm-kde )"

DOCS=( NEWS )
RESTRICT="test"

src_prepare() {
        sed -i -e 's:getgroups:lightdm_&:' tests/src/libsystem.c || die #412369
        sed -i -e '/minimum-uid/s:500:1000:' data/users.conf || die

        einfo "Fixing the session-wrapper variable in lightdm.conf"
        sed -i -e \
                "/session-wrapper/s@^.*@session-wrapper=/etc/${PN}/Xsession@" \
                data/lightdm.conf || die "Failed to fix lightdm.conf"

        epatch_user

        # Remove bogus Makefile statement. This needs to go upstream
        sed -i /"@YELP_HELP_RULES@"/d help/Makefile.am || die
        if has_version dev-libs/gobject-introspection; then
                eautoreconf
        else
                AT_M4DIR=${WORKDIR} eautoreconf
        fi
}

src_configure() {
        # Set default values if global vars unset
        local _greeter _session _user
        _greeter=${LIGHTDM_GREETER:=lightdm-gtk-greeter}
        _session=${LIGHTDM_SESSION:=gnome}
        _user=${LIGHTDM_USER:=root}
        # Let user know how lightdm is configured
        einfo "Gentoo configuration"
        einfo "Default greeter: ${_greeter}"
        einfo "Default session: ${_session}"
        einfo "Greeter user: ${_user}"

        # also disable tests because libsystem.c does not build. Tests are
        # restricted so it does not matter anyway.
        econf \
                --localstatedir=/var \
                --disable-static \
                --disable-tests \
                $(use_enable introspection) \
                $(use_enable qt4 liblightdm-qt) \
                --disable-liblightdm-qt5 \
                --with-user-session=${_session} \
                --with-greeter-session=${_greeter} \
                --with-greeter-user=${_user} \
                --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
}

src_install() {
        default

        # Delete apparmor profiles because they only work with Ubuntu's
        # apparmor package. Bug #494426
        if [[ -d ${D}/etc/apparmor.d ]]; then
                rm -r "${D}/etc/apparmor.d" || die \
                        "Failed to remove apparmor profiles"
        fi

        insinto /etc/${PN}
        doins data/{${PN},keys}.conf
        doins "${FILESDIR}"/Xsession
        fperms +x /etc/${PN}/Xsession
        # /var/lib/lightdm-data could be useful. Bug #522228
        dodir /var/lib/lightdm-data

        prune_libtool_files --all
        rm -rf "${ED}"/etc/init

        # Remove existing pam file. We will build a new one. Bug #524792
        rm -rf "${ED}"/etc/pam.d/${PN}{,-greeter}
        pamd_mimic system-local-login ${PN} auth account password session 
#372229
        pamd_mimic system-local-login ${PN}-greeter auth account password 
session #372229
        dopamd "${FILESDIR}"/${PN}-autologin #390863, #423163

        readme.gentoo_create_doc

        systemd_dounit "${FILESDIR}/${PN}.service"
}



1.1                  x11-misc/lightdm/lightdm-1.12.3.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-misc/lightdm/lightdm-1.12.3.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-misc/lightdm/lightdm-1.12.3.ebuild?rev=1.1&content-type=text/plain

Index: lightdm-1.12.3.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/x11-misc/lightdm/lightdm-1.12.3.ebuild,v 1.1 
2015/03/17 20:37:44 hwoarang Exp $

EAPI=5
inherit autotools eutils pam readme.gentoo systemd versionator

TRUNK_VERSION="$(get_version_component_range 1-2)"
DESCRIPTION="A lightweight display manager"
HOMEPAGE="http://www.freedesktop.org/wiki/Software/LightDM";
SRC_URI="http://launchpad.net/${PN}/${TRUNK_VERSION}/${PV}/+download/${P}.tar.xz
        mirror://gentoo/introspection-20110205.m4.tar.bz2"

LICENSE="GPL-3 LGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
IUSE="+gtk +introspection kde qt4"
REQUIRED_USE="|| ( gtk kde )"

COMMON_DEPEND=">=dev-libs/glib-2.32.3:2
        dev-libs/libxml2
        sys-apps/accountsservice
        virtual/pam
        x11-libs/libX11
        >=x11-libs/libxklavier-5
        introspection? ( >=dev-libs/gobject-introspection-1 )
        qt4? (
                dev-qt/qtcore:4
                dev-qt/qtdbus:4
                dev-qt/qtgui:4
                )"
RDEPEND="${COMMON_DEPEND}
        >=sys-auth/pambase-20101024-r2"
DEPEND="${COMMON_DEPEND}
        dev-util/gtk-doc-am
        dev-util/intltool
        gnome-base/gnome-common
        sys-devel/gettext
        virtual/pkgconfig"
PDEPEND="gtk? ( x11-misc/lightdm-gtk-greeter )
        kde? ( x11-misc/lightdm-kde )"

DOCS=( NEWS )
RESTRICT="test"

src_prepare() {
        sed -i -e 's:getgroups:lightdm_&:' tests/src/libsystem.c || die #412369
        sed -i -e '/minimum-uid/s:500:1000:' data/users.conf || die

        einfo "Fixing the session-wrapper variable in lightdm.conf"
        sed -i -e \
                "/session-wrapper/s@^.*@session-wrapper=/etc/${PN}/Xsession@" \
                data/lightdm.conf || die "Failed to fix lightdm.conf"

        epatch_user

        # Remove bogus Makefile statement. This needs to go upstream
        sed -i /"@YELP_HELP_RULES@"/d help/Makefile.am || die
        if has_version dev-libs/gobject-introspection; then
                eautoreconf
        else
                AT_M4DIR=${WORKDIR} eautoreconf
        fi
}

src_configure() {
        # Set default values if global vars unset
        local _greeter _session _user
        _greeter=${LIGHTDM_GREETER:=lightdm-gtk-greeter}
        _session=${LIGHTDM_SESSION:=gnome}
        _user=${LIGHTDM_USER:=root}
        # Let user know how lightdm is configured
        einfo "Gentoo configuration"
        einfo "Default greeter: ${_greeter}"
        einfo "Default session: ${_session}"
        einfo "Greeter user: ${_user}"

        # also disable tests because libsystem.c does not build. Tests are
        # restricted so it does not matter anyway.
        econf \
                --localstatedir=/var \
                --disable-static \
                --disable-tests \
                $(use_enable introspection) \
                $(use_enable qt4 liblightdm-qt) \
                --disable-liblightdm-qt5 \
                --with-user-session=${_session} \
                --with-greeter-session=${_greeter} \
                --with-greeter-user=${_user} \
                --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
}

src_install() {
        default

        # Delete apparmor profiles because they only work with Ubuntu's
        # apparmor package. Bug #494426
        if [[ -d ${D}/etc/apparmor.d ]]; then
                rm -r "${D}/etc/apparmor.d" || die \
                        "Failed to remove apparmor profiles"
        fi

        insinto /etc/${PN}
        doins data/{${PN},keys}.conf
        doins "${FILESDIR}"/Xsession
        fperms +x /etc/${PN}/Xsession
        # /var/lib/lightdm-data could be useful. Bug #522228
        dodir /var/lib/lightdm-data

        prune_libtool_files --all
        rm -rf "${ED}"/etc/init

        pamd_mimic system-local-login ${PN} auth account session #372229
        dopamd "${FILESDIR}"/${PN}-autologin #390863, #423163

        readme.gentoo_create_doc

        systemd_dounit "${FILESDIR}/${PN}.service"
}




Reply via email to