tetromino    15/03/18 15:04:10

  Modified:             ChangeLog
  Added:                gnome-themes-standard-3.14.2.3-r1.ebuild
  Log:
  Add multilib support.
  
  (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 
0x18E5B6F2D8D5EC8D)

Revision  Changes    Path
1.78                 x11-themes/gnome-themes-standard/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-themes/gnome-themes-standard/ChangeLog?rev=1.78&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-themes/gnome-themes-standard/ChangeLog?rev=1.78&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-themes/gnome-themes-standard/ChangeLog?r1=1.77&r2=1.78

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/x11-themes/gnome-themes-standard/ChangeLog,v
retrieving revision 1.77
retrieving revision 1.78
diff -u -r1.77 -r1.78
--- ChangeLog   15 Mar 2015 13:34:44 -0000      1.77
+++ ChangeLog   18 Mar 2015 15:04:10 -0000      1.78
@@ -1,6 +1,12 @@
 # ChangeLog for x11-themes/gnome-themes-standard
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: 
/var/cvsroot/gentoo-x86/x11-themes/gnome-themes-standard/ChangeLog,v 1.77 
2015/03/15 13:34:44 pacho Exp $
+# $Header: 
/var/cvsroot/gentoo-x86/x11-themes/gnome-themes-standard/ChangeLog,v 1.78 
2015/03/18 15:04:10 tetromino Exp $
+
+*gnome-themes-standard-3.14.2.3-r1 (18 Mar 2015)
+
+  18 Mar 2015; Alexandre Rostovtsev <tetrom...@gentoo.org>
+  +gnome-themes-standard-3.14.2.3-r1.ebuild:
+  Add multilib support.
 
   15 Mar 2015; Pacho Ramos <pa...@gentoo.org>
   gnome-themes-standard-3.14.2.3.ebuild:



1.1                  
x11-themes/gnome-themes-standard/gnome-themes-standard-3.14.2.3-r1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-themes/gnome-themes-standard/gnome-themes-standard-3.14.2.3-r1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-themes/gnome-themes-standard/gnome-themes-standard-3.14.2.3-r1.ebuild?rev=1.1&content-type=text/plain

Index: gnome-themes-standard-3.14.2.3-r1.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/x11-themes/gnome-themes-standard/gnome-themes-standard-3.14.2.3-r1.ebuild,v
 1.1 2015/03/18 15:04:10 tetromino Exp $

EAPI="5"
GCONF_DEBUG="no"
GNOME2_LA_PUNT="yes"

inherit eutils gnome2 multilib-minimal

DESCRIPTION="Standard Themes for GNOME Applications"
HOMEPAGE="https://git.gnome.org/browse/gnome-themes-standard/";

LICENSE="LGPL-2.1+"
SLOT="0"
IUSE="+gtk"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 
~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux 
~x64-solaris ~x86-solaris"

COMMON_DEPEND="
        gnome-base/librsvg:2[${MULTILIB_USEDEP}]
        x11-libs/cairo[${MULTILIB_USEDEP}]
        gtk? (
                >=x11-libs/gtk+-2.24.15:2[${MULTILIB_USEDEP}]
                >=x11-libs/gtk+-3.12:3[${MULTILIB_USEDEP}] )
"
DEPEND="${COMMON_DEPEND}
        >=dev-util/intltool-0.40
        sys-devel/gettext
        virtual/pkgconfig
"
# gnome-themes{,-extras} are OBSOLETE for GNOME 3
# http://comments.gmane.org/gmane.comp.gnome.desktop/44130
# Depend on gsettings-desktop-schemas-3.4 to make sure 3.2 users don't lose
# their default background image
RDEPEND="${COMMON_DEPEND}
        >=gnome-base/gsettings-desktop-schemas-3.4
        !<x11-themes/gnome-themes-2.32.1-r1
"

multilib_src_configure() {
        # The icon cache needs to be generated in pkg_postinst()
        ECONF_SOURCE="${S}" \
        gnome2_src_configure \
                --disable-static \
                $(use_enable gtk gtk2-engine) \
                $(use_enable gtk gtk3-engine) \
                GTK_UPDATE_ICON_CACHE=$(type -P true)
}

emake_engines_only() {
        pushd themes/Adwaita/gtk-2.0 > /dev/null || die
        if [[ $1 = install ]]; then
                emake DESTDIR="${D}" install-engineLTLIBRARIES
        else
                emake libadwaita.la
        fi
        popd > /dev/null
}

multilib_src_compile() {
        # processing >3500 icons is slow on old hard drives, do it only for 
native ABI
        if multilib_is_native_abi; then
                gnome2_src_compile
        else
                emake_engines_only
        fi
}

multilib_src_install() {
        # processing >3500 icons is slow on old hard drives, do it only for 
native ABI
        if multilib_is_native_abi; then
                gnome2_src_install
        else
                emake_engines_only install
                prune_libtool_files --modules
        fi
}




Reply via email to