Re: [gentoo-dev] [PATCH v2 1/1] edo.eclass: add new eclass

2022-04-16 Thread Ionen Wolkens
On Sat, Apr 16, 2022 at 08:50:46PM -0400, Ionen Wolkens wrote: > e.g. if using edo to replace stuff like > # ./configure is not real autoconf! > local cmd=( > ./configure > --args > ${EXTRA_ECONF} > ) > echo ${cmd[*]}" > "${cmd[@]}" || die "cmd failed:

Re: [gentoo-dev] [PATCH v2 1/1] edo.eclass: add new eclass

2022-04-16 Thread Ionen Wolkens
On Sat, Apr 16, 2022 at 08:21:34PM +0200, Michał Górny wrote: > > +# @USAGE: [...] > > +# @DESCRIPTION: > > +# Executes 'command' with any given arguments and exits on failure unless > > +# called under 'nonfatal'. > > +edo() { > > + elog "$@" > > einfo? Way I see it, this could've even been

Re: [gentoo-dev] [PATCH] gnuconfig.eclass: fix eend w/o ebegin

2022-04-16 Thread Mike Gilbert
On Sat, Apr 16, 2022 at 2:28 AM Sam James wrote: > > eend should be preceded by an begin call. Looks ok.

Re: [gentoo-dev] [PATCH v2 1/1] edo.eclass: add new eclass

2022-04-16 Thread Michał Górny
On Sat, 2022-04-16 at 19:14 +0100, Sam James wrote: > Bug: https://bugs.gentoo.org/744880 > Signed-off-by: Sam James > --- > eclass/edo.eclass | 46 ++ > 1 file changed, 46 insertions(+) > create mode 100644 eclass/edo.eclass > > diff --git

[gentoo-dev] [PATCH v2 0/1] Add edo.eclass

2022-04-16 Thread Sam James
Changes since v1: - Add EAPI 7 support (useful for e.g. base-system@ ebuilds) - Add 'edob' (edo with ebegin/eend for better logs log-running commands, UX) Sam James (1): edo.eclass: add new eclass eclass/edo.eclass | 46 ++ 1 file changed, 46

[gentoo-dev] [PATCH v2 1/1] edo.eclass: add new eclass

2022-04-16 Thread Sam James
Bug: https://bugs.gentoo.org/744880 Signed-off-by: Sam James --- eclass/edo.eclass | 46 ++ 1 file changed, 46 insertions(+) create mode 100644 eclass/edo.eclass diff --git a/eclass/edo.eclass b/eclass/edo.eclass new file mode 100644 index

Re: [gentoo-dev] Re: [PATCH 1/1] edo.eclass: add new eclass

2022-04-16 Thread Ulrich Mueller
> On Sat, 16 Apr 2022, Florian Schmaus wrote: >> edobe() { > nit: I'd personally would use 'edob', as shorter is sometimes better > plus every begin needs an end, so no need to explicitly state that > there is an end. It's even more obscure as a name however. :) >> ebegin "Running $@"

Re: [gentoo-dev] Re: [PATCH 1/1] edo.eclass: add new eclass

2022-04-16 Thread Ionen Wolkens
On Sat, Apr 16, 2022 at 06:48:56AM -0400, Ionen Wolkens wrote: > On Sat, Apr 16, 2022 at 12:23:18PM +0200, Florian Schmaus wrote: > > > ebegin "Running $@" > > > "$@" > > > eend $? || die -n "$@ failed" > return $? > > > > I think this return statement can be omitted since it

Re: [gentoo-dev] Re: [PATCH 1/1] edo.eclass: add new eclass

2022-04-16 Thread Ionen Wolkens
On Sat, Apr 16, 2022 at 12:23:18PM +0200, Florian Schmaus wrote: > > ebegin "Running $@" > > "$@" > > eend $? || die -n "$@ failed" > return $? > > I think this return statement can be omitted since it will always be > invoked with 0 as argument, and this is the default

Re: [gentoo-dev] Re: [PATCH 1/1] edo.eclass: add new eclass

2022-04-16 Thread Florian Schmaus
On 16/04/2022 10.38, Ulrich Mueller wrote: On Sat, 16 Apr 2022, Sam James wrote: +# @FUNCTION: edo Just a remark: A similar command existed a long time ago under the name "try". [1] It was executed under "env" [2], should we also do that? +# @USAGE: command [arg1 [arg2 ...]] should be

[gentoo-dev] Re: [PATCH 1/1] edo.eclass: add new eclass

2022-04-16 Thread Ulrich Mueller
> On Sat, 16 Apr 2022, Sam James wrote: > +# @FUNCTION: edo Just a remark: A similar command existed a long time ago under the name "try". [1] It was executed under "env" [2], should we also do that? > +# @USAGE: command [arg1 [arg2 ...]] should be in angle brackets, if we follow the

[gentoo-dev] [PATCH] gnuconfig.eclass: fix eend w/o ebegin

2022-04-16 Thread Sam James
eend should be preceded by an begin call. Signed-off-by: Sam James --- eclass/gnuconfig.eclass | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/eclass/gnuconfig.eclass b/eclass/gnuconfig.eclass index 58bdcfd660a6b..0791798632cdb 100644 --- a/eclass/gnuconfig.eclass +++

[gentoo-dev] [PATCH 1/1] edo.eclass: add new eclass

2022-04-16 Thread Sam James
Bug: https://bugs.gentoo.org/744880 Signed-off-by: Sam James --- eclass/edo.eclass | 34 ++ 1 file changed, 34 insertions(+) create mode 100644 eclass/edo.eclass diff --git a/eclass/edo.eclass b/eclass/edo.eclass new file mode 100644 index

[gentoo-dev] [PATCH 0/1] Add edo.eclass

2022-04-16 Thread Sam James
Intended as a discussion starter after recent discussions in #gentoo-dev. I don't necc. expect this to be the final implementation at all, but it's often helpful to have something concrete to discuss & iterate on. I think the need for this is pretty strong in sci-*/* ebuilds which tend to need