Hi.

Guys, please, cleanup ebuids with version bumps!

Also Patrick, if you use this software or at least investigated it
during version bump, why it is still maintainer-wanted? Although
everything below makes me think that this was blind bump.

В Пнд, 17/05/2010 в 18:41 +0000, Patrick Lauer (patrick) пишет:
> inherit eutils flag-o-matic autotools
> 
> TW_VER=${PV}

This substitution is unnecessary and tripwire-${TW_VER} everywhere below
is just ${P}.

> DESCRIPTION="Open Source File Integrity Checker and IDS"
> HOMEPAGE="http://www.tripwire.org/";
> SRC_URI="mirror://sourceforge/tripwire/tripwire-${TW_VER}-src.tar.bz2
>       mirror://gentoo/twpol.txt.gz
>       mirror://gentoo/tripwire.gif"
> 
> LICENSE="GPL-2"
> SLOT="0"
> KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
> IUSE="ssl static"
> 
> DEPEND="sys-devel/automake
>       sys-devel/autoconf

This depends ^^ should be handled by autotools eclass.

>       dev-util/patchutils
>       ssl? ( dev-libs/openssl )"
> RDEPEND="virtual/cron
>       virtual/mta
>       ssl? ( dev-libs/openssl )"
> 
> S="${WORKDIR}"/tripwire-${TW_VER}-src
> 
> src_prepare() {
>       eautoreconf || die "eautoreconf failed"

|| die is not necessary here. Is autoreconf really required (nothing
changed configure.ac/Makefile.am here).

> }
> 
> src_configure() {
>       # tripwire can be sensitive to compiler optimisation.
>       # see #32613, #45823, and others.
>       #       -tav...@gentoo.org

This developer was retired 2.5 years ago. Why do we need this comment?

>       strip-flags
>       append-flags -DCONFIG_DIR='"\"/etc/tripwire\""' -fno-strict-aliasing
>       einfo "Done."

What is "Done." here?

>       chmod +x configure
>       econf $(use_enable ssl openssl) $(use_enable static)
> }
> 
> src_install() {
>       dosbin "${S}"/bin/{siggen,tripwire,twadmin,twprint}

Again || die should be here and in many other places ...

>       doman "${S}"/man/man{4/*.4,5/*.5,8/*.8}
>       dodir /etc/tripwire /var/lib/tripwire{,/report}
>       keepdir /var/lib/tripwire{,/report}
> 
>       exeinto /etc/cron.daily
>       doexe "${FILESDIR}"/tripwire.cron
> 
>       dodoc ChangeLog policy/policyguide.txt TRADEMARK \
>               "${FILESDIR}"/tripwire.txt
> 
>       insinto /etc/tripwire
>       doins "${WORKDIR}"/twpol.txt "${FILESDIR}"/twcfg.txt
> 
>       exeinto /etc/tripwire
>       doexe "${FILESDIR}"/twinstall.sh
> 
>       fperms 755 /etc/tripwire/twinstall.sh /etc/cron.daily/tripwire.cron
> }
> 
> pkg_postinst() {
>       elog "After installing this package, you should run 
> \"/etc/tripwire/twinstall.sh\""
>       elog "to generate cryptographic keys, and \"tripwire --init\" to 
> initialize the"
>       elog "database Tripwire uses."
>       elog
>       elog "A quickstart guide is included with the documentation."
>       elog
> }


-- 
Peter.


Reply via email to