RE: [gentoo-dev] New developer : Markus Duft (mduft)

2008-05-05 Thread Duft Markus
 
 On 2008-05-01 03:20, Duft Markus wrote:
  Hi!
 
  Just read the mail-archive and (i'm not at work), and felt that I
 have
  to say something about the binary packages on windows ;) (so sorry
 for
  what the outlook web-access thingy does to emails and threads :))
 
 Have you seen this?:
 http://home.in.tum.de/~jain/software/outlook-quotefix/

Yeah thanks, i used to use this one. But (of course) it doesn't work
with the web-interface, and since a few days i'm running outlook 2007,
with which it - grml - doesn't work neither. Still with the real outlook
i managed to at least get it to quote with  ;)

Cheers, Markus

 
 --
 gentoo-dev@lists.gentoo.org mailing list

--
gentoo-dev@lists.gentoo.org mailing list



[gentoo-dev] RFC: qemu - add gcc-3.x dependency

2008-05-05 Thread Enrico Weigelt

Hi folks,


I'm just installing qemu, which requires gcc-3.x for building. 
The current breaks are very ugly, IMHO. 

So I'm proposing to add the old gcc-3.x as depedency to qemu,
at least as long as it doesn't build w/ newer gcc. 

What do you think about this ?


cu
-- 
-
 Enrico Weigelt==   metux IT service - http://www.metux.de/
-
 Please visit the OpenSource QM Taskforce:
http://wiki.metux.de/public/OpenSource_QM_Taskforce
 Patches / Fixes for a lot dozens of packages in dozens of versions:
http://patches.metux.de/
-
-- 
gentoo-dev@lists.gentoo.org mailing list



[gentoo-dev] Re: New developer : Markus Duft (mduft)

2008-05-05 Thread Duncan
Duft Markus [EMAIL PROTECTED] posted
[EMAIL PROTECTED], excerpted
below, on  Mon, 05 May 2008 08:51:42 +0200:

 On 2008-05-01 03:20, Duft Markus wrote:
 
  (so sorry for what the outlook web-access
  thingy does to emails and threads :))
 
 Have you seen http://home.in.tum.de/~jain/software/outlook-quotefix/
 
 Yeah thanks, i used to use this one. But (of course) it doesn't work
 with the web-interface, and since a few days i'm running outlook 2007,
 with which it - grml - doesn't work neither. Still with the real outlook
 i managed to at least get it to quote with  ;)

I wonder if there's a greasemonkey script or the like for the
OL web interface.  Or a privoxy/proxomitron/whatever filter.

I know I use a custom privoxy filter to help enforce my 
light-text-on-dark-background browsing preferences without
killing color entirely, to reasonably good effect by now as I've
been making incremental filter improvements for several years,
so it's certainly possible to do such things.  It's likely just a
matter of finding the person who has developed an appropriate script.

-- 
Duncan - List replies preferred.   No HTML msgs.
Every nonfree program has a lord, a master --
and if you use the program, he is your master.  Richard Stallman

-- 
gentoo-dev@lists.gentoo.org mailing list



Re: [gentoo-dev] RFC: qemu - add gcc-3.x dependency

2008-05-05 Thread Peter Volkov
В Вск, 04/05/2008 в 21:48 +0200, Enrico Weigelt пишет:
 I'm just installing qemu, which requires gcc-3.x for building. 
 The current breaks are very ugly, IMHO. 
 
 So I'm proposing to add the old gcc-3.x as depedency to qemu,
 at least as long as it doesn't build w/ newer gcc. 
 
 What do you think about this ?

How do you suppose to change gcc version portage uses on-the-fly?
Please, answer trough bugzilla where most bug reports/feature requests
should normally go.

-- 
Peter.


signature.asc
Description: Эта	 часть	 сообщения	 подписана	 цифровой	 подписью


Re: [gentoo-dev] RFC: qemu - add gcc-3.x dependency

2008-05-05 Thread Jan Kundrát

Enrico Weigelt wrote:
I'm just installing qemu, which requires gcc-3.x for building. 
The current breaks are very ugly, IMHO. 


So I'm proposing to add the old gcc-3.x as depedency to qemu,
at least as long as it doesn't build w/ newer gcc. 


Hi Enrico, it is usually a good idea to search through the Bugzilla 
before asking for some feature, chances are that it has been already 
requested (in this case, you're looking for bug 190102). FYI, at least 
some of qemu's features were ported to gcc4 -- for example, see the 
kvm-qemu ebuild from bug 157987.


Cheers,
-jkt

--
cd /local/pub  more beer  /dev/mouth
--
gentoo-dev@lists.gentoo.org mailing list



Re: [gentoo-dev] RFC: qemu - add gcc-3.x dependency

2008-05-05 Thread Enrico Weigelt
* Peter Volkov [EMAIL PROTECTED] schrieb:
 ?? ??, 04/05/2008 ?? 21:48 +0200, Enrico Weigelt ??:
  I'm just installing qemu, which requires gcc-3.x for building. 
  The current breaks are very ugly, IMHO. 
  
  So I'm proposing to add the old gcc-3.x as depedency to qemu,
  at least as long as it doesn't build w/ newer gcc. 
  
  What do you think about this ?
 
 How do you suppose to change gcc version portage uses on-the-fly?

* add an small gcc3-wrapper script/symlink (eg. /usr/bin/gcc-3)
* rewrite the qemu ebuild to properly set $CC, etc.

 Please, answer trough bugzilla where most bug reports/feature requests
 should normally go.

Is there already an open bug on this ?


BTW: even with gcc-3.x qemu fails to build. this has been reported
multiple times, but none of the suggestions worked :(


cu
-- 
-
 Enrico Weigelt==   metux IT service - http://www.metux.de/
-
 Please visit the OpenSource QM Taskforce:
http://wiki.metux.de/public/OpenSource_QM_Taskforce
 Patches / Fixes for a lot dozens of packages in dozens of versions:
http://patches.metux.de/
-
-- 
gentoo-dev@lists.gentoo.org mailing list



Re: [gentoo-dev] RFC: qemu - add gcc-3.x dependency

2008-05-05 Thread Alon Bar-Lev
On 5/5/08, Jan Kundrát [EMAIL PROTECTED] wrote:
  Hi Enrico, it is usually a good idea to search through the Bugzilla before
 asking for some feature, chances are that it has been already requested (in
 this case, you're looking for bug 190102). FYI, at least some of qemu's
 features were ported to gcc4 -- for example, see the kvm-qemu ebuild from
 bug 157987.

I also waiting for gcc-4 enabled qemu for long time...
The problem that emerge --emptytree world will not work when
packages are compiled in different gcc versions.
The kvm-qemu is not relevant if you don't have the hardware.

One solution I saw is to compile gcc-3 as part of the qemu build
process, and make the qemu use this gcc-3 instance. This way you can
have qemu up and running while the system is configured for gcc-4.

It is very disappointing that upstream does not allow gcc-4
configuration so long after gcc-4 release.

Alon.


Re: [gentoo-dev] RFC: qemu - add gcc-3.x dependency

2008-05-05 Thread Matthias Schwarzott
On Montag, 5. Mai 2008, Peter Volkov wrote:
 В Вск, 04/05/2008 в 21:48 +0200, Enrico Weigelt пишет:
  I'm just installing qemu, which requires gcc-3.x for building.
  The current breaks are very ugly, IMHO.
 
  So I'm proposing to add the old gcc-3.x as depedency to qemu,
  at least as long as it doesn't build w/ newer gcc.
 
  What do you think about this ?

 How do you suppose to change gcc version portage uses on-the-fly?
 Please, answer trough bugzilla where most bug reports/feature requests
 should normally go.

I suggest something like this:
Get correct path of gcc-3 executable, then supply this with $CC to make.


Code may look like this:

# get last one of sorted list
for t in $(ls -1 /usr/bin/gcc-3*|sort); do
p=$t
done
einfo Using $p for compiling.
emake CC=$p

Matthias
--
gentoo-dev@lists.gentoo.org mailing list



[gentoo-dev] lastrite: sys-process/daemontools-scripts

2008-05-05 Thread Samuli Suominen
# Samuli Suominen [EMAIL PROTECTED] (05 May 2008)
# Masked for removal by treecleaners wrt bug 212331
# As requested by base-system. Gone in 30 days.
sys-process/daemontools-scripts
-- 
gentoo-dev@lists.gentoo.org mailing list